Arch Linux. Executable closes immediately upon opening

This is now a problem again, since the rest of Arch now crashes w/o updated freetype :frowning:

Looks like in Arch, after today’s update, doing a regression on freetype now crashes X entirely. So now downgrading both libraries is no longer safe to do and EVE won’t launch at all.

UPDATE: After installing downgrader from the AUR and using it on lib32-freetype2 and freetype2 the game now launches fine and X is still maintaining stability.

downgrader -a lib32-freetype2
downgrader -a freetype2
1 Like

I’m on Archlinux, I tried what Gellian Corde said and if I downgrade lib32-freetype2 and freetype2 the launcher doesn’t even start . If they are up to date the client closes immediatly after start. Right now i uningnored lib32-freetype2 and freetype2 from being updated and waiting for a magical update to fix it.

What’s the output you’re getting when the launcher doesn’t load at all. It sounds like there’s something else besides the libfreetype issue.

Here is what I get :
/home/vilya/evelauncher/evelauncher: symbol lookup error: /usr/lib/ undefined symbol: FT_Done_MM_Var
This is actually the same issue when I downgrade them and reboot, X doesn’t start and I have this issue when rebooting.

Temp fix:

1)downgrade harfbuzz using:
sudo pacman -U /var/cache/pacman/pkg/harfbuzz-1.7.4-1-x86_64.pkg.tar



3)then downgrade freetype as before, see above.

Game should work again, x should start as normal.

The game works perfectly again by following Kc Decartes’ steps, thank you sir. You were the kind of magical fix I was hoping for :smiley:

1 Like

For anyone having the freetype issue and who is unable (or unwilling) to downgrade, EVE works just fine with the most recent Wine standard on archlinux (3.1 at the moment).

Assuming you already have wine installed (pacman -S wine), do the following:
(1) install winetricks ( pacman -S winetricks )
(2) create a new eve-specific win32 wineprefix by running in a terminal

export WINEARCH=win32
export WINEPREFIX=~/.evewine

(3) in winecfg set the windows version to windows xp
(4) still in winecfg disable directx 11 by going to libraries and adding d3d11 , then modifying and disabling it
(5) use winetricks to install stuff:

winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010 vcrun2015

(6) create a bash shell to use as the custom wine version in the launcher (to set the correct WINEPREFIX!)

echo '#!/bin/bash' >
echo 'WINEPREFIX=~/.evewine wine $*' >>
chmod +x ~/

(7) If you need your settings, I believe you can copy them from the ‘official’ CCP wineprefix in .eve/wineenv (possibly .eve/wineenv/drive_c/users//Local Settings/Application Data/CCP/EVE ). I have not been able to test this, however.
(8) Finally launch your already installed eve launcher, go to settings and select “use custom wine”, then enter the full path to the script there.

Login and play… It should just work. :sunglasses:


Thanks a lot for this! It works! Even the copying of settings :slight_smile:

Thanks Zone Mirendir!
I will only reiterate that I had to write the absolute path ‘/home/user/’ in the settings for my custom wine to be recognized. It did not understand ‘~/’. Hopefully this saves someone a few minutes.
Feels good to finally upgrade Freetype2 after many months, haha.

So the only thing that worked for me was downgrading freetype2, but when I do that my system doesn’t boot (real talk lol) unless I upgrade them back. Zone’s custom-wine did not work for me either sadly. Any other suggestions guys? I’m on Arch

scroll up/read my friend…

Temp fix:

1)downgrade harfbuzz using:
sudo pacman -U /var/cache/pacman/pkg/harfbuzz-1.7.4-1-x86_64.pkg.tar



3)then downgrade freetype as before, see above.

Game should work again, x should start as normal.


Hmm, I’d be curious to know why wine 3.1 on archlinux is not working for you.

The only obvious thing I can think of is maybe you did not run the winetricks command in the same terminal as the export WINEPREFIX command?

When you edit ~/ do you see this:

WINEPREFIX=~/.evewine wine $*

What happens when you try to run the client? Does it open up and crash or does it not open up at all?

It didn’t open up at all, my launcher seems to have fixed itself without the need to downgrade or anything now. Not sure how or why but I’m not complaining. If you want I can still help you figure out why your method isn’t working just so you know what to do in-case someone else runs into the same issue.

I confirm that this is working the only thing is I needed to create file manually and edit it and write the commands line by line. This is because copy and paste seems to erase $* or while copying the number 5 snaps to the commands.
So open a file named
Edit it
Place the following code in it:

WINEPREFIX=~/.evewine wine $*

Then save and exit.
Then use the following command to make the file executable
chmod +x
You may put file wherever you want but use the exact location of the file with an absolute path in the custom wine settings in the launcher such that

Thank you @Zone Mirendir

This also works in Debian Sid. THANKS!!!

Created a custom wine & startup script.

Thanks for this great information! I haven’t played EVE in a long time, and decided I wanted to at least get it working again. Your instructions got it working again for me on Arch.

The only thing I have a problem with now is the screen will stay black (except for my mouse) after I dock.

With regards to copying over settings, I had to do a little bit of work. My old environment had these files:

~/.eve/wineenv/drive_c/users/{username}/Local Settings/Application Data/CCP/EVE:

I copied those files over to the new environment (~/.evewine), but after starting the launcher using the custom script it didn’t work. I noticed that in the new environment there was a different folder than c_tq_tranquility, named z_home_{username}_.eve_wineenv_drive_c_tq_tranquility. I renamed the old c_tq_tranquility folder to this new one, and all the settings were preserved.

For those who are blind like me, in order to set custom wine version, the ‘settings’ you need to go to are not found via the big ‘open settings’ button, but rather by clicking the obscure ‘E’ icon in the top right, and going to settings.

1 Like

Well, I’m glad to see I’m not just going nuts, and it’s such a weird issue to describe. Only when clicking on the 3D background to move the camera does it crash. Log doesn’t seem to fire on the crash. I couldn’t find a dump either. I’m running Gentoo so was just going to rollback to 2.7, but the oldest freetype ebuild available now is 2.8. Any word on the Linux version from these forums being updated? I was trying not to build Wine just for EVE since don’t use it for anything else.