Cannot add multiple accounts to launcher for SISI server

This morning when I went to log into Sisi, none of my remembered accounts were listed. There were red message boxes along the right side of the launcher that said something like the authentication token for my accounts had expired. I began to re-add my accounts and started with username XXXXXX. After adding the username and password and checking the “Remember this account…” checkbox, I pressed “LOG IN”. I got the License Agreement Update window and there was an “ACCEPT” button and a “CANCEL” button showing at the bottom right of the window. I pressed “ACCEPT” and I was returned to the main launcher window with the account XXXXXX showing in the list.
I then went to add my second account “YYYYYY” by pressing “ADD ACCOUNT +”. I entered the username and password for the account, checked the “Remember this account…” checkbox and pressed “LOG IN”. I again got the License Agreement Update window but this time, there was only a “CANCEL” button. There is no way to move forward and add this account to the launcher. I thought maybe scrolling through the whole license text would help but no luck.
As I have been playing with this the past few hours, I have encountered a few different patterns of behavior. In some cases after pressing “ADD ACCOUNT +” I am presented with the License Agreement window before I am shown the window where I enter username and password. Once I click “LOG IN” I am shown the license screen again. In both cases, only a CANCEL button appears on the license window. Very rarely, and I cannot remember how to reproduce it, I am shown the License Agreement window with no buttons…neither “ACCEPT” nor “CANCEL” are present.
I have set the launcher to download everything, I have used the verify option for the shared cache. Online help says there is a “reset” option for the launcher but I am unable to find it.
My original account (XXXXXX) can access SISI successfully and all my TQ account data is fine - I just can’t add additional accounts onto Sisi.

EVE ONLINE SISI launcher error|690x482

1 Like

i have the same problem. i may add that if i remove 1st account and trying to add other one i still cant do it. there is no “accept” button.
other account adds no problem

workaround was found: on the AULA screen just hold TAB and “accept” button should apear after few seconds

1 Like

same here…


1 Like

I am having a very similar problem trying to log in with Steam. I am asked to re-accept the EULA, but when I do I am offered the username and password login window. The Steam account is not available for log in. This issue is preventing me from testing on singularity at all. At least you guys have one character you can test with… D:

Same here, all my accounts that aren’t originally from Steam work just fine, the steam account doesn’t work anymore.

1 Like

And… No response from the quality assurance team. Two posts, both describing an obviously related problem, and they can’t even respond, much less let us know if or when there might be a fix. Very disappointing.

None of my accounts are working on SiSi. I always get an “Invalid username/password” error but on TQ I have no issues. I even removed my accounts from TQ and re-added with the new password and had no issue, but SiSi returns the same error.

1 Like

Same here. Licence agreement loops when scrolling down and there’s no “accept” button at the bottom.

1 Like

same here, so will it be fixed?
or multiple accounts on test server are prohibited?

1 Like

workaround was found: on the AULA screen just hold TAB and “accept” button should apear after few seconds


Yay for fellow testers finding workarounds!! Unfortunately this workaround does not appear to help with the steam login issue that appears to be closely related. Holding down tab on the mis-sized username and password screen does reveal a Steam icon labeled “login with another service”. Unfortunately clicking this link does nothing, so I am still unable to login to singularity. When I saw that button I was sure you had solved my problem @Karimiri, I was very disappointed to discover the button is not functional.

thanks a lot, problem solved


i have the same problem. The following works for me.

1./ Do what Karimiri wrote:

workaround was found: on the AULA screen just hold TAB 30x and “accept” button should apear after few seconds

–> you get an error.

2./ Close EVE Client
3./ Start EVE Client again
3./ Add Again the same Account from step 1.
4./ now the new Account appears in the list.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.