Cannot install implants

I have bought new implants but cannot install - There is no option to inject ?

Do you have the appropriate cybernetics skill? Are you an alpha/omega clone? Some implants can’t be used by certain clone states. Do you already have an implant in the slot it is going to take?


Cyberntics lvl 5 omega account.

Come on man, we need info. What is the implant, what are the errors, what options do you see? No one can troubleshoot when they have no information to go off of.

If you already have an implant for the same slot installed, and are trying to ‘upgrade’, you have to first unplug (destroy) the installed implant to enable plug in for the new one.

Sorry - I have a Cybernetic Subprocessor - Basic for slot 4. I have nothing in slot 4.

When I right click on it - I do not get an option to inject (or install or anything). I have an Omega account, my Cybernetic skills are maxed. I Have tried going to another station.

I also have tried other implant for other vacant slots - with the same outcome. I just seem to have had the option removed. I have implants installed - but not in those slots.

I have come to a deadend.

Sounds like its time for a support ticket then.

1 Like

Not saying it will help, but here’s some more things you could try:

  • swap clones
  • plug in cheap implants (in other clone)
  • and unplug the cheap implant

Other than that, a support ticket is indeed a good idea.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.