[Connection / Download] Download of updates very slow then stopping

Hello everyone,

I am having severe connection issues with the EVE online resources hosted on AWS (cloudfront.net). The newest launcher update failes to download from server-13-225-27-61.cdg3.r.cloudfront.net. It starts with ~100 KByte/s, then goes down to 0 in about 1 minute. So effectively I am not able to play at the moment, because the update wont’t download any further at a certain point. tracerts going out to [xyz].cloudfront.net servers have a packet loss of ~50%.

I have also experienced a somewhat similar problem in the last few weeks with client updates (not launcher). In normal cases I had a downstream of ~60 MBit/s while downloading these patches. In the last few weeks it went down to somewhat around 10 MBit/s, but did finish at least.

My ISP is the german Telekom (Deutsche Telekom, DTAG). My DSL connection syncs with 63/10 MBit/s up/down, and I do get these bandwidth 100% on other sites or on any speedtest (speedtest.net, utrace.de).

Several router restarts to change IPs / routes does not do anything…

Is anyone experiencing the same issues?

I have the same problem here. I did a bunch of things but nothing worked yet. Also other connections and downloads are not affected - only downloading patches and launcher updates for EVE seems to be problematic (starting at 2,5 MB/s and sowing down to 130 KB/s).

ISP is also Deutsche Telekom with 100/40 MBit/s connection.

Updating looks like this right now… Speed goes down step by step
NeedforSpeedEveUpdate

So I somehow managed to download the updates an start the client, this took roughly 3 Minutes according to LogLite. After that the game runs perfectly fine. So there this something wrong with the AWS infrastructure or with the peering to its subnets.

This is a traceroute to resources.eveonline.com:

tracert -d -4 resouces.eveonline.com = dm794883twbxj.cloudfront.net [13.225.27.46]

1 1 ms 1 ms 1 ms 192.168.0.1
2 16 ms 9 ms 10 ms 62.155.243.206
3 10 ms 9 ms 10 ms 217.5.94.70
4 10 ms 9 ms 9 ms 217.5.94.70
5 16 ms 13 ms 13 ms 80.157.204.66
6 22 ms 22 ms 22 ms 213.200.119.214
7 18 ms 23 ms 19 ms 77.67.122.2
8 169 ms 169 ms * 52.93.16.136 ← AWS, 30% loss
9 175 ms * * 52.93.16.191 ← AWS, 60% loss
10 * * * Timeout
11 * * * Timeout
12 * * * Timeout
13 * * * Timeout
14 * * * Timeout
15 177 ms 177 ms 177 ms 13.225.27.46

I also tried another way for the downloader: i just wanted to download the launcher from EVE Online Client (Launcher) für Windows oder Mac herunterladen - there’s the same behavior with the download speed. Currently it takes me more than 1h for downloading 86 MB and therefore i cant play…
URL behind this is https://binaries.eveonline.com/EveLauncher-1878290.exe

It seems to me this is a routing/peering problem of the ISP. I tried other AWS hosted services and they all have the same issue:

  • everything from *.eveonline.com in the aws services
  • twitch.tv VODs < 1 Mbit downstram (oddly the live streams work fine)
  • the forums of the ISP itself (telekomhilf.telekom.de)

This all refers to cloudfront.net / AWS. At the same time I can run a download at full speed (50 MBit) from other non-AWS services.

@Phil_Rin Are you having the same issues with twitch.tv VODs? I have opened a thread on the Telekom forums: https://telekomhilft.telekom.de/t5/Telefonie-Internet/Massive-Verbindungsprobleme-mit-AWS-cloudfront-net-und-facebook/td-p/5045289 & https://telekomhilft.telekom.de/t5/Telefonie-Internet/Probleme-bei-Verbindungen-zu-Amazon-CloudFront/td-p/5043150/page/2

If the problem is within the AWS infrastructure, then the service providers (such as CCP) must file a ticket. We as normal users can’t do much here I think…

Yeah it’s really slow. I restarted the download for the launcher upgrade several times now and managed to get a connection up with ~5 MB/s. But it seems really random, if you’re able to download fast or stuck in that 20 KB/s connection.

EDIT: What also comes in my mind is the problem with disconneting from server in an unpredictable pattern. Maybe, the root-cause is somewhere located there as well.