Corrupted textures and upside-down world


(Kerono Thalmor) #1

Hi there! It’s been a while. I just came back and it would seem that a few things have changed. First off, I can run the game in DX11 mode, under wine, which is new. However regardless of the mode I’m running in I get corrupted textures on planets, and things that play videos (billboards, and those annoying gadgets in the stations), for a fraction of a second, flash their frame in the lower left corner of my screen. Incidentally, the new map shows in its default window, but shows a non-interactive copy of the 3D portion in the lower left.

Among the new things, as well, is that when I log in, the world is upside-down. Not the UI, just my ship, its hangar, even the outside world when I undock. When I first experienced this issue, I was running DX11 mode. I corrected it by turning off UI transparency blur. The second time, I was running DX9 mode. I corrected it by switching from fullscreen to borderless (UI blur was already off).

I am running wine-2.15. I have a bleedin’ archaic Radeon HD 5000 series GPU–which, surprisingly, runs EVE seamlessly under Linux, far better than under Windows.

I seem to remember there being some kind of overrides that needed to be done in winecfg, but what with the forum having amnesia I can’t find the old topics that describe them. Anyone got any pointers?


(Merkwurkdigliebe) #2

Don’t know jack about radeon other than the opensource drivers are supposed to be good. If you switch to the lower graphic setting profiles does the problem still occur? If so check that you have an updated version of libtxc, debian calls them:

i   libtxc-dxtn-s2tc                - Texture compression library for Mesa      
i   libtxc-dxtn-s2tc:i386           - Texture compression library for Mesa      
i   libtxc-dxtn-s2tc-bin:i386       - S2TC texture compression and conversion to
i   libtxc-dxtn-s2tc-dev:i386       - Development files for the S2TC library 

You should give us some more info if you still have problems… glxinfo | grep version ,
cat .local/share/CCP/EVE/Launcher/launcherlog-2017* etc … or at least uname -a :slight_smile:

I doubt wine overrides are your problem if your on the opensource drivers. You also might look at wine staging for better DX11 support if your distro provides it.

Good Luck

  • M

(Kerono Thalmor) #3

“$ glxinfo | grep version” yields:

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.1.6
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 17.1.6
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.1.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

“$ uname -a” yields:

Linux [REDACTED] 4.12.8-2-ARCH #1 SMP PREEMPT Fri Aug 18 14:08:02 UTC 2017 x86_64 GNU/Linux

As for the launcher log, I can’t seem to find it. The path you directed me to doesn’t seem to exist and I checked other likely candidates. I lowered the graphic settings to the lowest, the problem still seems to occur.
These are the versions of libtxc I have installed, and they are the latest for my distro:

lib32-libtxc_dxtn-1.0.1-5  
libtxc_dxtn-1.0.1-6

I am running the open source radeon drivers (IIRC the proprietary ones are a PITA). I have not tried wine staging, but isn’t DX9 pretty much nailed down? This problem occurs in DX9 as well. Do you run any wine overrides, if I may ask? I’d like to rule that out.

EDIT: Everything is down as low as it could possibly go. I am still getting the upside-down world (with its own non-interactive copy in the lower left) when I log in, and when I open my fitting window there is an inverted copy of the 3D portion in the bottom left.


(Kerono Thalmor) #4

I have done a full system upgrade, I have futzed with my drivers, making sure both libva and vdpau are installed… Still no joy. I did notice that both libva and vdpau are not using the driver I’d expect them to be using, as shown here:
"$ grep -iE ‘vdpau|dri driver’ ~/.local/share/xorg/Xorg.0.log"

[    71.041] (II) RADEON(0): [DRI2]   DRI driver: r600
[    71.041] (II) RADEON(0): [DRI2]   VDPAU driver: r600

I would expect radeonsi instead of r600. I’m not quite sure how to get them to use radeonsi (since I do have it, I checked in /usr/lib/dri/). I have tried adding their respective environment variables to my .bash_profile but that doesn’t seem to do anything. I suspect the problem lies here, but I’m somewhat at a loss.


(Merkwurkdigliebe) #5

Hmm weird…

Here’s an old thread mentions some winecfg stuff:
http://www.eve-search.com/thread/1361441-0/page/2

libs llvm and drm will effect textures too… LLVM in particular should be up to date… and I’m assuming you didnt check the ~/.local/ but /.local/ ? Should be logs somewhere, the evelauncher pulldown settings will let you get to them… I dont use any overrides anymore, some people had to turn off xaudio_27 with dx11 to get the sound problems not to crash but I’m fairly sure they are unneeded, and anyways I dont know them or have any set. DX9 Shouldn’t need any afaik… sometimes people used to install dx9 by hand but again no longer needed. Unless your switching to gallium.


(Kerono Thalmor) #6

So here’s a thing. After encountering a weird thing where if I used regular wine, the eve launcher wouldn’t start, it would just crash, I switched back to wine-staging and it worked but winecfg didn’t. At a loss for what to do then, I removed every trace of wine from my system and reinstalled it from square one. After this fresh install of wine, the eve launcher still wouldn’t run in standard wine, so I switched to wine-staging again. And now, everything works flawlessly (so long as I don’t need winecfg).

It seems this is a case of trying to start the car, it won’t start so you open the door, get out, get back in, close the door, try to start the car again and it works. So frustrating. I hope one day CCP will see reason and make a native client. :disappointed:


(system) #7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.