Disable graphic popup when doing Planetary Interaction?

How do you disable that annoying graphic popup of the building you click while doing PI?

It is really annoying and makes it difficult to click on closely clustered buildings.


Unfortunately, you can’t.

This was something that they tweaked a little in the UI update last year, but in my opinion, it’s something that should just be removed entirely.

thats a shame, I like the feature but it gets in the way after a while. It would be fine to disable it or at least make the popup much smaller


Isn’t it there to prevent automation?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.