PI 3D Building Popup

Is there any way to disable the Planetary Interactions graphics that popup of the building? The 3D model of the different structures completely crashes the game for me when I try and select any of the buildings. It makes it impossible to do any PI whatsoever. I’m looking for a way to remove this graphic or turn down its settings?

I guess ill answer since none of the others have replied yet.

To my knowledge no there is no specific setting that disables that.
I would suggest try all low graphics…

Honestly Id look at the root cause of that may need a new laptop/computer. Must be pretty old if it can’t handle a tiny tiny building graphic… (Just my 2 cents)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.