Dr. Who Event Problem....No new activities show up

WTF? Blank event tasks…no progress possible if not doing combat sites.

1 Like

Don’t forget to bug report it too in case you haven’t already did so.

I had the same issue. Just submitted a Bug report.

I only have 25 event points after doing like 25 Relic sites and like 8 T1 filament relic sites. I’ve killed the saucer yet the combat portion of the mission still shows as uncompleted. It took me like four hours of running the relic sites to collect enough for 2 Combat filaments and looks like I’m going to have to wait until this gets fixed before I try again.

1 Like

Logged off and logged back on…

Sweet now I’m 1/1 but still no new challenges todo

1 Like

I have the same problem. All 3 challenges are blank. :frowning:

CCP says they are aware of the problem. CCP Swift on Reddit 9hrs ago:

We’re aware of an issue affecting some pilots where the challenges for the Interstellar Convergence are not properly refreshing. As soon as I have an updated timeline on the fix I’ll let you know, though I believe it will be solved at downtime tomorrow.

1 Like

That probably means that things will be reset with downtime, NOT that they have fixed the issue behind it.