DX12 causing severe microstuttering

I recently finished a high end gaming PC, I’ve been testing it out and noticed something I didn’t expect would persist with this new build. When I’m in a busy system, such as Jita, just outside a station with a lot of people nearby, I get decently stable FPS if I don’t move the camera. As soon as I pan around a few times, especially when zooming in, my frames drop by around 50%, from around 170 down to 70 / 80 FPS. Micro stutters register in the 60% + as well. I can notice the freezing and laggy responses in camera panning. This only happens near other ships. When I’m alone, stutters rarely go above 2 to 3%.

I was so confused. In my previous build (almost 8 years old) I just dismissed this behavior as general lack of performance. But I have a 7900xtx and a 7950x3d, the game is running on a 990 pro nvme ssd. I don’t expect that with this system.

I checked everything, drive throughput wasn’t even measurably close to saturated, as expected.
CPU was functioning as it should, running on the correct CCD, cores were parked, no severe clock drops, stable power. RAM was tested with MEMTEST and passed flawlessly, no clock drops there either. The only thing that happened across the entire system is that my gpu clock speed dropped with the stutters. Nothing else was happening simultaneously that would indicate being the cause of this.

So I ran Eve in DX11 and it was buttery smooth, super responsive. Not a single hitch while undocked in Jita, all graphic settings maxed out and getting around 190 to 220 FPS. As soon as I turn DX12 on again, it becomes laggy, very noticeably less responsive when panning and interacting with the UI.

So more testing later and the only thing that reduced this issue significantly was reducing the texture quality (everything else, aside from shaders, practically had no effect on this whatsoever). I could see the fps pattern was the similar, but much more narrow in it’s range The microstutter wasn’t registering over 60% anymore, instead to around 30%.

I’ve noticed microstutters in other games as well, but with some diagnosing I was able to fix them. For example, in Guild Wars 2 I ran at 80 FPS on max with severe stuttering and even brief lockups, very laggy camera, same as in Eve on DX12 in Jita. Turns out the “Ultra” shadow setting is very poorly implemented (old game…), reducing it to “High” removes all microstuttering (up to 30%) down to a max of around 1.5% and brings my FPS up to around 180 ish and was buttery smooth.

Having said this, it seems to me that my problem is a DX12 issue with Eve itself, probably the related to the new shading added?

So my question is, has anyone else noticed this on DX12? Getting wild FPS swings of 50% just by panning and zooming somewhere busy like outside station in Jita, getting laggy and unresponsive camera panning and interface. I was able to run perfectly smooth in DX11, so it has got to be a dx12 issue.

Again, for now I’ve only noticed this issue around other players in busy areas such as Jita. Alone, I haven’t had this issue yet. Though I’ve barely had time to test that out so far.

I’ve linked an Imgur album with screenshots of the FPS graph and hardware readouts in various scenarios.

3 Likes

Hi, you described the exact same problem I have. EVE in DX11 working butterly smooth and when running in DX12 it’s stuttering a lot.

I noticed this not only in Jita 4-4 but also in systems where newly designed graphical objects are added to the game. For example in Samanuni system, in front of Samanuni XI - Caldari Navy Warehouse station, a lot of newly designd objects are placed around the station (it is part of FW or Homefront operations, I don’t know exactly). Whenever I undock from that station or just pan the camera outside that station, I get a lot of stuttering in DX12 mode. The game feels very laggy in such scenes. But in DX11 mode, undocking and flying around that station is very smooth. Only DX12 is bugged.

@Thermal_X Can you please fly over to the Samanuni XI - Caldari Navy Warehouse and try undocking, camera panning and flying around and check the difference between DX11 and DX12?

I believe that this is not just related to highly congested systems but is related to in-game graphics and design.
Also I believe it is related only to AMD systems because with my brothers PC on Intel i5 and Nvidia 3060 there is no sttutering in DX12.

I had Ryzen 5 2600X and RX580.
Then switched to Ryzen 5 2600X and RX6750XT.
Some time later finnaly upgraded the CPU to Ryzen 7 5800X3D and RX6750XT - this is current setup.
In all above scenarios through time I hoped that with every hardware upgrade something will change but DX12 was bugged in all hardware combinations and in both Win10 and Win11. Tried many many driver versions but it’s still the same issue.

1 Like

That’s interesting. My prior build was a 4770k with a gtx 1080, I noticed the same stutters I do now. I just never tried diagnosing them, so I can’t say with certainty what it was. I did have the game running on an SSD at the time, but there were other factors at play. However, it was the same issue as now. I don’t have these issues when I’m alone, for example somewhere by a planet. I’m hoping this isn’t an AMD related issue. Are you absolutely sure that between you and your brother everything else was the same, aside from hardware? Especially ingame settings.

@Ezra_Endashi I’ve tested this and I can confirm the issue returns in this scenario, same as in Jita. So It’s not related to the number of players, it is definitely something with DX12. Maybe it’s just worse with the amount of assets being loaded. The issue did significantly reduce after a little while though, unlike with Jita where it persists. Perhaps because of the players coming and going and new textures being loaded? I also found out gas clouds play a severe part in performance hits.

I’ve been flying around in DX11 and DX12 to test this issue further. This is what I’ve found:

  • When alone, with DX12, somewhere near a planet not loading any other players or structures aside from the customs office and a few concord, I get stable fps. No stutters when panning, zooming. Microstutters don’t go above 1%. I still do get occasional dips when panning around, but not more than 10%. It’s the same in DX11 though.

  • Severe FPS drops, around 50 to 60%, only in DX12. After some testing, seems to be greatly caused by gas clouds with volumetric effects on max (still happens significantly when the setting is put on low, but less so). This would explain the severe drops in Jita 4-4, the station has a lot of volumetric effects now. When the camera zooms or pans through clouds, the FPS tanks badly. Didn’t cause any stutters when I was alone around a gas cloud. Also doesn’t happen on DX11.

  • I get significantly higher FPS with DX11 vs DX12, which I didn’t expect. I thought DX12 was supposed to bring performance improvements. Maybe I’m wrong.

  • FPS in DX11 is very stable compared to DX12 which can fluctuate significantly during normal gameplay, such as during warp, while dropping out of warp, around a lot of other objects (players, structures, etc). Can stutter with warp.

  • Severe FPS drops (not as bad as gas clouds) when zooming near multiple objects in DX12. With concord, gate guns, players and player modules etc nearby. I dropped volumetric effects down to low in case it was clouds I couldn’t see. But no change. No stutters or freezes.

All I can conclude is that something in DX12 is causing these issues. DX11 is completely free from this. It seems it isn’t just tied to new assets ingame, I get bad FPS drops near busy gates as well, which correlate mostly with zooming, less so when panning. Gas clouds are very significant culprits to performance hits. I think the stutters may be a result of the massive FPS swings, perhaps even the extremely low FPS I get as in Jita 4-4 in DX12, as I can go from 180 highs at times down to 30 or 40 fps when zooming or panning.

As is, I can’t justify using DX12 given the performance issues I’m currently experiencing. The game runs fine on DX11, the only stutter I get there is when jumping system and it’s while it’s loading.

I’d love to hear from other people if they have these issues as well: severe FPS drops, stutters / momentary camera freezes with DX12. What hardware they’re using, to see if this is a global issue.
I hope this can be fixed. Games are pushing mandatory DX12 more and more, I’d like to see things optimized before that happens here as well. DX12 was supposed to be a performance boost, as far as I understood it.

1 Like

I always play on all max settings. The same was on my brothers PC. He’s not playing any more so I would have to try once again with my account on his PC. Could try that once when in ocasion.