Had a DirectX 12 crash?

Hi all

In the last release we moved to DX12. We are aware that a small number of people had some stability problems within the first few days. We’ve since patched all known crashing issues and our metrics for this are looking good (Check out the devblog on how we know: Upgrading Crash Reporting Systems | EVE Online)

I’m keen to hear from anyone that is still experiencing client stability problems that are resolved by moving to DX11, as we’re unlikely to be aware of them at this point. As DX12 will be important to future updates, we want to ensure any outstanding issues are resolved.

We’re aware of a small number of (non crashing) DX12 issues in some configurations, namely a ‘flash’ of lighting that can happen. This is a rare issue with a low reproduction rate, but we are looking into it :slight_smile:

TL;DR - If you crash in DX12 mode, but not DX11 I really want to know.

Thanks :slight_smile:

2 Likes

Hey.

Yes I’m having issues with dx12, albeit wierd ones.

Cpu 3700x
Gpu 6800 16gb vram non xt
Ram 32 gb 3200
Motherb Asus Tuf gaming plus
Everything on stock, no overclocks except ram SMT/DOCP enabled in bios.

Issue 1: In dx11 when trying to cap fps to 60 via FRTC or chill it doesn’t work in windowed or fullscreen windowed mode, so fps goes unnecessarily high. When using dx12 it works to cap.

Issue 2: However dx12 causes a hard crash of game if my ship explodes or something more intensive happens quickly. This doesn’t happen with dx11 ever.

Issue 3: There is something very wierd and off with vysnc, it only works properly in windowed mode or fullscreen not in windows fullscreen mode with dx12.
FPS has a tendency after alt-tabbing jump up to 180-250fps.

Hi there

We are aware of the Vsync / sync issues in general. I made a post about it here: Version 20.06 - Known Issues - #134 by CCP_Caffeine
This is something we’ll be taking a closer look at with our partners, as it’s a combination of software and hardware causing this problem. You may have some success restoring it to how it previously worked by toggling vsync / VRR / Freesync settings until we can get to the bottom of the problem.

Issue 2: However dx12 causes a hard crash of game if my ship explodes or something more intensive happens quickly. This doesn’t happen with dx11 ever.

Thanks for this. I know the nature of crashing means it might be difficult to replicate on demand, but can you think of a specific scenario where this has happened? It would be useful to know some rough information so we can try to replicate it :slight_smile:
Can I also check that your drivers are up to date? We’ve seen issues with older ones for sure which are no longer present on the latest ones.

2 Likes

Hey.

Yes, for example when my ship actually explodes with gfx set to max settings, and close to a combat site or asteroid belt with rats. It often causes the hard crash.

Yes all my drivers are up to date, except the BIOS which is a TUF GAMING X570-PLUS set to bios version 4021, newest bios causes issues with Ryzen 3700x and Ram DOCP.

My system is very stable with temps well below normal averages.

Thank you for the link with the vysnc issues. Yes I have freesync enabled I’ll try with it toggled off, I’ll also patiently wait for a fix. Game really looks good in dx12.

Wow, finally I see the problem I encountered, I have resubmitted the report, EBR-236537, and also attached the video I recorded, I hope you can solve this problem sooner.

A feature that that I think would be appreciated if it could be implemented is a in-game fps cap slider.

@CCP_Caffeine
Hi, I found a strange phenomenon about the flashing problem,
when I changed the G-SYNC setting in the NVIDIA control panel to start in windowed and full screen mode, the flashing problem no longer appeared (just found that the frame rate dropped significantly by 30FPS+, only 10-20 frames and lag if the ship is out of the fortress when the crowd is dense, although it will rise after a while), when changed to start in When replaced to start in full screen mode the flashing problem will appear again, (my client has been running in windowed),
I hope this discovery will bring you new ideas to solve the problem.
Also do I have to update this issue in the bug report?EBR-236537

@CCP_Caffeine

Should smart access memory be on or off with dx12?

And is there any difference running the steam client vs the CCP stand-alone client for dx12 stability?

Update: I believe that having SAM turned on is what’s causing the crashes in dx12 when running multiple clients. Just a wild guess but it seems the gpu tries to access the max vram for both clients.

Same should apply for Nvidias resizable bar.

hii i get BSOD whenever the installer updates and does the cache purge thing, no restart on the launcher, launch 2 clients fairly quickly then BSOD forced restart, on restart works fine, but eve graphic settings inside eve sometimes have reset. o7

I have the same on multiple clients, two to be exact, running at the same time with dx12. After awhile I start getting artifacting then it crashes. Doesn’t happen in dx11.

My guess, is it doesn’t adjust resource allocation correctly so the gpu tries to render both at the same time and the 1 & 0’s goes crazy.

I am running an older NVIDIA Gforce 1060 GPU, an i5 6600 CPU, with 8 gigs of memory.

A little over a month ago, when the game was using DirectX11, I could run 4 separate accounts simultaneously and have over 100 fps. Now that you have changed to DriectX12 when I run the 4 accounts I am having a lot of crashes and the rare ‘flash’ lighting issue. My fps is now at 60 when docked but dips to 0.14 ish to 20 ish during undocking, jumping through gates, and while in an anomaly. Most of the crashing is mainly jumping through gates. The ‘flash’ lighting issues usually happen during undocking and docking, mostly during undocking.

Thanks for showing interest in this, @CCP_Caffeine!

I don’t get client crashes with DirectX 12 enabled - but I DO get the flashing light stuff, and I get a lot of irregular client freezing - to the point the whole PC seems to freeze - the screen goes completely black, I lose the Windows (Windows 10, not Windows 11, I’ve been holding off on the upgrade largely to be sure Eve will be OK with it) taskbar, not just Eve clients. It lasts for anything from a 2-3 seconds to 30 seconds or longer (the 2-3 second freezes are most common, the 30+ second ones are rare).

My PC’s pretty powerful, with no overclocking at this stage, and all temps under control - Ryzen 7 3700X on an MSI x570 motherboard, 32GB Corsair RAM, all HDDs are nVME M.2, RTX3070 graphics, wired Ethernet connectivity back to a router/firewall that I’m 100% positive is not the issue (why - because what I did to fix it has nothing to do with the router/firewall, and it only started after the DirextX 12 client release), so initially I thought it was a configuration or potentially driver issue. I’ve gone to the latest WHQL drivers for the card (from nVidia, not MSI), all aspects of my system (except motherboard BIOS, I haven’t updated that for a while) are well patched. I tried disabling local security software (various anti-virus/anti-malware options that I have available to me, all to no avail. I toggling the interval settings in game as , I tried native (3440x1440) and lower resolutions, I’ve tried changing the graphics options (I generally run full quality).

I play in full-screen Windowed mode if that matters (as it seems to be less intrusive on the system as a whole, particularly when switching windows).

When nothing I did fixed it, I disabled DirectX 12 from the launcher - and immediately all problems went away - I was having freezing with even a single client open when DirectX 12 was enabled, I’m back to being able to run 10+ clients without any noticable freezing in the active client now.

I haven’t turned DirectX 12 back on for double confirmation - because frankly, I don’t want to have to put up with the freezes at the WORST possible times (they happen at all sorts of times, including taking gates, leaving structures/stations, etc), but can if needs be as part of testing.

I had the client run VERY dark a few times and not draw the full interface (menus missing text, graphics, items under menus blank) when I had DirectX 12 active as well. I am not testing the new client interface at this stage (because it’s either on or off across all clients - I’d happily test it on only one or two, but the game/launcher seems to synchronise the setting for this across all clients - and as much fun as it is to turn it on manually and turn it off manually on a single client and remember to do this every single time I play - that’s a chore, and thanks, but no thanks).

Some more data for @CCP_Caffeine:

MSI X570 Tomahawk WiFi motherboard. Was running BIOS v1.0, now running v1.90
Latest AMD chipset drivers (package v3.10.22.706) installed.
Latest relevant LAN, sound, WiFi, Bluetooth, etc drivers all installed.
nVidia driver v31.0.15.1659 (according to Windows, nVidia internally says 516.59, DirectX 12 runtime installed and enabled.

Update,

I played with DirectX 12 enabled for about 30 minutes. Clients felt “laggy”, though I didn’t experience the complete freezes I’ve experienced in the past - but 30 minutes is hardly a good test. I might try some more 3D challenging content today with DirectX 12 enabled to see if the updates have fixed things…

I’m still getting the momentary freeze (can last about 20 seconds) or total client crash when I have multiple clients running (typically 4) and switching back and forth across clients.

I’ve removed the cache and completely reinstalled the client.

Sadly, I am in the same boat. I’ve tried the same things. It’s generally only when I have multiple clients open - but it’s completely debilitating when it does occur - the screen goes black, the whole PC seems to freeze. This is after a complete system update - BIOS, firmware, drivers, the works. I have tried a cache refresh, I have not tried reinstalling the client yet (I don’t believe I should need to, it works perfectly well with DirextX 11).

@CCP_Caffeine, is this still being tracked/worked on?