DXVK + EveWine w/ RX Vega 64

First off, thank you so much to Gharim for the superb Eve Launcher on Linux. Thank you for taking the time to keep Wine & Eve working well :slight_smile:

Anyway! Onto my issue, I am using an RX Vega 64 & using the amdgpu open source driver on Arch Linux kernel version: 4.20.13-arch1-1-ARCH. I am using the latest Evelauncher from March 3rd & DXVK 1.0. Eve does launch & everything runs correctly as I am in DX11 mode. Performance is better too!

Unfortunately, I am getting some artifacts over the GUI elements like the potrait picture in the character selection screen & any UI element like the station side panel or chat window or neocom. It’s almost like large digital snowflakes if I were to describe it.

Has anyone seen this error before? I noticed previously there had been earlier DXVK releases that fixed artifacting. I wasn’t sure or wasn’t able to find any forum posts similar to my issue, though.

Any suggestions on further diagnosis? Thanks!

Yeah, this particular tidbit drove me absolutely bonkers. Come to find out the VK extensions aren’t implemented properly on the stable distribution drivers. You need to use the Padoka PPA for your AMD RX Vega 64 drivers to fix the issue. When I installed those, the artifacting went away completely and she runs like a charm with DXVK enabled

What kernel version are you running?
I installed the unstable Padoka PPA on Ubuntu 18.10, kernel 4.18, but I still get the artifacts.
I have a Vega 56.
Tried with wine 4.2&dxvk 1.0, and also with latest Proton 3.16

Thanks for mentioned me but i am not the developer from evelauncher itself, it was the work from @CCP_Snorlax and @CCP_Bartender maintain the linux evelauncher atm. My work was only the installer and some packages, which made it easier to install and maintain an eve installation on linux (hopefully). :slight_smile:

@Gharim_Turen Ah, thank you for that correction. Much thanks to those guys as well :slight_smile:

Anyway, a bit of an update on this. I struggled testing various configurations I had setup by hand, and I gave up. Instead, I just used the 4.2 Wine prefix with Steam Proton and it solved this issue using its own DXVK.

So… it works! Now I can ditch Windows just a lil more :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.