Eve Client treating secondary monitor with primary monitor resolution

I have an issue similar to this one:

However, my issue persists. I run two clients, one on a 1440p monitor (the primary monitor) and another on the secondary at 1080p. Every time I start a client on the secondary (regardless of which account I’m assigning to it) it scales the window as though it is on the 1440p monitor. So at 1080p it scales to the same window position as it would appear on the primary monitor. Sometimes I can - eventually - get it to behave properly by switching between window, fullscreen, and fixed window until it finally recognizes the monitor resolution and becomes a full screen fixed window at 1080p. Other times, it will simply not revert to correct behavior, and will even lock me out of the resolution selection dropdown.

Fullscreen mode is the only option that reliably works. Window and Fixed Window will both scale as though they are on the primary monitor.

My client profiles are configured in the launcher. Using a profile configured for primary or secondary will start on the correct monitor. No issues with any profile/account combo on the primary monitor. This only occurs on the second monitor. I am also setting the monitor to “Adapter 2” in the display options. This is becoming an extremely frustrating issue as it makes it next to impossible to read anything on the secondary monitor.

Does anyone have any advice on resolving this issue? Has anyone had this happen that hasn’t had it magically disappear? Thanks in advance to anyone that can offer insight or assistance.

Alright, I’ve done more testing and will share here what I’ve done. Problem still persists.

I’ve tried every variant of scaling related compatibility settings on the eve.exe properties. All but one failed to change anything - and the setting that fixed the 1080p display borked the 1440p display instead lol.

I’ve tried all of those settings with/without the “Disable fullscreen optimizations” box checked.

I’ve checked all of my settings in the Nvidia control panel.

I’ve disabled Windows automatic scaling feature, and retested all the above combinations with the automatic scaling enabled and disabled.

I’m at a complete loss. If it’s a windows setting, I don’t know where else to look. If it’s an EVE setting, I can’t find it.

I even tried to install a second installation of EVE assuming I would run one for the 1440p and one for the 1080p - I can’t have two versions of the launcher open at once. I’m desperate for a fix at this point, and I’ll send a months worth of Omega in PLEX to whoever can solve this issue.