EVE Installing

Yes wine-staging is currently 4.18-1

https://www.archlinux.org/packages/multilib/x86_64/wine-staging/

Maybe Manjaro hasn’t updated yet?

Yes maybe you should start a discord for eve linux people :slight_smile: @Gharim_Turen

Another update and hopefully the last for this year but before Christmas for sure. :slight_smile: Download sources are on AUR as always (have there a look on evesetup). As long previous versions work for you, there is no need to update to revision 6. Happy holidays and…

– fly safe o7

When I had to buy a new laptop it came with W10, and Linux was the natural antivirus system to adopt. Over a decade of solely using Windows has limited my technical skills (To HTML and basic JS), so I am currently only able to do Linux stuff if I can name and google it.
Which was why I was delighted that Eve Uni has a guide!

However, after getting through the guide I found two issues. First, Terminal seems to encounter an error when installing (Though as you can see, I followed the EveU guide without noticing at first) and when I wanted to check whether the installer worked at all, I realised that the launcher opens fine, but when I try to launch the game itself, it doesn’t work.
Is this a common issue with a guide to solve? What steps can I do to troubleshoot, and what would you fine people need to know to assist?

Hi, Alphea. Nice to meet you here. :slight_smile: It seems, you are on a Ubuntu distribution to install the evelauncher using the guide from UniWiki but this guide is quite outdated. IDK in which evelaucher version CCP has changed the qtwebengine. The sql errors comes from incompatibility to newer ones. To solve this error remove the CCP directory in your ~/.local/share with

rm -rfv ~/.local/share/CCP

Please download the latest evelauncher binary from here:

https://binaries.eveonline.com/evelauncher-1548102.tar.gz

to try the UniWiki way again and please, use NOT the build-in wine version from the launcher, use a custom wine like the wiki has this described. So you can use then DXVK, which is a great perfomance boost for EVE but only with a custom wine. DXVK can be installed with winetricks (which is also recommended) like so:

env WINEPREFIX=~/.eve/wineenv winetricks dxvk

Check your input lines twice, in your last line on the 2nd screenshot you have a typo, sudo and edit are two commands.

HTH :slight_smile:

Ups just seen, the typo are in the wiki, but changes nothing, should be sudo edit

PS. On Ubuntu distributions you have maybe difficulties launch the game itself because of incompatibilities of installed xcb libraries. In this case just remove the xcb-libraries in the evelauncher directory like so:

rm -v /Path/To/evelauncher/libxcb*

You can find me on TiS discord :wink:

It’s time for another update. :slight_smile: The highlight of revision 8 of my evesetup package are a reworked evebackup script which produces now portable client setting archives in users Documents/EVE directory.
These archives hold all client settings for all known servers (which i know atm), including fittings, overlay settings and so on and can be used on different EVE setups as long the used hardware are the same (or better :wink: ) which was used during the backup process.
It doesn’t matter if you use wine from your distribution or from WineHQ or use a proton version via Steam, the only thing you must know, where your eve profile folder are located, in most cases are this

$WINEPREFIX/drive_c/users/$EVEUSER/Local Settings/Application Data/CCP/EVE

If you use only my package then does everestore this for you (after you have the archives from a external storage into your Documents/EVE folder copied). For more explanations have a look at this thread: how-to-never-lose-your-ship-fittings-and-eve-settings

The sources can you find on AUR under evesetup as always.

– fly safe o7

1 Like

Thank you for all the work you did!

1 Like

Nice update!

having issues with latest update:

tar: ./eve-transl5.11-??.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

1 Like

Thanks for the hint :slight_smile: That is the disadvantage when you maintain more than one variant of the same project. It works with the independed installer but i forgot to insert the absolute path to the translation archives in the PKGBUILD script. With revision 11 should it work now.

1 Like

Thanks so much for this, Can get in contact with you on how to do this? I’d love to learn more and contribute!

Getting wine crashes with the latest build @Gharim_Turen

Which wine-version are you using? Works flawless here:

Used nvidia-drivers are 440.82 all others see the screenshot. There is nothing atm what i can do with my script package as long the linux launcher is stuck on qt version 5.11 and openssl version 1.0.

This is btw the reason while no newer qt-versions can be used anymore. Newer versions depends on openssl 1.1.x and when the launcher connect with qtwebengine for SSO she try to use openssl 1.1.x instead 1.0.x but uses functions from openssl 1.0.x which are no longer supported.

@CCP_Bartender can you fix that please by building a new linux launcher with qt version >= 5.12 and openssl version 1.1.x ?

– fly safe o7

P.S. Today wine from version 5.5 to 5.7 updated. Nothing changed, it works. Only other things from the last update yesterday broke my gnome-desktop but by disabling some gnome-shell-extensions he work again (joy of a rolling release model).

Based on the good work of @CCP_Bartender with the new beta launcher is it possible to using this beta version with Arch’s qt system libraries again (atm version 5.14 on Manjaro).

If you want to try this out i have created a custom build script which can be used with the last snapshot from my AUR package to create a package (other Distro’s are not included atm).
But beware, it’s still beta so be warned. :wink:

Here we go:

[gharim@amd4k3 evesetup]$ cat PKGBUILD.beta 
#Maintainer: Gharim Turen <gharim@turen.de>
pkgname=evesetup-beta
pkgver=1732117
pkgrel=0
pkgdesc="An inofficial EVE Online Launcher Setup Tool. Beta version, be careful."
arch=(x86_64)
url="https://forums.eveonline.com/t/eve-installing/71494"
license=('custom')

depends=('icu'
         'openssl'
         'openssl-1.0'
         'p7zip'
         'qt5-base'
         'qt5-declarative'
         'qt5-translations'
         'qt5-location'
         'qt5-webchannel'
         'qt5-webengine'
         'qt5-websockets'
         'wine')

optdepends=('libnotify' 'winetricks')

conflicts=('evelauncher' 'evesetup_dev' 'evesetup')

source=("evelauncher.desktop"
        "evelauncher.sh"
        "evelauncher.sh.real"
        "evesetup.shlib"
        "everegedit.desktop"
        "evewine"
        "evewinecfg.desktop"
        "evewinetricks.desktop"
        "evewinetricks"
        "evebackup.desktop"
        "evebackup"
        "everestore.desktop"
        "evelauncher.kwinrule"
        "evelauncher.lua"
        "eve-icons.tar.gz"
        "eve-icons_large.tar.gz"
        "https://binaries.eveonline.com/evelauncher-${pkgver}.tar.gz")

package() {
        install -d "${pkgdir}/opt/${pkgname}/bin"
        install -d "${pkgdir}/opt/${pkgname}/lib"
        install -d "${pkgdir}/opt/${pkgname}/doc"
        install -d "${pkgdir}/usr/bin"
        install -d "${pkgdir}/usr/share/applications"
        install -d "${pkgdir}/usr/share/icons"
        sed -i s,ELVER=\"\",ELVER=\"${pkgver}\", "${srcdir}/evelauncher.sh"
        sed -i 2\ s,[0-9].*\",${pkgver}\", "${srcdir}/evelauncher.lua"
        sed -i s,SETUPDIR=\"\",SETUPDIR=\"/opt/${pkgname}\", "${srcdir}/evelauncher.sh"
        sed -i s,Online\ Launcher,Launcher\ \(Beta\), "${srcdir}/evelauncher.desktop"
        for cmd in backup launcher.sh regedit restore wine winecfg winetricks ;do
            cmd=eve$cmd
            if [ -f "${srcdir}/$cmd" ] ;then
                sed -i s,./evesetup.shlib,/opt/${pkgname}/lib/evesetup.shlib, "${srcdir}/$cmd"
                install "${srcdir}/$cmd" "${pkgdir}/opt/${pkgname}/bin"
            else
                if [ "$cmd" = "everestore" ] ;then
                    ln -s evebackup "${pkgdir}/opt/${pkgname}/bin/$cmd"
                else
                    ln -s evewine "${pkgdir}/opt/${pkgname}/bin/$cmd"
                fi
            fi
            ln -s "/opt/${pkgname}/bin/$cmd" "${pkgdir}/usr/bin/$cmd"
            if [ ! "$cmd" = "evewine" ] ;then
                oexec=$(grep Exec= ./${cmd%.*}.desktop)
                sed -i s,$oexec,Exec=/usr/bin/$cmd, ./${cmd%.*}.desktop
                cp "${srcdir}/${cmd%.*}.desktop" "${pkgdir}/usr/share/applications/"
            fi
        done
        cp ${srcdir}/evesetup.shlib ${pkgdir}/opt/${pkgname}/lib
        cp ${srcdir}/evelauncher.lua ${pkgdir}/opt/${pkgname}/doc
        cp ${srcdir}/evelauncher.kwinrule ${pkgdir}/opt/${pkgname}/doc
        cp -r ${srcdir}/icons ${pkgdir}/usr/share/
        rm -rf ${srcdir}/evelauncher/resources/ ${srcdir}/evelauncher/plugins/
        rm -f ${srcdir}/evelauncher/*[Qq]t* ${srcdir}/evelauncher/libcrypto*
        rm -f ${srcdir}/evelauncher/libicu* ${srcdir}/evelauncher/libssl*
        rm -f ${srcdir}/evelauncher/libpng* ${srcdir}/evelauncher/libxcb*
        cp -f ${srcdir}/evelauncher.sh.real ${srcdir}/evelauncher/evelauncher.sh
        chmod 0755 ${srcdir}/evelauncher/*
        chmod 0644 ${srcdir}/evelauncher/*.qm ${srcdir}/evelauncher/errorpage/*
        ln -sf evelauncher.sh ${srcdir}/evelauncher/LogLite.sh
        ln -sf libgpr.so.6.0.0 ${srcdir}/evelauncher/libgpr.so
        ln -sf libgpr.so.6.0.0 ${srcdir}/evelauncher/libgpr.so.6
        ln -sf libgrpc++.so.1.12.0 ${srcdir}/evelauncher/libgrpc++.so
        ln -sf libgrpc++.so.1.12.0 ${srcdir}/evelauncher/libgrpc++.so.1
        ln -sf libgrpc++.so.1.12.0 ${srcdir}/evelauncher/libgrpc++.so.6
        ln -sf libgrpc.so.6.0.0 ${srcdir}/evelauncher/libgrpc.so
        ln -sf libgrpc.so.6.0.0 ${srcdir}/evelauncher/libgrpc.so.6
        ln -sf libprotobuf.so.16.0.0 ${srcdir}/evelauncher/libprotobuf.so
        ln -sf libprotobuf.so.16.0.0 ${srcdir}/evelauncher/libprotobuf.so.16
        find ${srcdir}/evelauncher/ -type f -exec strip -s {} 2>/dev/null \;
        tar czf ${pkgdir}/opt/${pkgname}/lib/evelauncher-${pkgver}.tar.gz evelauncher/
}

sha256sums=('ce85defa2698ea72e88221d72424fb953f86836494ecc0e4006f41ec89682af4'
            'b1faa042a96746fe80ea5d85a0c26e80b29353394897774f45b9e48e0639a1d8'
            '80fceef0e28c2291cd4ba3924410211edd188717be093ffc329d18697583bd21'
            '4eaceb0661dd38354c3738411bdbe48e29bab103bb09b8f959d16f1073904625'
            'a8e604e6481b9a386269b6252852ee57812fc932f44f767982c4dbac168bb03b'
            '9079fd9ed7967479b7a78643d43537c04f9275303cd713651d2481bf4c658653'
            '546aaf5669dc3d3f1b2fff1b9a493d8ba31c19940a04fa4b9eb080e7301df4bd'
            'c83beba543663b926d28d0eda98f1035cd73327da50f718a487763d300415a24'
            '56929a0129540140ed7c85c04b83a163b4977bcc9d5555f760af871fc5ccbd17'
            '30b6440b842c19df64892cc560c274a7cc4f5de910a9f81e12dd0d76da561474'
            '3c4aedb6e3ea37cf041abb2ac15decb25d5a1852c1eac344943645fd954466cf'
            '261da84107168979d241c60cd7adbfee0f6675464675faaefd5f6140009d54d8'
            '528fc6627e8893db5d7092194e9f3320067f2f1f4593a206aee8a5207956e563'
            'd4610df883778f91e0ea5feba84720dfe814af0b9960677e3861809d70de24b2'
            '69b98d923c08c6fb035c0c6905ec5e9c73273b694f8f3497777d44597dbe63e3'
            '762db1df07dfcf526fe634b4b589a08e8affefb2f79f02cff2624c70e0820422'
            '2704010674592311df2bf890f1b6add4da9e53e7bcbe23c39215516b7bd71568')

Copy this as PKGBUILD.beta in the downloaded source directory then build the package with
makepkg -sf -p PKGBUILD.beta

After successful build install it with
sudo pacman -U --asdeps <insert packagename here>

If you have used my scripts before, i recommend make a backup from your ingame settings with evebackup before you launch the beta version, because the cleanest way to use it is to begin by zero.

Meaning remove all directories in your $HOME which was used from EVE (except Documents/EVE where your backups are stored), evelauncher will create it again.

rm -rf $HOME/.cache/CCP
rm -rf $HOME/.config/CCP
rm -rf $HOME/.local/share/CCP
rm -rf $HOME/.local/lib/EVE

First important thing is cancel the update to 1548102 and set in Settings the launcher on Beta.
While he download his stuff you can restore your (hopefully saved) ingame settings with everestore

Optional but highly recommended install dxvk with evewinetricks -q dxvk

For updates, glitches and errors have a look at this thread New launcher beta: 1732117 . The most nasty bug which i have atm is he doesn’t close so i have to kill all remaining processes of evelauncher by hand with killall evelauncher . Have a look on your running processes after close him. :wink:

– fly safe o7

The last days i have updated the beta package of evesetup to the latest version of the beta launcher and added some improvements.

As an optional dependency i have added AUR - dxvk-bin which were installed (only the d3d11 part) if present on the system and setup_dxvk are executable.

In EVE.conf i have evelauncher version set to beta so that by the first start no more downloads from the standard evelauncher should be occur.

For the displayed error about missing roots.pem i have added a workaround which create a symlink in directory
/usr/local/share/grpc/roots.pem to /opt/evesetup-beta/lib/roots.pem but only, if the directory in /usr/local/share doesn’t exist.

[gharim@amd4k3 evesetup]$ cat evesetup-beta.patch

diff --git a/PKGBUILD.beta b/PKGBUILD.beta
--- a/PKGBUILD.beta
+++ b/PKGBUILD.beta
@@ -1,12 +1,14 @@
 #Maintainer: Gharim Turen <gharim@turen.de>
 pkgname=evesetup-beta
 pkgver=1734683
-pkgrel=0
+pkgrel=1
 pkgdesc="An inofficial EVE Online Launcher Setup Tool. Beta version, be careful."
 arch=(x86_64)
 url="https://forums.eveonline.com/t/eve-installing/71494"
 license=('custom')
 
+install=${pkgname}.install
+
 depends=('icu'
          'openssl'
          'openssl-1.0'
@@ -20,7 +22,7 @@ depends=('icu'
          'qt5-websockets'
          'wine')
 
-optdepends=('libnotify' 'winetricks')
+optdepends=('libnotify' 'winetricks' 'dxvk-bin')
 
 conflicts=('evelauncher' 'evesetup_dev' 'evesetup')
 
@@ -99,9 +101,9 @@ package() {
 }
 
 sha256sums=('ce85defa2698ea72e88221d72424fb953f86836494ecc0e4006f41ec89682af4'
-            'b1faa042a96746fe80ea5d85a0c26e80b29353394897774f45b9e48e0639a1d8'
+            'e9c2145865e425a13fa38f433f2aec0574c44950442dffb900ae41085bfe7566'
             '80fceef0e28c2291cd4ba3924410211edd188717be093ffc329d18697583bd21'
-            '4eaceb0661dd38354c3738411bdbe48e29bab103bb09b8f959d16f1073904625'
+            '88df60eb2e71bd267089e03daac743c5882350f56499b0b548b239b704ee4c6e'
             'a8e604e6481b9a386269b6252852ee57812fc932f44f767982c4dbac168bb03b'
             '9079fd9ed7967479b7a78643d43537c04f9275303cd713651d2481bf4c658653'
             '546aaf5669dc3d3f1b2fff1b9a493d8ba31c19940a04fa4b9eb080e7301df4bd'
diff --git a/evelauncher.sh b/evelauncher.sh
--- a/evelauncher.sh
+++ b/evelauncher.sh
@@ -3,7 +3,6 @@
 set -e
 
 ELVER=""
-QTVER="5.11"
 EVEDIR="$HOME/.local/lib/EVE"
 SETUPDIR=""
 LAUNCHER="$EVEDIR/Launcher"
@@ -16,13 +15,5 @@ check_elv
 check_wine
 check_steam
 
-if [ ! -r "$LAUNCHER/translations/qt_en.qm" ] ;then
-    if [ -r "$LAUNCHER/libQt5Core.so.$QTVER.0" ] ;then
-	for eta in ./eve-transl${QTVER}-??.tar.gz ;do
-	    tar xf $eta -C $LAUNCHER
-	done
-    fi
-fi
-
 cd $EVEDIR
 exec $LAUNCHER/evelauncher.sh
diff --git a/evesetup-beta.install b/evesetup-beta.install
--- /dev/null
+++ b/evesetup-beta.install
@@ -0,0 +1,18 @@
+post_install() {
+	if [ ! -d /usr/local/share/grpc ] ;then
+	    mkdir -p /usr/local/share/grpc
+	    touch /usr/local/share/grpc/needed_by_evelauncher
+	    tar -xf /opt/evesetup-beta/lib/evelauncher-1734683.tar.gz \
+		-C /opt/evesetup-beta/lib --strip-components=1 \
+		evelauncher/roots.pem
+	    ln -s /opt/evesetup-beta/lib/roots.pem /usr/local/share/grpc/roots.pem
+	fi
+}
+
+pre_remove() {
+	if [ -d /usr/local/share/grpc ] ;then
+	    if [ -r /usr/local/share/grpc/needed_by_evelauncher ] ;then
+		rm -rf /usr/local/share/grpc
+	    fi
+	fi
+}
diff --git a/evesetup.shlib b/evesetup.shlib
--- a/evesetup.shlib
+++ b/evesetup.shlib
@@ -44,6 +44,7 @@ check_env() {
 	echo "SharedCacheFolder=$EVEDIR/SharedCache/" >>$EVECONF
 	echo "UseCustomWine=true" >>$EVECONF
 	echo "CustomWinePath=$WINEPATH/wine" >>$EVECONF
+	echo "LauncherType=1" >>$EVECONF
 	mkdir -p $EVEDIR/SharedCache
 	if [ -d "$SHAREDIR/ResFiles/" ] ;then
 	    mv $SHAREDIR/ResFiles/ $EVEDIR/SharedCache/
@@ -71,7 +72,12 @@ check_wine() {
 	CUSTOMWP=${SHAREDIR}wine
 	WINEPATH=${SHAREDIR}wine/bin
     fi
-    if [ ! -x "$WINEPATH/wine" ] ;then
+    if [ -x "$WINEPATH/wine64" ] ;then
+	WINE=$WINEPATH/wine64
+    else
+	WINE=$WINEPATH/wine
+    fi
+    if [ ! -x "$WINE" ] ;then
 	desktop_msg "ERROR: \"$CUSTOMWP\" not found!"
 	exit 1
     fi
@@ -80,22 +86,31 @@ check_wine() {
     WINECONF=$(find ${WINEINFP%bin*}share/wine* -name 'wine.inf')
     WINEDATE=$(getdate $WINECONF)
     if [ "x$WINEDATE" != "x$INSTWINE" ] ;then
-	desktop_msg "Preparing wine in $WINEPREFIX"
+	desktop_msg "Preparing wine environment for EVE"
 	env WINEPREFIX=$WINEPREFIX \
 	    WINEDEBUG=-all \
 	    WINEDLLOVERRIDES="mscoree,mshtml=d" \
-	    $WINEPATH/wine wineboot
+	    $WINE wineboot
 	env WINEPREFIX=$WINEPREFIX \
-	    $WINEPATH/wine reg add \
+	    $WINE reg add \
 	    'HKCU\Software\Wine\FileOpenAssociations' \
 	    /v Enable /d N /f >/dev/null
     fi
+    WINESYSDIR=$WINEPREFIX/drive_c/windows/system32
+    if [ -x "$(which setup_dxvk 2>/dev/null)" -a ! -r $WINESYSDIR/d3d11.dll.old ] ;then
+	desktop_msg "Setup DXVK in EVE's wine environment"
+	env WINEPREFIX=$WINEPREFIX ${WINE%/*}/wineserver -w
+	env WINEPREFIX=$WINEPREFIX \
+	    WINEDLLOVERRIDES="mscoree,mshtml=d" \
+	    setup_dxvk install
+	env WINEPREFIX=$WINEPREFIX \
+	    $WINE reg delete \
+	    'HKCU\Software\Wine\DllOverrides' \
+	    /v d3d9 /f >/dev/null
+	mv $WINESYSDIR/d3d9.dll.old $WINESYSDIR/d3d9.dll
+	mv ${WINESYSDIR%/*}/syswow64/d3d9.dll.old ${WINESYSDIR%/*}/syswow64/d3d9.dll || true
+    fi
     if [ "x$(grep -csw winemenubuilder $WINEPREFIX/system.reg)" != "x0" ] ;then
-	if [ -x "$WINEPATH/wine64" ] ;then
-	    WINE=$WINEPATH/wine64
-	else
-	    WINE=$WINEPATH/wine
-	fi
 	env WINEPREFIX=$WINEPREFIX \
 	    $WINE reg delete \
 	    'HKLM\Software\Microsoft\Windows\CurrentVersion\RunServices' \

Use this patch with the PKGBUILD.beta script from the post before in the same source directory by running

patch -p1 -i evesetup-beta.patch and then build, install the new package as described before.

– fly safe o7

Hi, just joined after I’ve read about the amazing job carried out by @Gharim_Turen.
I am fighting with the eve launcher since weeks without results.
Only here on the @Gharim_Turen’s post I found valuable replies but still I am not able to fix.

Here is my issue:

~/evelauncher$ ./evelauncher.sh 
QObject::startTimer: Timers can only be used with threads started with QThread
/home/stuffnex/evelauncher/./evelauncher: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

@Gharim_Turen already posted on this issue with:

You have on your system the libxcb* files always installed and these are not compatible with the xcb-libs from the launcher. Delete these libraries in your launcher directory with

rm -v ~/.local/lib/EVE/Launcher/libxcb*

and try again to start evelauncher.sh.

So I tried tho something went wrong:
Flagging the point that I have no such directory as ~/.local/lib/EVE but only ~/evelauncher, executed the command:

~/evelauncher$ rm -v libxcb*

and executing ./evelauncher.sh
Returns this:

~/evelauncher$ ./evelauncher.sh 
QObject::startTimer: Timers can only be used with threads started with QThread
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)

Trying to solve the issue I tried 3 linux distributions, I am lost but maybe I found finally a place and someone to address my issue.

Now some infos about my system and hardware to help out in troubleshooting:

$ uname -a
Linux b1d0n3 5.3.0-55-generic #49-Ubuntu SMP Thu May 21 12:47:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ sudo lshw -short
H/W path         Device     Class          Description
======================================================
                            system         20B3001XIX (LENOVO_MT_20B3_BU_Think_FM_ThinkPad S5-S540)
/0                          bus            20B3001XIX
/0/0                        processor      Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz
/0/0/2                      memory         32KiB L1 cache
/0/0/3                      memory         256KiB L2 cache
/0/0/4                      memory         3MiB L3 cache
/0/1                        memory         32KiB L1 cache
/0/5                        memory         8GiB System Memory
/0/5/0                      memory         8GiB SODIMM DDR3 Synchronous 1600 MHz (0,6 ns)
/0/5/1                      memory         DIMM [empty]
/0/44                       memory         128KiB BIOS
/0/100                      bridge         Haswell-ULT DRAM Controller
/0/100/2                    display        Haswell-ULT Integrated Graphics Controller
/0/100/3                    multimedia     Haswell-ULT HD Audio Controller
/0/100/14                   bus            8 Series USB xHCI HC
/0/100/14/0      usb2       bus            xHCI Host Controller
/0/100/14/0/4               communication  Bluetooth wireless interface
/0/100/14/0/5               input          Synaptics Large Touch Screen
/0/100/14/0/6               multimedia     Integrated Camera
/0/100/14/0/7               generic        VFS5011 Fingerprint Reader
/0/100/14/1      usb3       bus            xHCI Host Controller
/0/100/16                   communication  8 Series HECI #0
/0/100/1b                   multimedia     8 Series HD Audio Controller
/0/100/1c                   bridge         8 Series PCI Express Root Port 1
/0/100/1c.1                 bridge         8 Series PCI Express Root Port 2
/0/100/1c.1/0    enp3s0     network        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1c.2                 bridge         8 Series PCI Express Root Port 3
/0/100/1c.2/0    wlp4s0     network        Wireless 7260
/0/100/1c.3                 bridge         8 Series PCI Express Root Port 4
/0/100/1c.3/0               generic        RTS5227 PCI Express Card Reader
/0/100/1d                   bus            8 Series USB EHCI #1
/0/100/1d/1      usb1       bus            EHCI Host Controller
/0/100/1d/1/1               bus            USB hub
/0/100/1f                   bridge         8 Series LPC Controller
/0/100/1f.2      scsi0      storage        8 Series SATA Controller 1 [AHCI mode]
/0/100/1f.2/0    /dev/sda   disk           500GB HGST HTS725050A7
/0/100/1f.2/0/1             volume         511MiB Windows FAT volume
/0/100/1f.2/0/2  /dev/sda2  volume         465GiB LVM Physical Volume
/0/100/1f.2/1    /dev/sdb   disk           16GB LITEONIT LSS-16L
/0/100/1f.2/1/1  /dev/sdb1  volume         9215MiB Windows NTFS volume
/0/100/1f.2/1/2  /dev/sdb2  volume         512MiB Windows FAT volume
/0/100/1f.2/1/3  /dev/sdb3  volume         5542MiB EXT4 volume
/0/100/1f.3                 bus            8 Series SMBus Controller
/0/2                        system         PnP device PNP0c02
/0/3                        system         PnP device PNP0b00
/0/4                        generic        PnP device INT3f0d
/0/6                        input          PnP device PNP0303
/0/7                        generic        PnP device LEN2000
/0/8                        system         PnP device PNP0c02
/0/9                        system         PnP device PNP0c31
/1                          power          45N1165
$ lscpu
Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   39 bits physical, 48 bits virtual
CPU(s):                          4
On-line CPU(s) list:             0-3
Thread(s) per core:              2
Core(s) per socket:              2
Socket(s):                       1
NUMA node(s):                    1
Vendor ID:                       GenuineIntel
CPU family:                      6
Model:                           69
Model name:                      Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz
Stepping:                        1
CPU MHz:                         1227.809
CPU max MHz:                     2600,0000
CPU min MHz:                     800,0000
BogoMIPS:                        4589.55
Virtualization:                  VT-x
L1d cache:                       64 KiB
L1i cache:                       64 KiB
L2 cache:                        512 KiB
L3 cache:                        3 MiB
NUMA node0 CPU(s):               0-3
Vulnerability Itlb multihit:     KVM: Mitigation: Split huge pages
Vulnerability L1tf:              Mitigation; PTE Inversion; VMX conditional cache flushes, SMT vulnerable
Vulnerability Mds:               Mitigation; Clear CPU buffers; SMT vulnerable
Vulnerability Meltdown:          Mitigation; PTI
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1:        Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2:        Mitigation; Full generic retpoline, IBPB conditional, IBRS_FW, STIBP conditional, RSB f
                                 illing
Vulnerability Tsx async abort:   Not affected
Flags:                           fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acp
                                 i mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon
                                  pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 mon
                                 itor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt t
                                 sc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single 
                                 pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adju
                                 st bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts md_clear flush_l1d

I am not a knowledgeable linux user but I can read and I think to be only normally retarded. So far despite all my efforts nothing did work.

Sorry for the long post, I hope to be blessed by your wise advises an being able to log into space soon!
Thanks!

Based on your kernel data i suppose, you use Ubuntu Eoan or some derivat of this version (19.10). The xcb libraries on Ubuntu are splitted in some packages which are not all installed by default.

To find out which are missing go to your evelauncher directory and try following command (after you have deleted the xcb libraries there)

~/evelauncher$ env LD_LIBRARY_PATH=`pwd` ldd ./plugins/xcbglintegrations/libqxcb-glx-integration.so | grep -i not

This should show you the missing libraries. In my test are this only

libxcb-xinerama.so.0

but the error-messages are the same as you have posted before:

qt.qpa.plugin: Could not load...

Search these libraries with apt like so:

~/evelauncher$ apt search libxcb-xinerama

and install the listed package with

~/evelauncher$ sudo apt install <package-name>

HTH :slight_smile:

@Gharim_Turen, I am touching the sky with my shorter finger (lost in translation?).

Launcher is now working!! I can come back in space and have fun with you all but not just that, thanks your excellent explanation I learnt more about Linux and its environment!

Thanks a lot, sincerely

To add, setting

export QT_DEBUG_PLUGINS=1

can be useful for seeing what’s going wrong when looking at it. Recently used that to debug the same issue for something else. Ubuntu 20.04 was having it. Same fix with libxcb-xinerama

Also, if you run into black screens on startup (or after character selection , make sure to set download everything in the launcher settings, close the launcher, then reopen it. It’ll take a while to download 9GB or so.

Thanks for the advise about debug parameters for qt bug hunting :slight_smile:

Maybe i should set LauncherShouldDownloadEverything=true in EVE.conf for the first start after the installation from the launcher itself, but the disadvantage is, it will extend the download time for the first start of the game i think.

– fly safe o7

1 Like