EVE Installing


(Gharim Turen) #30

Did you have installing difficulties with my installer package or with the original launcher package on Kubuntu 18.04?


(Gharim Turen) #31

Website updated with an How to for the installer packages.


(Erasmus Grant) #32

Yes the launcher would immediately crash after starting


(Gharim Turen) #33

If he has crashed immediately without error messages, maybe it was the missing crypto libs which my evelauncher script symlinked by the first run and checked by every start after for presence.


(Spacecav) #34

Just ran this on my Ubuntu 18.04 install after trying for weeks to get the client working. Was prompted to install Wine and Winetricks and lo and behold, there is Eve Online Launcher in my applications and it started right up and downloaded the client after which the game loaded right up! Awesome work thank you so much!!


(Fecal Matters) #35

First off, great work! I’m noticing that every time I run the Launcher from my menu it is deleting the .eve folder under $HOME. The launcher then proceeds to download everything again. Have you seen this?

-Ignore- This was due to the ‘Download Everything’ setting being enabled, it will literally delete everything and redownload EACH TIME!!!


(Gharim Turen) #36

Have you changed the “SharedCacheFolder” setting in ~/.config/CCP/EVE.conf? If you start evelauncher.sh from your application menu the first time, it moves all downloaded resourcefiles from ~/.eve/ResFiles to ~/.local/lib/EVE/SharedCache/Resfiles and delete then the folder ~/.eve complete. This should only on the first start be happen, not every time, when you start it. Can you please post your ~/.config/CCP/EVE.conf? The setting “Download Everything” has nothing to do with this, it caches only the client data from Tranquility, Singularity and Duality, independed if you use the testservers or not.


(Fecal Matters) #37

Hrmm…after I removed the DownloadEverything setting in the EVE.conf file, well set it to False, it stopped doing it and all is well :slight_smile: Thanks for reaching out though!!! And thanks again for the work!


(Gharim Turen) #38

You are right with this “DownloadEverything” setting. I have it enabled today to see, wat happens.
After a restart of the EVE Launcher he would over 2GB on data download, so i have it disabled again and restartet the launcher. I thought, this setting for download client resources was this ingame under video settings, but it seems, this was not the case.


(Gharim Turen) #39

Next update for the Installer Package. After an discus about trust i have changed the needs of root permissions to extract the installer package. Root permissions are furthermore required for installing or removing the setup. Changed the check for crypto libs so it can handle broken symlinks in the launcher directory.

Updated Installer Package (Right Click “Save as…”)


Help Installing EVE on Ubuntu 18.04
(Gharim Turen) #40

Today i have the AUR packages updated to the same revision as the Installer Package. You dont need to update to this version if the scripts are working as expected, but if you want to update anyway then should an

sudo pacman -U --asdeps evesetup-1225328-2-x86_64.pkg.tar.xz

do the job.

Updated AUR Installer Package
Updated AUR Source Package
Checksums


(elitatwo) #41

Cheers! Thank you for your hard work!!


(Fletcher Ambrye) #42

you sir are a blessed soul. Thank you!


(Risar Surtr) #43

Thanks for putting this together. I get a pretty weird behavior, launcher starts but upon clicking ‘play’ the game itself just hard exits, UI elements spawn briefly and then disappear nothing past that happens, nothing notable in the logs. Arch with proprietary nvidia drivers, fully updated.

Anyone seen similar?


(Gharim Turen) #44

Did you have the 32bit part of the nvidia driver installed? Depended on the version which you use are this

lib32-nvidia-utils,

lib32-nvidia-390xx-utils or

lib32-nvidia-340xx-utils

Without this wine are not functional and it looks for me, that wine dies silently because it’s not found these drivers. It should be in the logfiles if wine try to access nouveau or something else. If you install wine from multilib it has no dependencies to the proprietary drivers, so you must install it for yourself. Have a look at the logfiles from the launcher.


(Gharim Turen) #45

After finding a bug which not update the evelauncher locale files after an update from the evelauncher himself i have updated my installer packages so that she handle now this situation.

AUR Installer Package
AUR Source Package

Installer Package (Right Click “Save as…”)

Checksums for all Packages

After changes on the login process on server side, the login with the linux launcher versions

  • 1225328

  • 1243388 (called as Beta in the Settings Menu)

dont work anymore, only login with the developer version from the linux launcher works atm.

After you have updated the launcher to the developer version (which i not recommend, but its atm the only solution when you must use the linux eve launcher) he will hang after trying to restart himself. The only workaround so far is to kill the evelauncher process and restart the EVE Launcher from the Application Menu again, so it can restore the deleted links and files which the updater has cleaned up during the update process. Solved with the last update. Please see the next post and replace downloaded packages if she are earlier than 2018/09/14 created.

Addendum:
Please have a look at this post Not able to login with linux launcher


[Solved] Popup window for log in not opening
Blank screen after trying to log on
Eve linux launcher
(Gharim Turen) #46

Today i have updated my packages again so she can now handle the problem, that after an restart of a updated/changed launcher he hangs again while the updater cleaned up the launcher directory. After an update he should now restart and after a new start from the Application Menu will evelauncher.sh restore the locale files and the steam_appid.txt in the launcher directory.

Download links in the post before have not changed, only the packages himself :wink:


(elitatwo) #47

Thank you for your work!


(Gharim Turen) #48

By handling the latest trouble with login failures and changing of launcher versions i have seen some glitches with the localization of the evelauncher. If you dont use evelauncher with locales like me then is this latest patch not necessary for you. The evelauncher will now handle locales correct when you change it in the Settings Menu.

Download Links are the same, version has not changed, only the date of building to 2018/9/16

On my website i have the Howto’s updated so it should be more precise, in which case which type of installer package are be usefull.


(Gharim Turen) #49

Fresh meat coming in. Have a look here EVE Launcher build 1385477 beta release for linux or on my website.