EVE Installing

I have it now tested on a Kubuntu 18.04 standard installation. Same as usual, installing proprietary drivers for my graphics card, wine-devel and winetricks. But this time with kdialog instead of zenity which btw are recommended not a dependency for winetricks as i expected. I can not recommend KDE for such things like play some games with wine, i prefer slim desktop environments like XFCE or MATE for that, but its only my opinion.

Developer script revised for more POSIX Kompatibililty and some bashisms removed.

I have now build an AUR package from my scripts, ready for installing or, if you wish, to build for yourself an AUR source package. Please be kind, this are my first steps with AUR and package building there. :slight_smile:

Last post i was a bit confused about the filenames of the archives, now fixed. Found on AUR an alternative concept to install evelauncher was maybe are in conflict with my solution, so i have it added as conflict package.

AUR Installer Package
AUR Source Package

Aleksandr uses the QT libraries from the repository for the launcher which are maybe not full compatible with the launcher. It may work or not, in my case i have with his solution some error messages on start which i have not, when i use the libraries which are delivered with evelauncher. So you decide, which solution you prefer. :wink:

1 Like

Finally i have build a distribution independed installer with makeself. It works on Debian Testing and need root permissions or sudo for installing and removing. For removing just call as root or sudo the installer again and he will remove the installation. Your settings in your home directory will be not deleted.

Installer Package (Right Click “Save as…”).

A little Update for the Installer Package, fixing some permission issues from the icons.
Download link in the posting before has not changed.

This worked for me on Pop_OS! 18.04 which is a heavily themed version of Ubuntu Gnome 18.04. I had issues with it on KUbuntu 18.04 launcher would immediately close out after opening.

@Gharim_Turen you are my hero and if you need a Patreon to keep up the good work and keep us Linux users in the fight let me know. We need more Linux guides so people can use their distro/desktop of choice.

@Gharim_Turen You are my ■■■■■■■ hero. @CCP_Falcon @CCP_Snorlax

OMG thank you so much!! Your launcher works like a charm and I can log on again. I cannot thank you enough for this!!!

Thanks for your replies but i have only build an installer which mades something easier to install EVE on Linux. :slight_smile: This where all not possible without the good work from @CCP_Snorlax

1 Like

Did you have installing difficulties with my installer package or with the original launcher package on Kubuntu 18.04?

Website updated with an How to for the installer packages.

1 Like

Yes the launcher would immediately crash after starting

If he has crashed immediately without error messages, maybe it was the missing crypto libs which my evelauncher script symlinked by the first run and checked by every start after for presence.

Just ran this on my Ubuntu 18.04 install after trying for weeks to get the client working. Was prompted to install Wine and Winetricks and lo and behold, there is Eve Online Launcher in my applications and it started right up and downloaded the client after which the game loaded right up! Awesome work thank you so much!!

First off, great work! I’m noticing that every time I run the Launcher from my menu it is deleting the .eve folder under $HOME. The launcher then proceeds to download everything again. Have you seen this?

-Ignore- This was due to the ‘Download Everything’ setting being enabled, it will literally delete everything and redownload EACH TIME!!!

Have you changed the “SharedCacheFolder” setting in ~/.config/CCP/EVE.conf? If you start evelauncher.sh from your application menu the first time, it moves all downloaded resourcefiles from ~/.eve/ResFiles to ~/.local/lib/EVE/SharedCache/Resfiles and delete then the folder ~/.eve complete. This should only on the first start be happen, not every time, when you start it. Can you please post your ~/.config/CCP/EVE.conf? The setting “Download Everything” has nothing to do with this, it caches only the client data from Tranquility, Singularity and Duality, independed if you use the testservers or not.

Hrmm…after I removed the DownloadEverything setting in the EVE.conf file, well set it to False, it stopped doing it and all is well :slight_smile: Thanks for reaching out though!!! And thanks again for the work!

You are right with this “DownloadEverything” setting. I have it enabled today to see, wat happens.
After a restart of the EVE Launcher he would over 2GB on data download, so i have it disabled again and restartet the launcher. I thought, this setting for download client resources was this ingame under video settings, but it seems, this was not the case.

Next update for the Installer Package. After an discus about trust i have changed the needs of root permissions to extract the installer package. Root permissions are furthermore required for installing or removing the setup. Changed the check for crypto libs so it can handle broken symlinks in the launcher directory.

Updated Installer Package (Right Click “Save as…”)

1 Like

Today i have the AUR packages updated to the same revision as the Installer Package. You dont need to update to this version if the scripts are working as expected, but if you want to update anyway then should an

sudo pacman -U --asdeps evesetup-1225328-2-x86_64.pkg.tar.xz

do the job.

Updated AUR Installer Package
Updated AUR Source Package