EVE Isk Per Hour Industry Program - Version 4.0

tool

(Niriam DoT) #103

Unfortunately, you will have to reinstall IPH to start over, possibly even remove the folder after uninstall with all of it contents


(Imustbecomfused) #104

but I cannot full screen the application? I dl’d this and installed, updated it. worked first go. just noticed though I cannot expand this to full screen? any reason why that is not a function of this app? I ahve lovely monitors and would be a shame to not use that real estate, this is quite a pretty looking app here.


(Zymex) #105

What does the ME/TE and Cost % on the FACILITY tab do? They do not seem to affect anything regarding prices when I change them.


(Sokoton) #106

ISK Per Hour has always had a fixed window size. I suspect it would be a nightmare to support auto-positioning of all of those controls. I am also unsure of Visual Basic’s native tooling for such repositioning.


(Imustbecomfused) #107

that sux… most programs now adays actually let you use your entire computer monitor.


(Sokoton) #108

ME should affect the quantity of materials required. Note that for an EC you may need 100+ of a particular material to notice a difference.

TE affects the time required to build the item.

Cost % affects the job cost for the item.


(Zymex) #109

On the FACILITY? Not the blueprint.


(Imustbecomfused) #110

to the OP:

I really really appreciate that you made an hour long video tutorial here… that was very thoughtful of you. I dl’d it from youtube for personal reference. Cheers mate! Donation sent


(Tzar Sinak) #111

I have uninstalled and deleted the folder plus deleted the program from the CCP site too. Unfortunately I cannot get back to the step of this in order to update the port:

IPHEntryWindow

Am i SOL?


(Niriam DoT) #112

I’m out of ideas then, probably should wait for OP to answer this


(Niriam DoT) #113

Yep, facility has ME bonuses too.


(Suzuki Yotosala) #114

im having an exception message on windows 10 pro x64 when i try to load iph, it was loading before, it may be some settings issue

Source: EVE Isk per Hour
Message: An error occurred creating the form. See Exception.InnerException for details. The error is: Specified cast is not valid.
Raw Error Text: System.InvalidOperationException: An error occurred creating the form. See Exception.InnerException for details. The error is: Specified cast is not valid. —> System.InvalidCastException: Specified cast is not valid.
at System.Data.SQLite.SQLiteDataReader.VerifyType(Int32 i, DbType typ)
at System.Data.SQLite.SQLiteDataReader.GetDouble(Int32 i)
at EVE_Isk_per_Hour.ManufacturingFacility.DisplayFacilityBonus(ProductionType BuildType, Int32 ItemGroupID, Int32 ItemCategoryID, String Activity, FacilityTypes FacilityType, String FacilityName)
at EVE_Isk_per_Hour.ManufacturingFacility.LoadFacilities(Boolean NewFacility, String& FacilityActivity, Boolean& AutoLoadFacility, String OverrideFacilityName)
at EVE_Isk_per_Hour.ManufacturingFacility.LoadFacility(Int32 ItemGroupID, Int32 ItemCategoryID, Int32 BlueprintTech, Boolean BPHasComponents, Boolean LoadDefault, IndustryFacility DefaultFacility, Boolean ComboSelect)
at EVE_Isk_per_Hour.ManufacturingFacility.InitializeFacilities(FacilityView ViewType, ProductionType InitialProductionType)
at EVE_Isk_per_Hour.ManufacturingFacility.InitializeControl(FacilityView ViewType, Int64 SentSelectedCharacterID, ProgramLocation FormLocation, ProductionType InitialProductionType)
at EVE_Isk_per_Hour.frmMain…ctor()
— End of inner exception stack trace —
at EVE_Isk_per_Hour.My.MyProject.MyForms.Create__Instance__[T](T Instance)
at EVE_Isk_per_Hour.My.MyProject.MyForms.get_frmMain()
at EVE_Isk_per_Hour.My.MyApplication.OnCreateMainForm()
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
Error Tracking:


(Ishaki) #115

I am having a problem with adding characters. I registered the program and have all of the right scopes saved. Using port of 12500. I go to add a character and I get a successful message in my browser but the select character window never changes, it stays blank. I tried directing it to two different browsers and completely uninstalled the old version, including deleting the eveiph folders in the various other spots and profile folders and no luck. Any ideas what I am missing?


(Sarah Aran) #116

I’m also having issues registering a character with the program. I can chose a character to log in with, I hit authorize, and then it redirects me to a blank page with the message “127.0.0.1 sent an invalid responce.” The port number 12500 shows in the address bar and is saved in the registration information.


(Lagair en Marland) #117

Hey, I’m really happy to see the program back up and running. I was wondering if there was a way to show my running research jobs. I’d like to be able to see time remaining on the jobs and what jobs are running on all my chars. It shows my actual manufacturing jobs, but for research it just shows 8/10 or whatever.

Edit: Actually, I was wrong. For some reason the Current Industry jobs window isn’t even showing my manufacturing jobs. The char pane is showing that the chars have jobs running, but nothing is showing up in the main pane.

Link to image of problem: https://imgur.com/a/CqLqkP0

As you can see, there are jobs running for the chars, but nothing is showing in the main pane.


(Gonzo Zirud) #118

When trying to change the settings such as disable sound or the default ME it throws an exception error.

An Unhandled Exception has occured and EVE Isk per Hour will now close.

Please fill out the following information so I can reproduce the bug

What is your Operating System?
What tab or screen did the error occur?
What are the steps to reproduce the Error?
Web link to a screenshot of your error:
In addition to a screenshot, copy the data below and send to developer.

Source: EVE Isk per Hour
Message: Object reference not set to an instance of an object.
Raw Error Text: System.NullReferenceException: Object reference not set to an instance of an object.
at EVE_Isk_per_Hour.frmSettings.btnSave_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Error Tracking:

Also when changing between blueprints it is selecting it on the selection bar but not in the calc, you have to reselect it again to change the calc.


(Rhys Onasi) #119

I’m also having that issue. I tried playing around, noticing the instructions page pictures had https instead of http, that led to a different error and the authorization page never appeared.

Can’t seem to get past selecting a character to authorize before it fails.

EDIT:After troubleshooting in EVE-IPH chat, I determined two things:

First, the 127.01.01 callback seems to be being blocked by chrome by default, once i made Mozilla my default browser it began displaying success messages.

Second, it still didn’t actually do anything, so I deleted my entire EVE-IPH folder and reinstalled and in combination with above, it worked.

EDIT2: Reinstating chrome as default, if I add a second character I get the same error message, but the character is added anyways with no visible issues. For anyone having issues I recommend reinstalling IPH, I know I tried just using the updater at first, but maybe doing an update after a year breaks it.


(Victor Raketov) #120

I do not have a tick on the tab “ignore in calculations Invention” and prices are not counted Invention . If you enable this check box in the blueprints tab, the IPH value will match the tab Manafacturing list without this tick.
(Возможно плохо перевел с русского)


(Sarah Aran) #121

Having to change default browsers seems to be a bit much just for a utility. Also, not sure why this app has such a convoluted process to register compared to say Pyfa.


(Zifrian) #122

Because he built an embedded web server to use one client and secret key registration for everyone. I didn’t want to do that due to security issues (and my limited experience with it) so I chose to have everyone register the program. Others such as EVE Mon have done the same.