EvE Online website doesnt work

So I thought this morning, hey it has to have just broken, but nope it still doesn’t work.

How exactly are you supposed to attract customers when the first website they log on doesn’t work at all?


Btw Falcon nice article you posted that links to the website. Too bad it doesn’t work when you actually click it because it goes to the website. Of course why would anyone actually check right?

Still believe there are testers? Then you haven’t been paying attention.

P.S. expect some excuse about internet explorer.

It works for me…

1 Like

I checked on mine and my wifes and it doesn’t work. Well it works for a second or two and just blank screens. Website does same thing without the link.

Works fine for me and haven’t seen anyone complaining in the official thread.

So my guess is, that it is your setup that is the problem.

Have you tried a different browser ?

Unplug and replug in your computer…
Works for me on Chrome.

Worked on Torch for wife but still didn’t work on Internet Explorer.

The games her and I play both are few.

There are testers - you’re the one who haven’t paid any attention at your ISP connection! :stuck_out_tongue:
The site works just fine, i just checked the IE too, no problems at all.

Sounds like there is a loose connection on your internet browser.

Try hitting it with a hammer and report back on the number of beeps you hear


You can tell me all day there are testers but after that last event I will never believe you.

What version? 11?

Internet Explorer doesn’t really exist any more. It’s discontinued but still maintained. Unless you’re talking about Microsoft Edge?

I’ve tried this on four different machines I have at home, on IE11, Edge, Chrome, Firefox, Opera. All of them work.

You might want to take a look at how your machines are set up.

If you still can’t figure it out, it’d be a good idea to contact customer support with a technical ticket.


Works great for me.

Tried on W10 and IE11 … see same problem as below:

with and w/o Adblock Plus enabled. At least zKill is happy.
https://secure.eveonline.com/ loads fine.

Question for the IE11 users who don’t have a problem: do you have the official JavaScript installed? I don’t. The pages have a ton of JS.

The browser contains the engine that interprets and runs the javascript. You shouldn’t need to install anything separately.

However, different browsers run on different engines, which is why you might see some issues using different browsers.

That’s weird your right that separate page loads fine.

I am just using internet explorer that comes with windows 8 IE11.

No I don’t have java anything.

Only just noticed this. Do you really suggest that CCP should test every possible variatiion of every possible browser on every possible operating system release, on every possible combination of hardware and software, through every possible ISP ? I wouldn’t be surprised if the number of possible variations of the above exceeeded the number of people on earth - and you still feel that this failure is aimed at you personally ?

1 Like

Lol, there is no “official JavaScript” you can install, that is built directly into modern browsers. Do you mean the Java plugin? That’s something different and not used anymore in browsers.

Also even with noscript enabled (blocks all javascript) it still shows an animation for me and says that JavaScript has to be enabled. So that can’t be it.

Hi Falcon,

I have this problem as well. I have posted in the Issues subforum about it. There are a couple of people that have reported this in the ingame Help chat as well.

It does seem to only affect a few people, I’m on Win 8.1 and using IE 11. The odd thing is that dev blogs and news announcements worked fine until yesterday and it is only now that I am seeing this issue - as stated by others, click on a dev blog and I see the blog for a split second then the browser window goes black.

I’ll raise a support ticket.

Sometimes Chrome is too busy uploading your documents and email to let you use the computer :rofl:

Amen to this. Open Chrome with only 1 tab and go look at your task manager. There are about 8 Chrome processes running.

I somehow still use it. Is there a “better” browser?