EVE Planetary Planner

Turns out simply waiting worked… kind of. I’m no longer in the update loop but now I’m getting this error when I start:

Version 8.6.10.1

Failed SetStartPosition Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at System.String.System.IConvertible.ToInt32(IFormatProvider provider)
at System.Convert.ToInt32(Object value)
at EVEPlanetaryPlanner.MainWindow.SetStartingPosition()

lol, not lucky.
Ok, I’ll see what I can find about that one.

Thanks for still trying :slight_smile:

1 Like

@Ideki thanks so much for what must be hundreds of hours of work on this. I just installed the latest version and when i try to add an API key I get this:

Version 8.6.10.1

Failed Add API

Could not load file or assembly ‘Microsoft.Extensions.Options, Version=2.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

at EVEPlanetaryPlanner.API.ESI_API.InitClient()
at EVEPlanetaryPlanner.MainWindow.<TextButton_AddAPIClick>d__6.MoveNext()

ugh…
I hate it when you fix something and then everything else breaks down.

Thanks @Janso_Ambrye.
I will take a look at it.

@Janso_Ambrye Can you try the latest version I uploaded?

I have downgraded the NewtownSoft.Json version I am using to match the EST.Net version.
I was able to reproduce the issue when I was loading the release version, but not the debug version.
After the downgrading the issue was not happening again.

@Ideki it worked! SOrry for the delayed response. THanks for looking into it. Now to dig in and start using this thing. Thanks again for all the work on this!

Also, I just had this happen when trying to import planets to Planets Plan via ESI:

System.Exception: Failed to retrieve ESI data
at EVEPlanetaryPlanner.LoadingAPIPopup.GetColonies(ESI_Character pAPI, Dictionary`2& pCommandCenterLevel)
at EVEPlanetaryPlanner.LoadingAPIPopup.b__48_0(Object sender, DoWorkEventArgs args)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

Doesn’t crash the tool or anything though, so I’m gonna my planets manually.

Please kill me, that would be the merciful thing to do at this point! :smiley:

Thanks @Janso_Ambrye, I’ll check what is going on.

What? Noooooooo way. Then who would I report the bugs too? :rofl:

Just downloaded this and I can’t seem to be able to update prices at all. Doesn’t matter if I have a region or not, or a system or not. The label to right of the refresh box also says “Failed”. I haven’t wired in my API key yet, if that matters.

Version 8.6.10.2

While refreshing prices: Object reference not set to an instance of an object.

Heya bud,
Not sure if you’re still monitoring this thread. I’m getting an error when I try and Load planets from API in the Planets Plan. Not sure if I’m doing something stupid.
I’ve “found” the planet in the “Find” tab. It is a wormhole system so I don’t know if that makes a difference?
I’m tearing my hair out with this :smiley:

Hi @Tremitry_Darkstar sorry for the later reply.
Was it a fresh install?
Did you try with a region selected?
Also, there should have been a popup with an error message showing.

Does it still happen ?

Hi @Seraline_Torkonis
So if I understand well, you setup PI in a wormhole but the API crashes trying to load your planets?

I think I had a couple people that were doing PI in wormholes before and they did not report any problems.

Can you post the error message here?
It might help me figure it out.

I have fixed a couple of issues related to loading API with expired tokens and well as starting position.

I also improved the API loading to be able to fill the extractors with products quantity and timer.

I’ll probably post a new version by the end of the weekend.

Version 8.6.11 is available.

  • API is now loading extractors installed product, quantity, duration and number of heads
  • Fixed exception when starting with an expired API token
  • Fixed exception loading window position