EVE won't launch on M1 MacBook Air [With Temporary Solution]

In the Settings / Graphics, turn OFF Post-Processing option, that should largely get rid of the larger white textures. Doesn’t cure all, but helps a lot.

If I run native-mac in my 8G RAM M1 Macbook Air , maybe it can run more fluency than @petal Everbloom’s, who run it through CrossOver.
Am I right? haha.

I haven’t figured out how to get it running natively, CrossOver works just fine for me.

Is there any indication when there might be a native client released (or at least one that doesn’t require wine?) Just trying to figure out if this could be right around the corner, months, or possibly not even this year? I just let my omega status lapse as I have yet to be able to get it to work with wine and i really don’t feel like spending even more time on it just to have an emulator running inside an emulator in the end.

I understand that the formal response from CCP is “Soon ™”

It’s in the works

And as always


So attempting to run this through Crossover 20.0.4 on my MacBook Air M1. Installed it through the CrossTie in a Windows 7 64-bit bottle. The launcher loads, updates and begins to download the client, but I only get a white screen.

Has anyone been able to work around logging in with this issue.

Scroll back through the post. Someone talks about one of the wine version working and no need for crossover. Wine 4.17(?)

1 Like

If you run with log files it should work.

I run on my MacBook Pro M1 with Wine 4.17, and no problems.

I can confirm that the current Mac launcher runs fine using Wine 4.17

1 Like

Confirm ! It works

The launcher works - but I am wondering if it feels extremely slow for anyone else?

I’m having one problem, but I’m not sure if it’s just a general mac issue. I’m trying to run in windowed mode on my large monitor. But it will only accept 1024x700. The settings show windowed mode, but I can’t resize the window. Any clues how to change the size of the window?

Same here, can only run on 1024x700 or full screen, this on M1 mac. Issue with full screen is that when i click in other app, the window closes. So that is quite annoying. Have seen some solutions to change Yamel file, but this did not seem to work on the M1. So really would appriciate a solution here :wink:

1 Like

Try enabling hardware acceleration if it’s not on already.

Where is that option?

I’m in the process of downloading xover and the eve launcher, but I’m getting errors that c++ redistributabless can’t download? is there a workaround for this or it doesn’t matter…?

Thank you I am going try this work around I really hope this works really want to get back into EVE Online no update on the macOS Clint since December

Do we have any update on a native Mac client yet? Anything for us M1 users?