Big Sur and/or M1 chip

Does anyone know if the EVE Mac client will work under the macOS Big Sur update that is coming out today? I’ve searched, and some folks say to go to Preferences in the Wine Client and choose the developer release, but I didn’t find a way to go to Preferences in the Wine client.

Also, will the EVE client work with the new M1 chips released by Apple?

2 Likes

You should see this while you are at the EVE Launcher.

After that, select the Use dev versions. I have been on this since Big Sur Beta 2 and has been serving me extremely well.

*Since this is my first post, I can’t do more than 1 embedded image :frowning: *

To answer your question, Yes Eve Mac client works well with Big Sur, to iron out some WINE minor issues, consider running the dev versions.

EVE Client might not work with the new M1 CPU due to the lack of Aarch64/ARM64 support by WINE. For this we got to see if it will be able to run under the Rosetta 2 emulation.

1 Like

Thanks! Much appreciated!

I know some guys in a local Apple reseller and they were testing different apps and games on one of the 13 inch MacBook Pros with the M1 chip. The EVE Launcher will run, but Wine will not at this point. Avoid buying a new Mac with an M1 chip if you are planning to play EVE on it.

I would always suggest double checking the EVE Technology and Research Center and vise versa when it comes to Mac and their issues.

1 Like

Thank you! This issue resolved my issue of “Game client closed unexpectedly.” Much appreciated.

Intall crossover 20.0.2 with 64 bit client, works on me with no issues at m1 mac mini with big Sur 11.0.1

I have a MacBook Pro just purchased with M1 chip. Latest updates from Apple applied to Big Sur. I still cannot get the client to launch. The launcher starts but the the client will never start up.

Have tried to set preferences to latest in Wine and also tried to set to developer version latest and 5.7, but it never helps.

Any way I can resolve this?

Hi, think we ( I have a new MacBook pro M1 as well ) are out of luck until sometime around March 2021.

They are building a Mac version now (see here) the first version ‘should’ work with the M1 chips. But if not it will be a little later.

Got MacBook Pro M1 with latest updates. Didn’t even get answer on my support ticket (2d atm).

Having the same set of issues… even with the new build. The client won’t launch and the logs have this in them:

    Traced at:
<pre>/carbon/common/lib/autoexec.py(126) <module>
<pre>/packages/monolithsentry/minidump.py(17) set_sentry_crash_key
<pre>/packages/monolithsentry/tags.py(16) get_tags
<pre>/packages/monolithsentry/tags.py(84) get_client_tags
<pre>/packages/gpuinfo/__init__.py(1) <module>
<pre>/packages/trinity/__init__.py(33) <module>
<pre>/packages/trinity/_singletons.py(14) <module>
<pre>/packages/trinity/_trinity.py(100) _ImportDll
<pre>/packages/trinity/_trinity.py(53) _RobustImport
<pre>/packages/trinity/_utils.py(9) Quit
<pre>/packages/logmodule/__init__.py(618) Quit
reason = 'Failed to import _trinity_stub_deploy ("ImportError(\'No module named _trinity_stub_deploy\',)")'

In fact, just avoid buying Macs. Why do people still buy these expensive, impossible-to-repair, mangled , fragile Unix monstrosities?

Cue the ‘s***s on macs guy’.

Idiots like you show up in nearly every thread mentioning macs in every forum in the history of the world. You are tiresome and unoriginal in your trolling.

Here’s one reason: software engineers that want to build web apps and enjoy the fact that homebrew exists along with applecare.

Go back to your ubuntu high horse, or are you an unsophisticated knuckle dragger using winblows instead?

This is the same post as another forum thread, just wanted to post it here. Changing the wine version was confirmed by another user to work. Let’s hope it lasts or gets fixed in the current launcher version

I have the Latest and greatest big sir version as of today Version 11.2.1

This worked for me, I do not have any additional programs to run eve. And even today I tried to run the default launcher and it failed. I think changing the wine version is what worked

Open the launcher, but do not launch an account

With the launcher window selected, Go to upper left hand of your desktop (next to the apple symbol) and left click the words “EVE launcher” …like you want to get info on the eve launcher

Second option down is “Preferences”. Click it

I have “use system configuration for proxy” selected

“Use dev versions” selected

And I changed the “wine version” to :

wine-4.17-staging-winehq-binary-208

2 Likes

Boo! I just updated Big Sur (11.2.3) and now the Dev version doesn’t work ho hum…

I am using a MacBook with Big Sur 11.2.3 and the Dev version of Wine mentioned above. This is working perfectly for me!

On a MacBook Pro M1 here with the Dev version of Wine mentioned. It works but I do get a kernel panic now and then. It was said somewhere this is because of a memory leak which makes the whole system crash and reboot after a certain amount of time. I’m not sure if this is exactly the case. A seldom time a kernel panic can occur after 15 minutes of playtime already. Looking forward to being able to play with the beta of the native client. Probably in Q4 I guess.

if I had a penny for every time I had to pay to get over “mac, not game machine” bridges.

Thank you.
This is working M1 mac 11.3 (20E232),
I also set memory to 1gig
and under tools/cache to version type set to release
enable addition laucher logs unchecked

1 Like