EVE won't launch on M1 MacBook Air [With Temporary Solution]

With help of some magic, I’ve been able to run EVE on M1 chip.

I fully reinstalled the client and used CrossOver option to run eve client with flags and wrote logs to file.
Somewhy client stuck during the upgrade process if I click anywhere so I just let it go until the “launch” button appears.

That might not work for others, or maybe I miss something important, but it finally works!

You have to use the launcher version 1850297 and stop it from downloading any new version until they fix it.

Any ideas on how an older launcher can be downloaded?

I have found that if you right click the eve launcher icon in crossover, and then click run with options, then click create log file that it works.

1 Like

Has anyone had issues with 64 bit applications on Crossover 20.0.4 on Big Sur 11.3 public beta (1 or 2)? I had things running great until I decided to try the Big Sur beta (in hopes of resolving my bluetooth issues. and accidentally cleaned up the wrong bottle. Now Crossover chokes on bottle creation, and CodeWeavers blames Apple for “a bug” (that’s the level of detail I got from them)

A native Eve client sure would be nice…

[ETA: So it seems that the issue I encountered was with installing with the 11.3 beta. I dropped back to 11.2.1, re-installed, upgraded to 11.3 again and It ran just fine until the launcher upgraded itself.]

would love it if you could get EVE Online running on Apple Silicon … thanks keep us updated.

Latest and greatest big sir as of today 11.2.1

This worked for me, I do not have any additional programs to run eve. And even today I tried to run the default launcher and it failed. I think changing the wine version is what worked

Open the launcher, but do not launch an account

With the launcher window selected, Go to upper left hand of your desktop (next to the apple symbol) and left click the words “EVE launcher” …like you want to get info on the eve launcher

Second option down is “Preferences”. Click it

I have “use system configuration for proxy” selected

“Use dev versions” selected

And I changed the “wine version” to :

wine-4.17-staging-winehq-binary-208

2 Likes

Did you get it to work without cross over?

Yes. I do not own that program

I’m on a Mac mini m1

I had downloaded “wineskin winery” on my own and downloaded the latest 3 engines:

WS11winecx64bit20.0.2

Ws11winecx20.0.2

WS9winestaging64bit5.7

While trying to get a different game running

I did nothing related to eve with the wineskin program…just wanted to mention I downloaded those engines

Please ask questions and I’ll tell you what I know or what my settings are…but I don’t really know what I am doing…this was dumb luck for me

i have testet it right now. You just need to change the Wine Version to wine-4.17-staging-winehq-binary-208. After patching it works

No extra Download like wineskin or similar needed.

1 Like

How can I patch it??

Edit: i found it and is working well!!!

thanks a lot Slam! Also on MacBookAir M1

Working fine - but CCP should do something to not loose the Mac-Users

Can confirm if you set the wine version to this in the launcher settings it works. No cross over or third party software needed.

Apple M1 Native client cannot come soon enough though.

Would anyone be so kind and make a small guide on how to get EVE going on an M1 under wine pls ?

Edit: nvmd just got it going facepalm

Has anyone been able to get Eve running at more than 1024x768 when in windowed mode on an M1 MacBook Air? I also tried fixed window mode, but that made everything disappear.