FIX THE FKING LAGG

ITS BEEN A WEEK SINCE THE GAME KEEPS LAGGING… AND DONT TELL ME TO DO TEST NET AND SH1T. COZ MY INTERNET WORKS PERFECTLY…

2 Likes

Try turning the audio off, worked for me. Not ideal by any stretch of the imagination but CCP gonna CCP

2 Likes

and turning off something so important as the incoming warning sounds shouldn’t be considered a valid workaround, not in the short term nor long. IMHO

1 Like

You are aware there is a bunch of internet between your ISP and CCP’s servers right?

does this mean I gotta lag for a week straight?

No it means just because your local connection is good doesn’t then mean the problem is all at CCP’s end.

This isn’t as a defense of CCP, just as a reality that it may not be a problem at their end either.

Its something, I logged in last night and every gate jump was a weird black screen event across both toons and this morning the market took forever to update orders when it is normally a quick cup of coffee operation. For Reference, I am US East Coast, Have a newer gaming rig and expensive top end internet service because the entire family works from home, so its not me or my provider. Its probably the damn Triggs. they aren’t done f-ing things up.

Have you tried switching off the audio? I’m getting client freezes where the FPS drops from a solid 75 to sub 20 but when i switch off the audio this seems to fix it. Obviously this causes gameplay issues though…

Not doing that, CCP can fix it, I’ll suffer until then. I would rather know when an enemy is warping on me than the both of us having no sound.

Every gate jump, either a black screen or freezes for a long time, eventually running the gate timer out and leaving me on the other side helpless. Have had one DC. Cannot plot courses because my location tab refuses to work and it remains blank trying to load. Countless (and I do mean countless) lags and freezes whether in combat or not. All over a period of a couple of hours. This persistent problem needs to be fixed. Other games, even those based in London or elsewhere in the EU, run fine.

I got disconnected from one of my alt today. Not gonna play till servers are fixed…

Fix the FKING LAGG. Make the game run so we player can play the game. Stop All development of New initiativets and action before the games works

I’m also getting weird freezes since the last patch