(Fixed) AMD Vega 3/R530 swicthable gpu issue

I’ve just purchased a laptop with amd Vega 3/R530 switchable gpu hardware. I’ve learned that gpu runs on V3 in general to save power and switch to R530 when gaming. However this does not happen while playing Eve. I’ve noticed that when I check the performance tab of the task manager while playing Eve, I see V3 is running on peak while R530 is not doing anything which is supposed to be the complete opposite.

My laptop model and specs: HP 15-DB1000NT Athlon 300U 4GB Ram 256SSD 2GB Radeon 530

I’ve looked the issue up on several forums and learned that there are alot of people who had the same issue with different brand/model laptops and different games.

This is really annoying because the game is not utilizing dedicated 2GB R530 gpu and instead trying the run the game on onboard V3 (512mb base vram+virtual memory) which causes poor performance.

The things I tried that did not work:

  • I did a clean install of gpu driver.
  • İnstalled lateset chipset driver.
  • I’ve set the laptops power option to high performance.
  • From desktop- right click – display settings – advanced settings I tried to add eve.exe and eve launcher as a high performance app.
  • I tried to add Eve manually to Radeon settings game library and chose gaming mode. Started the game from Amd software. Amd software does not recognize Eve automatically which is a another issue imo.
  • I disabled and uninstalled V3 while keeping R530 from the device manager which ended up in disabling both gpus.

I read that there is no way to manually select/force R530. Also read that this is a Win10 related issue so I’m thinking of installing Win7. But I want to try that as a last resort.

Can anyone help me with this?

Open the Settings App (in windows)

Go to System - Display - Graphics Settings (at bottom of page)

Add EVE client from “EVE\SharedCache\tq” folder and set to high performance.

Hi Sordina, thx for the reply but that didn’t work either.

I installed a secong 4gb ram to boost apu performance (and it did) so I guess this will have to do for now.

I solved it and I want to share it for people who might encounter the same issue.

Here are the steps:
1- Use AMD uninstall tool to make a clean uninstall.
2- Then check your laptop manufacturers support site for drivers -specific to your laptop model-. This part is important. DO NOT go and install the lates drivers from AMD. I found mine on HP’s support site and installed that which is actually an older driver called “AMD Picasso”.
3- After you install this driver, launch AMD settings app then launch Eve while this app is open. When the app recognizes eve.exe, choose “high performance” setting for the .exe on “Switchable Graphics” menu.
4- Enjoy high shader-60 fps explosions and nebulas!

My fps shot up from 30s to stable 60 fps on the same settings. My task manager/performance tab finally show R530 is active and working at peak performance! So there is that :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.