Freezes on CCP Intro screen thingy

I tried the environment variables thing and it didn’t work for me. Only an issue since last update.

I had the same issue since the last update/patch, fixed mine by uninstalling my recording software.

Which recording software did you uninstall may I ask?

Hi folks

I’m not part of the launcher team but have been involved in some of the discussions as we (launcher / engine) often investigate these issues together.

While this isn’t going to be the case for everyone, we have noticed a rise in 3rd party software which has started to interfere with both the launcher and the game client, causing them to stop launching.

In a log above, we can see “VK_MIRILLIS_LAYER” which likely relates to ‘Mirillis Action!’. We have seen this software inject and intercept calls that has caused issues with launcher and client launching. We have spoken to a few players who have confirmed removal fixed their issue.

While we will always try to work around this so you can get back into game if we can, we are quite limited in what we can do when external software injects into the launcher and client. There is simply no way we can anticipate what this process will be doing, or how it will interact.

For anyone that is having launcher or client launching issues recently: See if there is any 3rd party software that could be interfering. Typical examples include: Screen recording software, overlays (CPU/Memory stats), voice overlays (who is speaking), and multiboxing software. Try disabling / uninstalling to see if the issue persists.

While I appreciate that most people in this thread have probably already done so, updating your GPU drivers is also important. We see a number of issues from laptop users who run graphics card drivers that are years old. Even if the GPU is integrated into the CPU, it will still have drivers available with important fixes.

1 Like

Hi CCP Caffeine

Firstly thank you for replying to this post. In my instance I can confirm that although Action! was working previously with EVE no worries for at least six months, that removal of the application has allowed the launcher to load.

I am however wondering if you could please let me know if there is something specific I can point to that is causing the interference with the EVE client so I can raise the issue with Action! support.

Cheers,

Asahaar

Hi

I’m glad to hear that it resolved the issue.

I would suggest looking to see if there is an update to the software first, as we tried to replicate it internally, but could not. It looks like there have been frequest updates, some of which include stability fixes: https://mirillis.com/action-history

We found the fix through examining logs and asking others to give it a try. Given that we can’t replicate it internally, it may be some specific combination of driver version + software version which causes the issue.

The heart of the issue is how the software works (via attachment of a process / injection).
The specific problem is related to when we check for what hardware GPU acceleration is avaliable (The launcher has this as an option, along with the client requiring it), which the software intercepts and causes a problem.
Unfortunately, this interception is out of our hands (much like if anti-virus was causing a false positive). While I’ve personally not used the software, there are a few options that would resolve the issue:

  • Find why the software crashes when intercepting the API call and fix it
  • Allow the option for a whitelist and whitelist the EVE launcher and game
  • Give the option to capture without the injection at all

I know very little of the actual software I’m afraid, so I can’t comment past that point. If you contact them and they require assistance, I would be happy to provide them with the information we have.

I’m running into the same issue.

Reinstalled the game several times, cannot launch through Steam. I tried running the Launcher as an administrator. Still nothing. I tried downloading the launcher stand-alone and the installer won’t even launch. I can’t discern what the problem is and I was just charged another month for a game I can’t even launch on my PC.

Ryzen 9 3900X
32GB DD4 3.2GHz
RTX 2070 Super
1TB SATA SSD