=FUNCRES.XLAM!_xldudf_EVEONLINE_ / xldudf_EVEONLINE_ Errors and maybe a fix

If you get the functions replaced by xldudf_EVEONLINE_ on desktop we figured out a way to help with it.

If a mac user with a similar issue can test it out too that’d be great.

Basically go to Options → Addins

Disable the Analysis Toolpak and the Solve add-in (or all of them)
The eve addin does not use any of these that appear in that section, as evident by my own settings.

It’s likely a restart of excel is required to unbind the save logic, and potentially a fresh workbook.

Please tell us if this helps, so we can add it to the official FAQ. :slight_smile:

Hello, I have been plagued by funcres lately. When I remove all of the Solver/Analysis Excel Add-ins the formulas will change from the FUNCRES.XLAM!_ or =EVEONLINE.functionname into 'C:\Program Files\Microsoft Office\Root\Office16\LIBRARY\Analysis\FUNCRES.XLAM'!_xldudf_EVEONLINE_functionname .

The only work around I have found so far is removing then reinstalling the add-in each time I reopen my workbook that is affected by this.

If I disable the Solver and Analysis add-ins and attempt the same uninstall/reinstall for the add-in there is no change.

To test, I built a new workbook and if I open it and disable the ‘Analysis ToolPak’ the add-in functions will append the 'C:\Program Files\Microsoft Office\Root\Office16\LIBRARY\Analysis\FUNCRES.XLAM'!_xldudf_' to the start of them, even if they were working formulas before.

If anyone knows of a workaround to fix this I am desperate for one!

Thank you.

I’ve found the issues in the office-js github and the latest news is that there is a patch late december that might solve this. (It’s been an issue since 2021.

Here is the thread for anyone interested in the details, the gist is that the VBA or older addins conflict with the registration of custom functions.

It’s possible that doing “Reload” might fix any formulas in the sheet that are corrupted like this.
(You have to hover around that top spot and hit the arrow on the sidebar, it’s an “i” button in mac)

My workaround was to do a mass find replace of

C:\Program Files\Microsoft Office\Root\Office16\LIBRARY\Analysis\FUNCRES.XLAM'!_xldudf_EVEONLINE_



I even resorted to a small macro that I could run on the tab to just do it automatically. I haven’t seen the issue since disabling the Analysis Toolpack and Solver Addins though.

Hi y’all, hope your holidays went well. I ended up stumbling upon a similar approach to what OldGuyMonty has suggested and it has worked for me so far.

I first disabled all of the unnecessary addins from excel then went through and removed all of the broken appended text to the fomulas. Once everything was in EVEONLINE. format, I saved a copy of the workbook and was able to close & reopen it without and further issues.

Thanks for the help!

1 Like

I didn’t have the other addons enabled. Tried a blank workbook as well. Still broken.

Microsoft released a fix for new workbooks in this patch. >=16.0.17126.20064.

Anyone encountering it can try to update and see if it happens.

“The fix already released to CC(preview) version, please check if you are on Insider and Office version >=16.0.17126.20064.”