Game client assigned to ____ has closed unexpectedly, redux

Brankos BasCelick had a similar problem in Sep '22, but I didn’t see a resolution. I went through all the steps suggested, but I still can’t get past the launcher.

Steps I’ve taken so far…
(1) deleting both caches
(2) fix permissions
(3) running launcher as admin
(4) uninstalling base game (directly from CCP), and reinstalling through Steam
(5) full game download
(6) used LogLite
(7) updated every driver I could find
(8) Tried logging in to different toons, including the generic “Steam User xxxx”

I still get the “Game client assigned to _____ has closed unexpectedly” pop-up, and Loglite is showing “Client crashed with exit code -107374091”. The only thing left to troubleshoot, that I can’t figure out, is why the launcher is showing up in Task Manager as the 32-bit version. Is there a unique 64-bit launcher I need to use?

Any suggestions would be appreciated!

More info, for reference. I believe this meets the system requirements, but if I’m missing something let me know!

And, finally… a (temporary?) solution! I Google’d “how to disable the integrated graphics of the processor in the device manager”, and a few clicks later I’m in.

If this results in the complete destruction of my laptop, my processor, and/or human civilization itself… that’s fine with me. At least I get to play for a little bit longer.

Well… I made it through the character-creation screens. But as soon as I tried starting the -actual- game, the launcher crashed again with the exact same error. So this wasn’t a fix.

Turns out, Intel has an “Arc Control” which lets you download patches and updated drivers for the Iris chipset… and that’s all I needed. I’M IN!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.