Game is laggy recently?

I’m not sure if it’s just me? My home internet is fine, Every other website and game runs fine.
My resources look fine, the games running smoothly fps-wise and it’s barely using 50% of my memory.

The only thing thats odd is on the Network Data Monitor in game, the Machonet ping sometimes spikes to 1000+. And I cannot figure out why.

It’s making things like D-scan take sometimes up to 5 seconds to go off, it’s making the Hacking minigame in exploration take multiple seconds to register button clicks. The market doesn’t load snappily. These issues have only started occuring recently after like 2 straight weeks of No issues.

Any advice? I tried verifying the game, I tried clearing the unused files from the shared cache.

Not sure what you think anyone here can do about a slow node on your route.

Maybe find and contact the owner of that node and ask them to reboot it?

True. Boris is cooking his soup on his server and it tends to overheat.

@Taiga_Xelos you might want to read this posting about latency.

So to clarify with everyone. I posted here because I checked and it is NOT an issue on my end, or so I thought. I found a solution tho.

Apparently there’s an option in the launcher to Fully install in the game…and that fixed my issue.

2 Likes

Kudos for you. Also shut the launcher down once the game starts, it caused me a bit of lag too. Running a browser I am not looking at is pointless, takes up RAM, and CPU threads. If you need the launcher again during the game, you can open it again.

Fly safe o7

1 Like