Game launches with CCPs wine, not my own

As the title said, the game launches through the launcher if I use the CCP wine from the settings on the launcher menu. However, if I choose to run with my own mine, the launcher never runs the game.

Suggestions? I have installed the latest wine and configured it to XP

Try windows 7, rather than XP. As Eve doesn’t support XP any more.

Open a shell and type “winecfg” and set windoze to windoze 10.

In the launcher settings, set wine settings to “latest”.

Windows 10 did no launch either. Will try 7 later today.

It is normal if using the dev wine to run almost unplayablely slow?

Will try later today. the path for wine in the launch settings is fine with just wine?

Yes.

With your incredible detailed description of your hardware it is always a yes.

The “Windows XP”-mode setting works for me.

Maybe start by telling us which version of WINE you are using and the distro you are on. And be sure to use the 32-bit version of WINE and not the 64-bit version. You can see the WINE version when you run winecfg and check the ‘About’ tab. Your distro’s package manager will tell you if it’s 32-bit or 64-bit.

A heads up: you need a 32-bit version of WINE 3.0 or newer for EVE to run with the standard Windows installer.

While you probably mean well … don’t. The standard Windows Client for EVE only works in “Windows XP”-mode. The “Windows 7”-mode of WINE and higher currently fails to run it.

My bad :smiley:

Well, this is on the same machine that can run max settings on my windows hard drive, so yeah the hardware is not a issue.

Im running Ubuntu 16.04 and wine 3.0. I believe I have 64 bit wine. could be the problem.

Changed to the 32 bit of wine. Still no luck with the launcher. I selected use custom wine and have the path as just wine.

wine set to XP. laucher still not launching game.

Using wine32 on a 64-bit PC and Debian/Ubuntu requires one to add i386 as an architecture to the distro. It’s not just a matter of changing a couple of packages, but it will pull in a lot if i386 libraries, which are essential for wine32 to run. I’m assuming you’ve done this.

Now, when you say launcher, did you in fact delete the old installation? I don’t know if one can transition easily from 64-bit to 32-bit, so I recommend you start with a clean installation of the EVE client.

If you’re not sure about how to install wine32 then look here:
https://wiki.debian.org/Wine#Step_1:_Enable_multiarch

Most Windows application, even those which say they’re 64-bit, still use a lot of additional 32-bit libraries. So you definitely have to get wine32 running.

Also, I have followed the instructions. I deleted my current wine and the CCP version of the EVE launcher. I have redownloaded wine and it now shows wine 1.6.2

I will try to go grab the CCP launcher again from https://wiki.eveuniversity.org/Installing_EVE_on_Linux

No success. Here is the terminal errors when opening the launcher before trying to even launch with my own wine.

I fear I am doomed to play on windows.

[0402/205221:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/liquid/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/liquid/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[0402/205221:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[0402/205314:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/liquid/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/liquid/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[0402/205314:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.

This right here will be a problem. You need to get yourself a recent version of WINE first. WINE 3.0 was said to work. I myself use 3.2 and the current development of WINE is already at 3.5. So your version of 1.6.2 is pretty old really and likely too old.

You will have to download a recent version of WINE directly from WineHQ and won’t find it with your package manager, because your distro (“16.04”) may not have anything newer.

Take a look here for how to get a recent version:
https://wiki.winehq.org/Ubuntu

Yes. I had the 3.0 but deleted and redownloaded per https://wiki.debian.org/Wine#Step_1:_Enable_multiarch

I will again deleted and redownload tonight. ty for your help so far.

You must have done something wrong. I’ve tested it and I can assure you 3.4 and 3.5 are working with “Windows XP”-mode. I’ve just tried it even though I’m fine with what my distro offers me.

For anyone reading here, this is how you can install WINE when you get it from WineHQ… Assuming you have a 64-bit PC will you need to download 3 files:

For WINE 3.7 on Debian 10 (“Buster”):
https://dl.winehq.org/wine-builds/debian/pool/main/wine-devel_3.7.0~buster_amd64.deb
https://dl.winehq.org/wine-builds/debian/pool/main/wine-devel-amd64_3.7.0~buster_amd64.deb
https://dl.winehq.org/wine-builds/debian/pool/main/wine-devel-i386_3.7.0~buster_i386.deb

Same here, you do NOT need:
wine-devel_3.7.0_buster_i386.deb

The three files contain the 64-bit binaries&libraries ( wine-devel-amd64_*_amd64.deb ), the 32-bit binaries&libraries ( wine-devel-i386_*_i386.deb ) and the loader ( wine-devel_*_amd64.deb ).

After downloading the three files do you need to install each one of them either as root or with the help of sudo. But first will you have to add i386 as an architecture when you haven’t done so already:

dpkg --add-architecture i386

Then you do and in the same order as shown here:

dpkg -i wine-devel-amd64_3.7.0~buster_amd64.deb
dpkg -i wine-devel-i386_3.7.0~buster_i386.deb
dpkg -i wine-devel_3.7.0~buster_amd64.deb

WINE will then be installed in /opt/wine-devel/. Make sure your desktop icon points to it or set your PATH variable to include /opt/wine-devel/bin.

@Liquid_Entropy I’m assuming you’ll have to get the files for Ubuntu 16.04 (“Xenial”) from here:

https://dl.winehq.org/wine-builds/ubuntu/pool/main/wine-devel-amd64_3.7.0~xenial_amd64.deb
https://dl.winehq.org/wine-builds/ubuntu/pool/main/wine-devel-i386_3.7.0~xenial_i386.deb
https://dl.winehq.org/wine-builds/ubuntu/pool/main/wine-devel_3.7.0~xenial_amd64.deb

Best of luck!

And to show off and say “I haz pr00f”:

Edit:
Latest update to Debian 10 “Buster” now provides WINE 3.5 as default for the wine-development package. So one can now just stick to the distro’s original packages and doesn’t need to get the files from WineHQ. Unless of course you’re already going for WINE 3.6 …

Edit2:
Updated the links for the packages as these now have changed and all contain a ~-character.

Very detailed ty. Will try here in a short while.

I don’t know what kind of weird setup you have running but I never had to do any of this.

It was a fresh install and other than installing the ia32libs (only works with Ubuntu other distros based on Ubuntu) and mono, there is nothing else I need to do but start the launcher and log in.

That’s because you run Mint.

Debian runs on x86 32-bit & 64-bit, ARM 32-bit & 64-bit, MIPS 32-bit & 64-bit (and both little endian and big endian), PowerPC, Power, S390, Hitachi SuperH, Motorola m68k and Sparc 64-bit.

Because Debian has support for all these different architectures was the support for x86 32-bit moved into its own category a while ago. So in order for a Debian distribution to manage x86 32-bit packages (aka i386) next to x86 64-bit packages (aka amd64) does one need to add it as an architecture to a distribution with:

dpkg --add-architecture i386

Your Mint, while its based on Debian, has dropped all support for these other architectures, possibly blurred the line between 32-bit and 64-bit for their users to no longer notice a difference. Or perhaps you’re running a 32-bit and not a 64-bit distro. Hence you don’t know of any of this.

In other words, when you install Debian as a 64-bit distribution then you get a pure 64-bit OS, and you need to explicitly run the above command before you can mix 32-bit code with 64-bit code.

Insult me one more time and your time here on the forums is over.

I studied computer science in college - on Fedora and Debian.

My machine runs on a 64bit architecture, so I can use most of my 16GB of DDR4 memory. And just so you know, Ubuntu also runs on ARM.

1 Like