Intel programs like Spyglass in Linux

For the life of me I can not get Spyglass to work or Vintel to work under linux. Both keep telling me they can not find the chat files and keep giving what would be the windows location. I am running eve under steam.

Not sure how to tell the program where the chat files are or find another intel program that works. Both of these programs I believe have not been updated in some time. I did have Vintel working under windows before.

Oumpaa

Try starting spyglass like this:
python spyglass.py "$HOME/.steam/steam/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/My Documents/EVE/logs/Chatlogs"

Same thing with vintel:
python vintel.py "$HOME/.steam/steam/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/My Documents/EVE/logs/Chatlogs"

Make sure the file path is correct.

Ok I tried this with both from terminal and nothing seems to happen. Believe I have python 2.7 installed

Sorry, that method is for when you are running the program from source code.

An alternative solution:

In the terminal, enter this command:
ln -s $HOME/.steam/steam/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/My\ Documents/EVE $HOME

Then, run the program like you normally would, by double clicking it or using ./spyglass-linux-1.0.0.run

Ok, so spyglass didn’t work for me with wine or native. Both spyglass and vintel for linux require some old packages i’m having trouble finding like PyQt4.QtWebKit.

What does work is the windows version of vintel running with wine, so here is how to do that:

Make sure you have wine installed.

Download the vintel windows executable here https://github.com/Xanthos-Code/vintel/releases/download/1.2.3/vintel-1.2.3.exe

Open the terminal and create a symlink to your chatlogs like so:
ln -s $HOME/.steam/steam/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/My\ Documents/EVE $HOME/.wine/drive_c/users/toshiba/My\ Documents

Navigate to your downloaded vintel executable and start it with wine like this:
wine vintel-1.2.3.exe

ok that got me ten times closer to it working, Now I get Vintel failed to execute script error

Got it working thank you so much. I had to go in and erase the eve direction along with the chatlogs and then reload eve and then it worked. I guess the logs must have been corrupted or something.

Is there a way to make a link I can run from the desktop to run the program instead of having to use the terminal each time I want to run vintel? Like back in the days of dos I used bat files a lot, Kind of like text files that ran like scripts.

[Desktop Entry]
#!/bin/bash
wine “/home/andrew/downloads/Vintel-1.2.3.exe”

Made this and it works like a charm into a text file. So I can run Vintel with out having to use the terminal