Inventory not loading

Anyone else having this problem? I just get the spinning wheel that never goes away and it is happening on each of my accounts. Anyone know of a fix?

There seems to have been an uptick in random problems over the past 3 or 4 days. So, it’s possible that the problem is on their end. I suggest filing a support ticket and bug report. However, since it might take them a while to get back to you, try clearing the cache. If that doesn’t work, try doing a reinstall.

Also, please come back and tell us how you got this issue resolved. Might help the next guy with the same problem.

1 Like

I didn’t try to clear cache, but I got impatient and did uninstall/reinstall which fixed it. Thanks for your help.


Had this same problem months ago after assembling a new station container. The “load” spinner just kept spinning. Even from another station the items from that station were never viewable. Simple relaunch (after closing launcher) fixed it, without clearing cache.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.