Is there a clear way/procedure on how to remove WINE completely?

I was reading the 1FPS thread yesterday night, and thought about it, and perhaps I could try it, but then I read that it requires to have Wine-Staging, so that then you can do the procedure to add dxvk to wine (that’s as far as I understood).

Anyways, decided to check which wine I had, and I don’t understand how again I was stuck with the wine3.6, as I had already imported the new key so that I could use the latests wine.

Furthermore, for some idiotic reason, I remember installing the stable wine, and following undated threads off the internet (so many things to read and none with up to date info, not even at the winehq page, I could never find there step by step instructions on how to delete the whole thing)., so… for some idiotic reason, I have wine devel 3.6… and I have no idea why.

I kept perusing and trying different options, and ended up using synaptic to uninstall everything wine… but is still there and it still even works. I didnt play last night thinking that I must have screwed the installation with all the different commands and the stupid output I still get…

Out of frustration, I was going to wipe the whole install and start over from scratch, but then, today, I remembered I had to restart my PI :frowning: so I brought the launcher and the clients work.

So, I was hoping… any of you know a current and up-to-date howto (web page prefferred) so I can try one more time to destroy wine and start over? If not, then I’ll wipe the partitiion and start from scratch. But Im really confused on how I got 3.6 when I had installed the latest stable version, which is past version 4.

Any ideas?

I’m guessing that, since you say you uninstalled all things wine, that you’re using the steam version that synaptic wouldn’t know anything about.

I do feel for you, as you’ve clearly spent a lot of time searching the internets for the answers. This is actually the biggest detriment to eve on linux – too much dated/incorrect/poor information.

Using terminal you could probably toss something like:
locate wine

and find unholy numbers of files; but it might give you some hints as to what is under /opt or whatever.

If you want to completely wipe your wine environment, I would suggest deleting the entire /home/[username]/.wine directory.

As far as wine packages are concerned, this is going to be distribution-specific. In Arch Linux, it will be “sudo pacman -R wine” or “sudo pacman -R wine-staging” depending on the version you’re running. You may also need to remove any dependencies as well.

You shouldn’t have to completely format and re-install your entire OS, but that isn’t a terrible idea from time-to-time.

Well… no, I had installed regular wine, and I am sure I did install Wine Stable. I remember in 16.04.6 I had a problem once with the key, so after I had working an up to date wine, with that key problem, it swapped my wine down to 3.6, but I never noticed the change untilll a few months later. Then, I followed the winehq.org recommendation to update the key and doing the update I got it back to a more normal release 4.x.

On this 18.04 I decided to not do the steam install, nor lutris. I didnt even put the Padoka drivers, I left it as stock as possible. Thats why I was very surprised to find that I had wine Devel 3.6… as 3.6 would indicate another problem with the key, so I redid that key thing but this time it didnt update to the more recent Wine Stable.

Winehq.org doesnt mention how to switch from Stable to Staging. But I did try to do the install --recommends thing, only to get greeted with an error regarding some dependency… which then pointed to Wine Staging 4.13, which is what gave me away the version problem.

I used a command I saw about apt list, and it also showed the Wine Devel 3.6 version, which I then tried to remove, and thats when I started to get greeted with errors like I had broken packages, so I went to another webpage… that listed 6 ways (or 7) to fix that, and none fixed it…

So then I tried synaptic, found the offending ‘wines’ and uninstalled them, and then I also deleted the .wine folder completely. But, next day, decided to run the launcher and load a client… and when I saw it worked, I did a restart and after restart… I did the winecfg and I got greeted with the 3.6 version again (only on the winecfg window doesnt say its devel).

It is very confusing not having up to date info on these matters.

Anyways, I did locate wine… and it found wine on the .wine folder, obviously, but then I have zero wine references in the /opt folder, which is where wine is installed as per the winehq.org ubuntu page. I went to the OPT folder directly and I have a browser plugin only, nothing else.

Aside of the .wine, the locate wine command also mentioned things at: /usr/ (which looks references to desktop and/or icons) and /var/lib (these are the repositories…)

Theres nothing else. Yet wine3.6 works.

Thats why I feel is more apropiate to delete everything and start over. Its just a nuissance I didnt want to get into.

@Sabrina_Winslow deleting .wine doesnt delete the wine, I had read that it doenst really delete wine, just some settings, and when I run winecfg it recreates the folder (and contents). The problem is, I dont completely know which command I need to run because theres nothing up to date in terms of commands to run and what to eliminate to completely get rid of it. I tried, and its still working even though its not installled.