Issues with Ryzen 5950x

Hey friends,

Upgraded my PC last night to a Ryzen 5950 and having issues only when I undock.

In station is perfect FPS, but as soon as I undock it turns to a slideshow. Not just low FPS, but it freezes every frame for a second, it’s unplayable. There is some sort of technical issue and I’m thinking possibly as the CPU is very new.

Latest GPU drivers, lat est windows updates, latest firmware, BIOS and MB drivers. Reinstalled EVE on different drives. Same issue. Also tried g-sync on and off. No change.

Played the game for years prior on my old i7 no problems.

ASUS B550 mb
Ryzen 5950x CPU
32 GB DDR4 3600MHZ
Asus 1080ti graphics
500gb Evo Pro SSD
Windows 10 64

Only thing I have not tried is reinstalling Windows.

Anyone else had similar issues?

It looks like people have been complaining about stuttering in different games on Ryzen CPU’s. I looked through a few search results, and people were suggesting some very different fixes. So I don’t know. I would need to to sit down and do some research, but I don’t feel like doing that right now. I might, maybe do some research later. In the meantime, I suggest doing a google search for “Ryzen Stuttering Fix”.

Also, please come back and tell us how you fixed it. Might help the next guy with the same issue.