Game stuttering and fps dropping

I am experiencing poor frame rate, stuttering and spikes in frame time on one of my EVE installations. I have been using a different computer for several weeks and just returned to this one to find the game unplayable. The frame rate frequently drops below 60fps, and regularly tanks to 0 with frame times upwards of 500ms as reported by the in game FPS Monitor. This happens during any activity out in space or in station, though the busier the visuals the more frequently it happens. It affects all accounts on this installation only. It occurs at all graphics settings, even with CTRL+SHIFT+F9 super potato mode enabled, though more frequently at higher settings. System ran fine at high graphics settings, with multiple clients, prior to changing away from this machine at the start of December, nothing has changed other than allowing the launcher to automatically update.

Hardware
Xeon E5-3630 V4 on an ASUS X99-E WS 3.1 motherboard,
32GB Memory,
EVGA GTX1070 SC Black

All hardware is running within acceptable temperature ranges (40-60C), runs fine with other high intensity applications. CPU ssage <10%, memory usage <30%, all storage <80% full and not reporting any SMART issues, no background tasks running at more than 1-2% CPU and memory usage.

All drivers are up to date, and graphics drivers have been reinstalled, directX has been repaired using the Microsoft redist, EVE installation has been wiped and reinstalled. All with no change.

Turn off windows game mode and make sure your in game settings are “interval one”

Just disabled game mode with no noticeable effect, stuttering is still present. Have been in ‘interval one’ the entire time, though stuttering is still present on ‘interval immediate’

Hi there, I have been experiencing the very same issues since March 21

Still no fix

I’ve kept a log of everything I’ve found and everything I’ve tried here

I had seen your thread and read the first few months but it seems to affect me more than just on gate jumps, it happens even when docked. I’ll have a read through the rest of the thread now though in hopes of some helpful nuggets.

Interestingly the problem appears to be intermittent, sometimes it resolves itself and runs smoothly, and others it stutters more frequently. It isn’t even consistent and restarting the game client can cause the problem to appear when previously running smoothly. I cannot find any logic behind when it runs smoothly and when it doesn’t.

Hi, CCP done something horrible with audio engine, i don’t participate in large battles about 3 month, but yesterday i become participant in 600+ battle and my client become unresponsive after i jump in system CTRL+SHIFT+F9 dosent help, white window , task manager → end task, after restart 1 fps… but cpu load 20% gpu 1-3%, i start searching and find that disabling audio, fully restore client functionality and response.

so try to disable audio in setting, and please answer if its helps, lets CCP see there is problem.

At some point they removed the setting to limit the number of sound sources which now causes the client to basically shut down in anything even approaching a bigger fight.
Our SOP now is to yell in fleet coms to disable audio before any battle that involves more than 200 people.

Thank you for the comments about the audio engine issues. I was intending to try out your suggestions before replying, but somehow the problem has gone away without me having made any changes. If it returns I will try disabling the audio engine.

So the problem has returned, and I have identified that is only happens when on a voice call in Discord at the same time. For some reason being in a voice call (even when not talking or anyone else talking) causes the game to stutter massively whenever focused, particularly when the mouse is moving. When not focused on the game it is perfectly stable (i.e. when tabbed to another monitor). When not in a voice call it is perfectly stable (even if Discord is open). Disabling the audio engine has had no effect.

I can confirm the sound engine NEEDS an overhaul. On my high end PC with a dedicated sound card installed, the game stutters and the sound pops when first logging into the game and undocking, jumping thru star gates, in a large fleet battle or occasionally large NPC site, etc. It tends to somewhat smooth out after playing for a little bit but is still terrible to the point of having to shut down the audio in game for fleet engagements unless you want to risk losing your ship.

I brought this up to one of the devs / ccp on reddit and it seems they’re aware of the issue and it’s being worked on. I only hope a fix comes sooner than later.

1 Like

Two other causes, mixed refreshrate panels and Discord with HW acceleration on a lower refreshrate monitor. The GPU output signal gets throttled to the slowest panel, meaning massive stutter/fps drop on the main monitor. This ofc includes browsers, other eve clients. Anything HW accelerated.

The discord call animation is HW accelerated, disable discord HW acceleration in the settings.

Number two cause.
Freesync/Gsync/Adaptive sync. Due to a programming bug by CCP who never accounted for the technology. When switching between clients with a sync technology on, the clients incorrectly report which client is the active one that needs to be synced after, so you get the backgrouns clients throttled FPS as your refreshrate which persists until client restarts.

Disable adaptive sync technology

Try looking at the audio settings for your soundcard, I had mine set at 24bits due to music production stuff and had stutters but after setting it back to 16bits the problem is gone. But all in all, it surely is an audio bug because potato mode does nothing, if I set the soundcard back to 24bits and jump, huge FPS drop that can be seen on the ingame FPS monitor, but with the 16bits setting it’s only a minor FPS loss due to loading. Maybe this will help? But I guess few folks have their audio set to 24 bits…