Jumps to item does not match jumps listed in market

Market tells me an item for sale is, say, 3 jumps away.
I buy item and set destination.
Item is actually 15+ jumps away.
A 5 minute trip becomes 30+ minutes.

Why is this happening?
What’s the point in being able to sort the sellers list by jump distance if the listed range is false?
How do I stop this from happening?
I suppose I could set the destination before buying, if I remember to do so.
But the list is not sorted by actual distance, so how am I supposed to find the nearest item without manually setting destination for every seller in the list?

Do you have settings to avoid certain systems or regions?

1 Like

Your route might be set to avoid lowsec or other systems.

To check, click on the “A” next to your route and see which options are ticked. If any “avoid” options are ticked then it means your route will automatically try to avoid those systems or types of systems (even at the cost of re-routing you on a longer trip).

You can also go down to “manage route” which will show you if you have any specific systems on your avoidance list.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.