Launcher crashes after today's update(SteamPlay Linux)

I am running the Lutris (Windows) Version. I simply reinstalled it and then did this:
The Launcher in the Lutris Version is a week old. That’s perfect.

After Installation i copied ~/Games/eve-online/drive_c/EVE/Launcher to a safe Location.
Then i started EVE. The Launcher downloads the Update. I cancel the Update and start the Game.
Everything works just fine as long as i don’t update the frickin Launcher.

Just in case i accidently don’t abort the Luancher-Update i have a secure Copy of the old Launcher. I can simply replace the new one with the previously secured one.

Atleast this is working perfectly for me.

To go back to my original question - How do you install windows software on Linux ?
Also, what Linux are you using ?

It’s their right to support whichever OS they choose. It’s my right to decide if I want to subscribe, and to complain when they no longer unofficially support stuff they’ve unofficially supported in the past (e.g. CCP Snorlax).

You tried the installation from the linux launcher using the Uni Wiki instructions. Maybe you have the same problem which i have described here Linux Installer not creating conf files It’s the same error again and again, i’m tired to repeat myself.

The linux launcher work on my installation with one bug: he never stop his initiated processes (namely QtWebEngine processes) after i have close him but this can be handled with killall evelauncher at this time.

I use the Windows Version of EVE using Lutris and POP OS.
To install the game just register with Lutris, search it and click download.
It will install automatically.

Thanks Neo but i prefer the linux launcher because the windows launcher looks for me like a foreigner on my desktop. I like the same look and feel on all desktop applications so far as possible. :slight_smile:

P.S. Maybe i should open a new thread here about my project at AUR evesetup (don’t be afraid thats on AUR, the sources includes build scripts for other linux distributions than Arch based ones) The old thread is closed in the meantime Eve Installing

I can confirm that applying
to wine-staging-6.2 on gentoo works. no modifications required, just download the above and follow
after rebuilding with the patch I was able to update and run the launcher without issue; I didn’t even have to override any dll’s, clean prefix.

Obviously this doesn’t help users of inferior distributions; but I didn’t have to modify the patch to work with the specific wine version, I really expected this would be more of a mess and I would have to manually generate a patch file based on this one; I didn’t. If your using ubuntu derivatives the only hurdle you’ll have to overcome is building something from source; you won’t have to figure out how to generate a patch file yourself (at least for the moment).

Please do open up a thread, I’m glad your in this one; it deserves a dedicated thread. I’ve looked to that AUR in the past attempting to get the linux native launcher running in gentoo but ultimately gave up (given I didn’t try very hard, I wanted to run the latest version of wine and get dxvk/gallium-nine setup as well).

It would be nice to have a dedicated thread to ask questions; I still want to revisit that and try to make an ebuild (gentoo equivalent of an AUR build script).

■■■■, i don’t have the slightest clue how to compile Wine myself. Tried several “Tutorial” but it seems i’m too dumb to understand it :frowning:

You don’t need to compile wine for yourself. Actual wine will do like here

P.S. EVE are only for this screenshot in window mode and 60fps are the limit from my display :frowning:

Thanks folks. Whether I ever I get this working or not, I’d like to make a point of expressing my appreciation for all those who are trying to help - a true community.

So you say like actual Wine does work without having to patch it?
What branch? Stable or Developer?

Most of my configuration can you see on the screenshot. Manjaro use the Developer branch of wine without special patches afaik. So the Linux launcher should work like here, i’m using it and i’m not talking about the Windows launcher which i have no clue about it.

Just tried the Developer Branch a few Minutes ago. It’s Wine 6.2. Doesn’t work on my POP OS :frowning: I get stuck on Check GUI. Well i am using the Windows Launcher.

It’s the windows version of the launcher, try the linux version. Oh and btw, build wine on Debian based Distributions is a mess but not impossible :slight_smile: You must just go through the dependency-hell, nothing more :smiley:

I will give it a try. I was using the Lutris (Windows) Version. So i didnt have to install all the Wine and DXVK Thingies. That was the most interesting Challenge for me.

I used the Linux Launcher and it works without any problem.
I use Wine 6.2 Developer and had to install Winetricks and DXVK.

This was my source: Installing EVE on Linux - EVE University Wiki

P.S.: I had serious Issues to get DXVK running with EVE Online but finally it’s working now.

Nice to see, that it works finally on your system. For the problem described some posts before with no closing processes after ending the launcher itself i have written an ugly but working hack which maybe are from interest:

~/…/EVE/Launcher >>> cat


appname=`basename "$0" | sed s,\.sh$,,`

dirname=`dirname "$0"`

if [ "${dirname%$tmp}" != "/" ] ;then


"$dirname/$appname" "$@" &

if [ -x "$(which lsof)" ] ;then
	sleep 10
	until [ "$(lsof -t -u $(whoami) -a -c /evelauncher$/ -- \
			$HOME/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB/https_launcher.eveonline.com_0.indexeddb.leveldb/LOCK)" = "" ]
		sleep 10
	kill $(lsof -t -u $(whoami) -a -c /evelauncher$/)

It’s a changed script which need lsof to work. lsof are used to check every 10 seconds, if evelauncher’s QtWebEngine process has accessed his database lock file. If you close evelauncher so you close the GUI and the QtWebEngine his lock file. In this case are now kill used to terminate the evelauncher processes launched by the actual user.

Disadvantage of this hack are, you cannot use “Close to Systray” anymore, but minimize the launcher window to taskbar works as always.

To those confused here with the linux/windows launcher differences…

The linux native launcher is a native linux program, but ONLY the launcher. What the linux launcher does is pull in a specific version of wine that the developers apparently greenlight, but this version of wine is extremely old, and I’m not sure if current versions of dxvk or gallium-nine work with it; this is why some report performance differences switching to the linux native launcher, it’s because it’s pulling in an OLD version of wine to run the eve client.

The bug specifically effects the LAUNCHER not the eve client that the launcher starts, so the linux native launcher is not affected by this bug. The eve client itself is NOT native; it’s being run inside of a specific wine version that the linux launcher chooses.

What this bug effects is running the WINDOWS launcher directly with wine, which many people choose to do for performance reasons. When you start the WINDOWS launcher with a modern version of wine, it also uses the same modern wine to launch the eve client.

I’ve heard it’s possible to switch the version of wine that the native linux launcher uses, but I have not tested this as I can’t get it to run at all in gentoo, though that doesn’t mean it’s impossible it’s just a lack of effort.’

Edit: The reason this thread is so large is because running the launcher with wine instead of using the linux native launcher seems to be a lot more popular. I imagine that is because the linux launcher is not very well maintained and does not work out of the box on nearly ANY system. As far as my tries go it seems to be looking for old versions of library dependencies, you might have the right QT libraries installed, but because the native launcher is so far out of date and unmaintained it fails anyway because your libraries are too new.

This was just my appraisal of the situation the last time I tried, I gave up quickly because running the windows launcher directly with wine in addition to giving better performance, is simply easier; or it was until this bug anyway. It just worked. No games needed to be played.

Edit2: I don’t want to crap too much on the linux native launcher here, I appreciate the devs effort on it, any effort towards linux native is good, but considering the lack of maintenance on it, and how difficult it seems to get running on any distribution , I think that effort is misplaced. The devs time would be better spent towards simply ensuring the launcher and the client run in modern versions of wine; which aside from this bug, they already do.

If anyone bothered to test this with wine before releasing the launcher to the wild in the update, it would have been immediately caught; and debugging it I imagine would have been easier than writing an entire native linux launcher, just to have it pull in an ancient version of wine to run the actual client. They are already ensuring the client runs in wine, and in an ancient version at that, via that linux native launcher. Not to mention the linux community here pretty much works for free debugging it anyway, we seemed to have nailed the exact problem in less than 24 hours.

I’ve been running EVE through wine using the Windows installer/launcher for years (2015), every now and then a bug like this will stop it from working…

Currently running:

  • ArchLinux
  • Nvidia vulkan dkms
  • wine-staging 6.2-1
  • msvcp140_1 override
  • wine patch 199525
  • vcrun2019
  • d3dx9 - as a backup
  • dxvk
  • libstrangle - vsync only available at interval 1 for nvidia prime sync setups at 144hz/fps for my panel… gets a bit hot when running 3 clients at 144fps and works around window freezing issues in wine under dxvk and prime sync
  • EveOnline Windows Launcher

With the following start command:

NODEVICE_SELECT=1 DXVK_HUD=0 DXVK_STATE_CACHE=0 DXVK_LOG_LEVEL=none WINEESYNC=1 WINEDEBUG=-all WINEARCH=win64 WINEPREFIX=~/Software/eve-dxvk strangle 30:20 -k wine64 /home/username/Software/eve-dxvk/drive_c/EVE/eve.exe

Launcher broke today after updating for me. I’ve tested on ArchLinux wine-staging 5.22 through to 6.2-1 all refused to start the new launcher, reverting to an older launcher works fine if you cancel the update quick enough.

Overriding the msvcp140_1 dll in winecfg got the launcher to show Failed checking GUI version error page, and when setting wine to debug level “all” the following network error printed out to the point my terminal lost any history:

039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08

As a few have mentioned a patch is now available for wine, however you need to know how to build it which isn’t for every linux user, wine can take a while to build and you’ll need to combine both 32bit and 64bit. Patch details:

For anyone running Linux+wine+windows-launcher on an ArchLinux based distro i’ve compiled a quick patched version, alternatively review and use the PKGBUILD if you want to run a makepkg -sri yourself:

Obviously review and use at your own risk. Feel free to hit me up about running eve on linux and any fixes/patches you know, trying to compile a new up-to-date guide.

Personally i’d rather stick with the windows launcher and fix any issues with Wine / DXVK etc unless the game was to release a linux native version entirely (not just the launcher). As a software dev I can completely understand why the ccp devs wouldn’t want to support running their software under wine, however it would be nice if they could setup a testing community program with a group of us. I’d be more than happy to report bugs to Wine and help liaise and fix issues. I dislike having to reboot into windows just to fire Eve up while trying to work on projects in the evening :sweat_smile:

Edit 1 - overriding msvcp140_1 not needed after checking on original prefix with patched wine and no override.

1 Like

Just dropping my post from the other thread, as it might be useful for those who use Manjaro/Arch Linux.

This is somewhat the same as the above, except I use Proton-GE-Custom (aka GloriousEggroll) instead of wine-staging. It’s basically Proton + wine-staging + additional fixes and has been super reliable for me.