Launcher crashes after today's update(SteamPlay Linux)

I used:

One thing to note it almost seems like there is something strange about the path your error is looking for. When I downloaded the old launcher I put it in the wine prefix c drive with Eve and ran it with the same parameters as I would launch the Eve launcher normally with.

All I get is this:
Cannot open file “C:\EVE\EveLauncher-1850297.dat” for reading: File not found.

Kinda reinforces my decision not to pay for games/subscriptions which don’t support my platform.

A point of view I’m beginning to agree with…

One difference - I used the tar.gz download, you used the .exe - not sure what the difference is, apart from one is Linux and the other Windows (Wine). I’ve used the tar.gz successfully before, when upgrading my op-sys, but I’ve never used the .exe .

eta: - I know Linux is officially ‘unsupported’, but it has quite a few Eve users - have we heard anything at all from CCP on this issue ?

Show the stats on “quite a few eve users”, I too want to see them.

If it was “quite a few eve users” they wouldn’t treat us like second rate customers.

we need to stop them getting away with this, stop paying until they officially support Linux, natively. Like MacOS.

They’re not published (I wonder why ?), I’m just going by forums posts and online conversations over the past couple of years…

Only one way to find out, withdraw all funding if you run Linux.

See if it matters and they care then.

Watch the user charts on eve offline site

Don’t fund them, don’t log in.

We can find out, and force support if there is a sizable impact.

A month boycott by Linux users, will do the trick.

Reinstall the Game.
Cancel the Launcher-Update.
The Game will run fine then.

I copied the Launcher-Directory just for the case i accidently forget to cancel the Launcher-Update. If i do, i can simply overwrite the new Launcher with the old one.

It would appear that the instructions in The Eve University Wiki page Installing EVE on Linux no longer work either. I’ve used these instructions on both Mint 17.3 (multiple machines) and Mint 19 successfully. I created a new disc partition and did a fresh install of Mint 20.1 Cinnamon on it, then tried installing Eve as per the above instructions. It appeared to install OK, but trying to run the launcher gave the following error :-

user@Desktop:~/evelauncher$ ./evelauncher.sh
Settings path:  "/home/user/.config/CCP/EVE.conf"
Valid language not found in settings.
Checking system language  "en"
Language selected based on system locale:  "en"
QObject::startTimer: Timers can only be used with threads started with QThread
/home/user/evelauncher/./evelauncher: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers
user@Desktop:

I don’t think I’ve ever actually installed it via Wine using the .exe file, I suppose that’s the next thing to try… Has anyone here done that on Mint 20.1 ? Is there a write-up anywhere ?

Yes, I have always ended up using the windows version for two reasons, although I have tried out the various Linux attempts over the years.

One is that they stopped updating the Linux version a long time ago. (Which of course this time the update to the windows version is the problem now). The Linux support while welcome when it came over the years was off and on. Before the update that forced the 64 bit version I actually had the same install from when I started Eve. Even when I went to a new computer I just copied the folder and ran the repair tool, never having to redownload the whole game.

And two, there was a time where they packaged wine with the download which while it tried to make things easier, kept the wine version lagging behind the latest one. I don’t like having multiple versions of wine on my machine and I have always had the best results with the 100% Windows game version and the latest wine from wine hq.

I wonder if they can reliably glean this information. I remember reading somewhere that wine intentionally by default does not show the application that it’s being run under wine so that companies can’t intentionally block wine (other than some nasty DRM or “anti cheat” garbage). if this is the case, then perhaps many Linux users show up as windows users. They could get those numbers by having things like a native launcher but if the continued support and quality isn’t there then many Linux users will just use the windows version and call it a day.

Never thought I’d say this but - I’ve just cancelled my Omega subs due to the lack of any CCP acknowledgement that this problem even exists. I’ve being paying 3 months ahead, so it’s 5 advance-months wasted across my 3 accounts. Even if they fix it I shan’t be paying more than 1 month at a time in future (trust lost is not easily regained).

Question - people keep saying ‘reinstall the game’, presumably meaning the Windows version. I’ve never installed a Windows program into Wine (I only have it for Eve), so how exactly do I do this ?

Well your using an unsupported os and it’s right after an update that broke stuff for the supported os’s users. So expect nothing but if they do acknowledge it then likely it will be after fixing the issues for the supported users. Devs cost money so they will focus their money always on officially supported os and not unsupported users.

Unfortunately that is the trade-off when using Linux. At least CCP for the most part has kept the game working in Linux under wine even if there are hiccups once in a while. Some other game companies design their games such that there is no hope of them ever working at all or ban Linux users if they catch them. Which would you rather?

I am running the Lutris (Windows) Version. I simply reinstalled it and then did this:
The Launcher in the Lutris Version is a week old. That’s perfect.

After Installation i copied ~/Games/eve-online/drive_c/EVE/Launcher to a safe Location.
Then i started EVE. The Launcher downloads the Update. I cancel the Update and start the Game.
Everything works just fine as long as i don’t update the frickin Launcher.

Just in case i accidently don’t abort the Luancher-Update i have a secure Copy of the old Launcher. I can simply replace the new one with the previously secured one.

Atleast this is working perfectly for me.

To go back to my original question - How do you install windows software on Linux ?
Also, what Linux are you using ?

It’s their right to support whichever OS they choose. It’s my right to decide if I want to subscribe, and to complain when they no longer unofficially support stuff they’ve unofficially supported in the past (e.g. CCP Snorlax).

You tried the installation from the linux launcher using the Uni Wiki instructions. Maybe you have the same problem which i have described here Linux Installer not creating conf files It’s the same error again and again, i’m tired to repeat myself.

The linux launcher work on my installation with one bug: he never stop his initiated processes (namely QtWebEngine processes) after i have close him but this can be handled with killall evelauncher at this time.

I use the Windows Version of EVE using Lutris and POP OS.
To install the game just register with Lutris, search it and click download.
It will install automatically.

Thanks Neo but i prefer the linux launcher because the windows launcher looks for me like a foreigner on my desktop. I like the same look and feel on all desktop applications so far as possible. :slight_smile:

P.S. Maybe i should open a new thread here about my project at AUR evesetup (don’t be afraid thats on AUR, the sources includes build scripts for other linux distributions than Arch based ones) The old thread is closed in the meantime Eve Installing