Launcher crashes after today's update(SteamPlay Linux)

I’m using gentoo, intel/mesa drivers, wine-staging-6.1 (gallium-nine-standalone/dxvk work along with standard wine builtin directx), and normally dx9 and 11 both work well; dx9 with gallium-nine works amazing.

I’m on Mint 17.3 Cinnamon atm. I got Eve working on Mint 19 fairly easily, and I’m now about to install the latest long-term release, Mint 20.1 . It’ll be a case of reinstalling everything as there’s no upgrade path (which is why I’ve been putting it off…). Perhaps I should just ‘bite the bullet’ and get on with that instead of messing with Eve versions on 17.3.

Depending on your GPU, with intel integrated and mesa drivers (radeon open source is mesa also) those driver versions can be the difference between working and not; same with the kernel side of the drivers. Getting the latest version is probably a good idea, don’t have any experience with Mint or it’s repos though.

It’s pretty old hardware (although 64-bit) but Eve has worked OK if I stick to DX9, so I don’t anticipate any great problems in that respect.

It really depends on the hardware; with my setup mesa 21 has bugs, mesa 20 does not; and mesa 19 I think I couldn’t get dxvk to work at all, constant flicker/vsync issues, only worked with wine built-in dx9, blackscreened with dx11; upgrading to mesa 20 solved most of my issues; and gallium-nine/mesa 20 is the only setup that doesn’t show black icons for half the blueprints lol.

Edit: Moral of the story is once you find something that works, BACK IT UP lol; and when your upgrading drivers/wine/dxvk/gallium-nine/mesa/kernel do it incrementally so you can easily test and revert.

It all worked OK under Mint 19.3, so hopefully I shouldn’t have too many problems. :crossed_fingers:

The windows extract file didn’t work * so I thought I’d try the old Installing EVE on Linux - EVE University Wiki instructions (which I’d used before successfully). There doesn’t appear to be a wget https://binaries.eveonline.com/evelauncher-1850297.tar.gz , does anyone know what the latest .tar.gz is ?

  • Am I supposed to Open it with the “Wine Windows Program Loader” or the “Archive manager” ?

You use Linux, you’re suppost to know everything, you’re suppost to be able to build it with some duct tape, a used loo roll, 2 matchsticks and some wire to turn it into a helicopter

I probably could have 10 years ago - my birthday today is for a rather high number of years, and the memory isn’t what it once was…

Linux native launcher thread is here
https://forums.eveonline.com/t/linux-launcher-key-details/159751/3
it’s a different ball game, like I said I’ve never gotten it to work on gentoo but I didn’t try very hard, wine has always worked well.
You open it with archive manager and extract, you don’t run the launcher with wine in that case it’s a linux native launcher (but the game still runs in wine, the launcher just pulls in it’s own specific version of wine)

Thanks - although I see that Tar hasn’t been updated since last July :frowning:
Worth a try though, I’ll see what happens.

No good, missing a stack of libraries :frowning:

eta: Thoroughly pissed-off with CCP now, going to go and get drunk for my birthday instead.

Get hammered and have a good time; in a day or two there will be a clearer picture of what’s going on and how to fix it and/or hopefully CCP just fixes the launcher.

The issue is deeper, in that even if you fix the dll overrides you’ll still have a problem as then you won’t be able to connect to the network.

There is a patch on github for wine from 5 days ago that fixes the problem in the netprofm.dll in the connection_GetAdapterId() function.

Link →

Yes, this means if you want to use this patch you need to re-compile wine (for the moment, it will probably be included in a devel release soon).

1 Like

Linux Mint Mate 20.1 here

Wine Lutris 6.0 STABLE

Doesn’t Work Here

sorry but i don’t understand many things in your message and i have a few questions

  1. When you say “backup of shared cache folder” you mean manually saving that folder and restoring it after old launcher install?
    in case answer to first question is “yes” → 2) Is needed any further tweaking after old launcher install and restore original folder?
    In case answer to first question is “no” → 3) That backup is done from the game or from the launcher that doesn’t work? There is any way to maintain game settings without that backup?
  2. How do you achieve to not redownload when you have the backup? if i try to run the old launcher there is no option to not doing it.
  3. How do i “open settings in launcher” if launcher doesn’t work?

This sounds more complicated than it is.
There are 3 places eve stores data.
Folder A - The launcher folder, this contains the launcher itself, it’s what is installed after installing the launcher.
Folder B - The shared cache folder, this is where all the real game data is, the 20GB download that the launcher downloads.
Folder C - User data, this is where the user’s settings are stored, and login information.

Folder A is located whereever you tell the launcher to install.
Folder B is configurable in the launcher settings, I believe it defaults to a folder named “SharedCache” in the same folder as Folder A.
Folder C is located at [wineprefix]/drive_c/users/[username]/Local Settings/Application Data/CCP/

You can re-use both Folder B and Folder C if you revert the launcher to an older version. If you save Folder B, you won’t have to redownload 20GB of data, if you save Folder C, most of your settings will be preserved (your account login information being one of them).

To reuse Folder B with a different Folder A; just open up the launcher, go to settings and change the location of the shared cache folder, or copy it over to the location listed.
To reuse Folder C, you’ll have to copy the Folder into a new wine prefix (if your using a new prefix for the old launcher install); if not, Folder C will still be there and will be used automatically.

On first launch the launcher will start downloading the actual game data into Folder B; at this point, you can go into settings and change the location of the shared cache to your backup. This will not take effect automatically, the launcher will continue to download new data, you must restart the launcher for the new Folder B to be recognized. After restart, it will see the data is already there, and you won’t have to redownload everything.

I didn’t have to back up anything. All I did was download the old launcher file and run it. It asked for install location and I picked the same eve folder (which I ignored the warning that an install was already there). I picked the same shared cache location as I already had. It overwrote the new launcher and then I was able to launch eve with the cache and settings intact as long as I refuse the update every time I open the launcher.

Sorry - for clarity, exactly which file was this ? When I tried that I got a load of error messages of the form :-

  • /home/user/evelauncher/./evelauncher: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20’ not found (required by /home/user/evelauncher/./libQt5Qml.so.5)

You know you can use ~ or $HOME instead of replacing your path with user (actually you can even have a different username and home folder id completely too).