Launcher Crashes w/ version 1889623

With the latest update my launcher loads the CCP logo, adds the taskbar icon, and then does nothing else. When I mouse over the taskbar icon it vanishes. I’ve uninstalled and re-installed several times and that hasn’t fixed things. It’s been working fine for months, including this morning. Any help would be appreciated. Thanks.

Howdo, please try clearing your launcher cache files as directed here:
Troubleshoot - Launcher starts but then closes or gives a dll error on start. – EVE Online

1 Like

Hey there! I have tried these steps and it seems to still be crashing upon attempting to update for me as well.

Here are the items I have tried:

  1. Attempt to launch in administrator mode.
  2. Update video drivers
  3. Reinstall the game
  4. Delete Launcher Cache using your above steps
  5. Install x86: vc_redist.x86.exe listed under “Workaround for users not using Windows 10 where deleting the cache did not work.” (Just in case for some reason this worked anyways)
  6. Attempt to install STEAM version of game to test if it worked. It also crashes for me.
  7. Use REVO uninstaller to nuke it from my computer completely.
  8. Restore to a previous system restore point where it worked previously.

I am running:

Microsoft Windows 10 Home 64 Bit
AMD Ryzen 5 5600X 6-Core Processor
16 GB 3600 MHZ Ripjaws Ram
B550 Tomahawk Motherboard
500 GB SSD

Latest and up to date drivers from GeForce Experience.

If you can think of any items that I may have not covered I would love to try them out to see if I can get it working again. I was playing the game yesterday before the update and it seemed to be functioning fine, not sure if that is related.

I really appreciate you (whoever is reading :slight_smile: )taking your time to read through this and help us out. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.