Launcher Fails to Launch

The most recent launcher update (not sure which one, but at some point in the past week) seems to have created an issue where the launcher simply fails to open. I never get the spash screen, the executable, nothing. The only other time I have seen something like this is when Eve still has a process running for some reason, and killing it in task manager fixes it, but in this case, no task, no process, restart didn’t fix it.

A full reinstall did fix it, although obviously that also led to having to re-do a lot of settings and launcher groups. I can’t imagine that the primary fix for a launcher error is intended to be a full clear and re-install, so I wanted to put this up to see if 1) other people have seen the issue, and 2) if others have, what solutions worked?

1 Like

I had the same problem the last couple of days after the launcher updated and broke itself. The launcher would not run. No error messages, just nothing.

I wanted to find out if there was a solution that did not involve re-installing anything, so I filed a support ticket. After 2 days I got a “real gem” of an answer from CCP: For them to find out why the launcher won’t run, I must click on the gear icon in the launcher… (double facepalm…)

That’s when I gave up on their support and decided to re-install the launcher. Luckily it is a small download and very quick install. You don’t need to download the giant game files again - just make sure you move the SharedCache folder as instructed. Also luckily it seemed to keep all my launcher and ingame settings and preferences, window positions, overview settings, etc.