Launcher - using ccp-master dev - VSYNC ignored


(Forlorn Wongraven) #1

I am using the dev version of ccp-master wine with ccp’s linux launcher. Every wine version higher than 1.9.10 ignores the ingame VSYNC setting and any other oog way to enable VSYNC. My main issue is when docked in any station or citadel the FPS goes up to 300 and my GPU is going on full speed for core and memory. Any suggestion would be appreciated.

VGA: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev cf)
OpenGL driver: radeonsi
Kernel driver: amdgpu
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: X.Org (0x1002)
Device: AMD POLARIS10 (DRM 3.15.0 / 4.12.4-1-ARCH, LLVM 4.0.1) (0x67df)
Version: 17.1.5
Accelerated: yes
Video memory: 4058MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 4.5
Max compat profile version: 3.0
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD POLARIS10 (DRM 3.15.0 / 4.12.4-1-ARCH, LLVM 4.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.1.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL version string: 3.0 Mesa 17.1.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.1.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10


(Ravow) #2

First, your card have native D3D9 support on Linux, you should NOT use CCP Mesa, you should use a nine-patched wine (Native D3D9 is better than D3D9 converted to OpenGL on the CPU) and enable it in the EVE launcher (ping me if you can’t find how).

Not only it might double your FPS but also if you enable interval one/vsync, it kind of work (some people get 60fps, some people when using 4K, like me, get 30fps. What ever, it work better and lower the load on your CPU and also lower power usage.)


(Forlorn Wongraven) #3

I never got the custom wine on the launcher to work, some help would be appreciated.


(Guy Patrouette) #4

I think you need to delete the ~/.eve/wine directory, and check the use custom wine button.


(Ravow) #5

1 - Also, change the wine command to winecfg
then click on any other field (else it forgot the new command) then click ok.

2 - “launch eve”

3 - winecfg will open, go in the staging section and inable gallium nine

4 - go back in launcher settings and put the command to wine and don’t forget to click on something random after

5 - launch eve for real

Note, you need a patched wine with nine support, it depend of the distribution you have, googling might be required.