Launcher won't launch, "No module named _trinity_stub_deploy'"

A few hours ago I could launch Eve & play just fine. Now, the game client won’t start. Every time I try, the launcher says “Game client assigned to myAccountName has closed unexpectedly.”

In LogLite, I’m seeing errors, including this:

STACKTRACE #1 logged at 11/12/2020 21:27:49 : Exception in stack-trace-all, shutdown bombing

Common path prefix = c:/buildagent/work/d2d8a22a74178531/eve/release/release

Traced at:

/carbon/common/lib/autoexec.py(126) 
/packages/monolithsentry/minidump.py(17) set_sentry_crash_key
/packages/monolithsentry/tags.py(16) get_tags
/packages/monolithsentry/tags.py(84) get_client_tags
/packages/gpuinfo/__init__.py(1) 
/packages/trinity/__init__.py(33) 
/packages/trinity/_singletons.py(14) 
/packages/trinity/_trinity.py(100) _ImportDll
/packages/trinity/_trinity.py(53) _RobustImport
/packages/trinity/_utils.py(9) Quit
/packages/logmodule/__init__.py(618) Quit
reason = 'Failed to import _trinity_stub_deploy ("ImportError(\'No module named _trinity_stub_deploy\',)")'

Thread Locals: session was None
Stackhash: -110200354
Reported from: logmodule
STACKTRACE END


I'm running on Mac OS Catalina  10.15.7

Any help??

Okay, I don’t know much about macs, so I’m just going to throw some ■■■■ at the wall.

I tried looking up your error message, and everyone that had it was running linux. However, Trinity does seem to be associated with AMD APU’s, so perhaps updating/downgrading (use DDU to uninstall) your graphics driver might help.

Someone else was also asking in another thread if a new mac os update was safe to use (the last one caused people problems). Perhaps you need to roll back your OS update.

You can also try generic troubleshooting steps like verifying file integrity, moving the cache (that way you can restore client settings if it doesn’t fix the problem), and using revo uninstaller to uninstall before reinstalling.

You also might want to file a support ticket now so that you can get in line.

Also, please come back and tell us how you fixed it. Might help the next guy with the same problem.

Same problem, but only on one of my two Catalina-Macs. I’ll file a ticket, I guess. Pertinent info from the log where they differ:

Failing machine (filtered):

info	2020-11-16T12:42:03	8	C:\tq\bin64\exefile.exe	DELTA	blue	Manifest	Verification passed: "root:/bin64/_trinity_dx9_deploy.dll"
info	2020-11-16T12:42:05	8	C:\tq\bin64\exefile.exe	DELTA	trinity	availablePlatforms	Executing DirectXRedist.exe ...
error	2020-11-16T12:42:06	8	C:\tq\bin64\exefile.exe	DELTA	trinity	availablePlatforms	Execution of DirectXRedist.exe failed (exit code 9009)
warning	2020-11-16T12:42:06	8	C:\tq\bin64\exefile.exe	DELTA	trinity	General	Invalid Trinity platform dx9
info	2020-11-16T12:42:06	8	C:\tq\bin64\exefile.exe	DELTA	trinity	General	Using Trinity platform stub instead

Successful machine:

|info|2020-11-16T12:45:17|8|C:\tq\bin64\exefile.exe|BETA|blue|Manifest|Verification passed: "root:/bin64/_trinity_dx9_deploy.dll"|
|warning|2020-11-16T12:45:19|8|C:\tq\bin64\exefile.exe|BETA|trinity|General|Invalid Trinity platform dx11|
|info|2020-11-16T12:45:19|8|C:\tq\bin64\exefile.exe|BETA|trinity|General|Using Trinity platform dx9 instead|
|info|2020-11-16T12:45:19|8|C:\tq\bin64\exefile.exe|BETA|trinity|Main|Trinity (_trinity_dx9_deploy) module starting|
|info|2020-11-16T12:45:20|8|C:\tq\bin64\exefile.exe|BETA|trinity|Main|Trinity is using the regular device|

-Torg

Here’s something that worked: I booted into Recovery-mode and did csrutil disable to disable SIP.

I also flipped some switches before that which had no effect then (e.g. Wine-devl) but are now still active, so YMMV. Let us know if you try disable SIP and it works?

-Torg

Oh lawks, some nice kills and 12h later and I get the same error again :-/

Is it related to connecting via VNC? Starting EVE locally and THEN switching to VNC works.

-Torg