Linux. I know it's not supported

I’ve just started running Linux Opensuse Tumbleweed, and i got in the mood to get back into EVE. It’s been a year…
So after installing it, i started it up… And i can play for a few minutes, but then it freezes up on me. I’ve done several re-installs of Tumbleweed, and i’ve set it up for games, specifically through Steam… But it keeps freezing up on me.
The only other game, i have issues with is X3… And the thing EVE and X3 have in common, is that they both are launched, through it’s own separate launcher ?

Though - The problems are slightly different… In X3 i lose sound, when i minimize the game (Alt-tab). EVE - Just freezes up…

I have a sneaky suspicion that my gaming rig, has a PSU that’s too small… (800W) - I know, sounds unlikely…

But if not that… Then what ? Can you offer some suggestions, or otherwise a form of help ? I’ve reached out basically everywhere i can, and noone’s been able to solve this yet… ?

Moved to Linux - EVE Online Forums

What GPU, Nvidia or Amd and do you have the latest or some up to date video drivers?

Works fine here using proton experimental,.

As for freezing, check the logs for the time-frame when the game freezes, like system logs, start steam using terminal and look for some hints there, also eve launcher logs.

You could also try a different linux distribution based on debian or arch.

Ok. My GPU is Nvidia 3080ti. And everything is updated to the max.
In fact, i just re-installed Tumbleweed once more, because the sound disappeared in my X3… AGAIN… - It’s the only way i’ve found so far to “fix” it… And it’s likely only gonna last a day or two, before the sound goes again…

I haven’t tried with EVE, yet, but i do suspect it will be the same, considdering it haven’t done a lick of difference, in the last week or so, when ever i’ve tried to run it on multible installs…
Logs ? Ok… The ones that you can activate in the EVE launcher? Or, in Tumbleweed? (I’ve heard there’s a way to log activity there?)
But i am new at Linux. Haven’t messed with it for 10-12 years, or more… So i’m still just getting my bearings on the basics…

I’d love to supply you, with what ever info you need, i just need a step by step, on how to do so… ?

Thanks.

So… Just had a game, which ran an amazing 9 minutes… And then froze… But that was to be expected…

I forgot to mention, in the previous post, in regards to Proton - I am running Proton activated in Steam. I’ve tried 8.0 and experimental. But yielded the same result.
I’ve also got gamemode installed, as well as Lutris… As per the video i saw, that showed how to install and run steam, so i could play ALL my steam games…
Otherwise, i would’ve only been able to play aprox 1 in 10 games on my steam…

If anyone have this problem when running under Linux/Steam, here is a workaround to solve the issue:

  1. Increase the max open files in Linux:

Put this line in the file “/etc/sysctl.conf”

fs.file-max = 65536

Put the following at the end of the file “/etc/security/limits.conf”

*               soft    nproc           65535
*               hard    nproc           65535
*               hard    nofile          65535
*               soft    nofile          65535

65535 should be sufficient.

Log out or reboot, and make sure the settings are correct with the commands:

ulimit -Sn
ulimit -Hn
  1. Terminate all processes called “evelauncher.exe” after starting EVE.
    Here is a basic script that should do the job:
#!/bin/bash

for i in `ps ax | grep evelauncher.exe | grep Launcher | awk '{print $1}'`
do
        echo "Killing process $i..."
        kill -9 $i
done
echo 'Done.'

Put that in a file, for example KillEveLauncher.sh and make it executable.

Once EVE is up and running, Alt-Tab to a terminal and run this script, or run it from your file manager.

You can use the command “ps ax | grep evelauncher.exe” before and after running the script to make sure the processes are gone.

Alt-Tab back to EVE and play.

These instructions have been used successfully in Arch Linux. Chances are the commands and filenames will be the same on other distributions as well.

Good luck

PS.
Since evelauncher.exe has been terminated, logging out of eve is probably a bad idea. Instead of doing that I quit eve completely, restart it, and run the script again.

2 Likes

What is your memory and CPU usage look like before and after killing off the launcher processes?

System: 1.5GB mem, 1-5% CPU

System + Steam: 2.4GB mem, 1-5% CPU

System + Steam + Launcher: 7.4GB mem, 1-20% CPU

System + Steam + Launcher + EVE: 10-11.5GB mem, 1-20% CPU

Memory seems high, but pretty stable. Terminating evelauncher doesnt seem to change much regarding mem/CPU.
Steam uses about 1GB, Launcher uses about 5GB! and EVE uses about 4GB of memory.

The game spawns a lot of processes/threads while running, but that could be normal afaik.

I also see a huge number of filehandles and sockets being used by both Steam, Launcher and EVE.
The default max number of handles in Linux is surprisingly low (4096) so I wouldn’t be surprised if that was the culprit somehow.

It’s a shame really, I have been using Wine + the old launcher for the last week and everything is just butter smooth, but to day I was forced to update to the new launcher. That update didn’t work under Wine so now I’m back in Steam + the new launcher territory again :frowning:

The “workaround” described earlier seems to solve the issue at hand but it’s a nasty hack unfortunately.

That is a wildly inappropriate amount of memory for the launcher.

So I’ve noticed the launcher eating up hard drive space recently…I keep deleting it…maybe it tries to open it too or keep tabs on it so growing in memory usage?
Do you have a SquirrelTemp folder in your steam folders? nuke everything in there…I then set the folder to root so that normy user can’t fill it full of crappy temp files.

I made a post about it under launcher - simply launching launcher dumps 350Megs into that folder.

Absolutely. I’m thinking that the launcher may be a debug build which would take a lot of extra memory. I also have a sneaking feeling there is a memory hungry AI going on in there.

Either way, I’m using Bottles with the Caffe-8.21 runner to install EVE now, bypassing Steam. That seems to behave more nicely even though the memory usage is still wild

I do have a SquirrelTemp folder under Steam taking 5GB currently. I also have a SquirrelTemp folder in my EVE bottle with only a small log file in it

With wine staging 9.1 and msdelta installed i am not having similar issues, albeit the RAM usage is still a bit high for a launcher at 2.2GB. All SquirrelTemp folders are empty after 5 days of launcher usage.

1 Like

Unsurprisingly, the launcher update failed on my Wine install - latest wine-dev branch (i.e the one ahead of release rather than staging).
A bunch of Winsock errors. Ho hum.

Steam on Linux runs quite sweetly with the options of
PROTON_NO_FSYNC=1 PROTON_NO_ESYNC=1 %command%

I’ll run that way for now - especially since I can add a KDE launcher direct to Eve Launcher rather than clicking through Steam.

Not had a long session in Steam yet, you get the overhead of the Steam client, but can close the Eve Launcher.
I’m assuming it’s a stable solution and doesn’t go wonky after a few hours.

So far i haven’t heard of anyone able to update from an old installation with wine. Everyone went through a new wineprefix and a reinstall.
I did “winetricks corefonts msdelta vkd3d vcrun2022 dxvk2030” on a newly created prefix and after that used the latest installer from the website.