Login with Eve from launcher instead of each account

When I run the eve launcher I’m getting something new in regards to logging in. Instead of inputting my account name and password in the launcher itself, just today I am now getting a Login With Eve button that when pressed launches a pop up a Log In To Your Account popup. Below are snips of what I am talking about.

Is this normal behavior for the Eve Launcher now? Has CCP done away with entering in your account name and password directly into the launcher in favor of a new login style? Just want to make sure something didnt inject itself into the lanucher to capture my account credentials.

I would advice you to restart the EVE Launcher, if you still get the same thing then Reinstall the EVE Launcher. So, simple answer is; No, that is not normal.
Could possibly be a hijacked version of the EVE Launcher, you should probably send a report to SecurityTeam here: securityteam@eveonline.com.

Thanks for your response ISD_Sakimura.

I’ve been poking around in other threads and another person is having the same problem, also starting today, with the removal of logging in directly with the launcher and instead being shown a “Login With Eve” button that brings up a popup. He is using Linux Launcher while I am on windows 7. I’m beginning to wonder if CCP did in fact change the way the launcher works in regards to logging in and didnt tell us. Or some of us simply didnt see a message CCP released about the change.

Hi @ISD_Sakimura,

Are you absolutely sure that it is “not normal”? This new login seems to have been shown to quite a few people and even though it is unexpected (and a bit suspicious), it looks pretty much as it was described here by @CCP_Avalon. That post also mentions “These changes are now on the release version of launcher as 3090”, which seems to be the version of the launcher as of today.

Someone pushed beta live too early perhaps? In any case, it would be good to see an official announcement/confirmation.

1 Like

And another link about the “Login With Eve” button being new int he launcher today.

Thanks for the link Kebur Valeren. It indeed does look like CCP change the way the launcher login works. Much appreciated.

I’ve got this change as well, and am wondering about it’s authenticity.

Well… they prepared IT some time before: I saw same behaviour on beta launcher previosly.

Yep, same here. It’s odd that it’s not on the latest news feed? Would be good to get official confirmation from CCP.

1 Like

Ok, after reading through the link here.

@Olleybear what you are seeing is the Beta-version of the new EVE Launcher.

Due to the information on the beta-version of EVE Launcher, there are nothing to worry about. I apologize for not realizing that it is was the beta-version, I don’t use it so to me it just looked suspicious. :blush:

1 Like

IIRC, its due to them removing iframes from the launcher (which the login part might have been?).

Thanks for everyones responses. Yes, It would have been nice to have it in a news feed or pinned at the top of the “Eve Launcher” forum.

I believe he is actually seeing the release version 3090 (where login has been changed in line with that beta). Considering that the change is rather significant and, as you said yourself, looks suspicious, having some clarifying topic regarding this update pinned might help indeed …

On a side note, the button “login with eve” in the launcher that is used to login to eve looks slightly odd in general. It would be perhaps less confising (and less alarming) if it was just saying “login” :slight_smile:

Hey guys, just clarifying, the “Login with EVE” button is indeed intended, and was pushed live with UI version 3090 earlier today. And yes, it’s supposed to open up a second launcher window with the login form. :slight_smile:

Some information about why we discarded the iframe & went for this change can be found in this post:

Already have a fix lined up for the "Login with EVE" => "Login"

I have a white window once I put my account name and password after clicking « Login with EVE »

Why use iframes at all?
Can’t you guys make it a native QT windows / linux / mac application?
I’m a Linux user and it seems the new launcher has serious problems for Linux/Mac users.
The main one? It does not work!
just check: White screen after “Log in” press

…it did not work yesterday, it does not work today.
Maybe testing the new launcher on Linux/Mac before deploying would be a good idea next time.
Hopefully somone with knowledge and responsibility can see this and fix it.
A choice of fixing rare iframe bug vs breaking the game for all non-windows users seem rather odd.


I’m having the same problem as well. White window after I put my acc and password.

Same problem here.

The Development version works, but then I get stuck in the Settings/Connect menu in the game.
When I press connect, the Authentication… progressbar starst, but it vanishes after a few seconds.

Some linux users have switched to “Developement Vesion” and they said that it worked and no longer are having white screen.

How does one switch to the development version?
(I am using CCP Snorlacs launcher 1225328.3104 on linux and it has the white screen problem which a few people are also experiencing)