Mac Client Can't Install

After I download the installer and run it, it tells me there is an error. I took a look at the error report and this is what I found

Blockquote Dyld Error Message:

Library not loaded: @rpath/QtWebEngineWidgets.framework/Versions/5/QtWebEngineWidgets

Referenced from: /Applications/EVE Launcher.app/Contents/MacOS/evelauncher

Reason: no suitable image found. Did find:

/Applications/EVE Launcher.app/Contents/MacOS/../Frameworks/QtWebEngineWidgets.framework/Versions/5/QtWebEngineWidgets: code signature invalid for '/Applications/EVE Launcher.app/Contents/MacOS/../Frameworks/QtWebEngineWidgets.framework/Versions/5/QtWebEngineWidgets'

I am running Yosemite 10.10.5.

Bad news, I’m afraid. Your version of macOS is no longer supported. Here are the current system requirements:

Minimum System Requirements:

  • OS: Mac OS X 10.12
  • CPU: Dual Core @ 2.0 GHz
  • RAM: 2 GB
  • Video: NVIDIA GeForce 320m, Intel HD 3000

I have that, but the game still doesn’t run.

Me and a few others.

Yeah, I know there have been a lot of issues with the Mac client- I took a break for a few months, decided to pop back in and found it completely broken for about a month.

I had an issue where the installed launcher would just freeze and never launch the client. What finally fixed it for me was installing Xquartz:

https://www.xquartz.org

But in regard to the OP, I’m not sure that the OS version is causing the issue on the installation, but even if that wasn’t it, the game is no longer supported on that build.