Macbook display on fullscreen stretches vertically hiding the bottom 1 cm of the game

On my 14" M1 Pro Macbook, Eve doesn’t seem to see the top part of the screen with the notch and the menu bar. It is pushing the fullscreen display down from it and below the bottom of the screen so that the capacitor and controls are cut off by the bottom of the screen.

It also doesn’t seem to detect the resolution of the screen properly. The display controls in settings for full screen only offer resolution choices that are not the dimensions of the built in display. In fixed window mode, it only offers one resolution and it is locked. In windowed mode, the resolution is the same as the size I drag the window.

Why does fullscreen not work properly for me? Any suggestions?

1 Like

This happens to me as well, but I don’t remember this happening before the summer.

1 Like

yes been annoying me too - you can fix it by going into windowed mode and then maximising the window to full screen again (using the title bar green button not the eve control) BUT that’s a real pain every time I open the client

Can confirm, same issue here. It’s a bug and I hope it gets fixed soon.


If all goes to plan, we’ll be deploying a change which should fix this problem tomorrow. It will alter the way the window for the client interfaces with the OS.

To explain how the window rendering works:

In full screen mode, there will be a black bar at the top of the screen in line with the notch. As a result, the notch is “ignored”, at the cost of losing a few pixels at the top of the screen. You can still move the mouse cursor into the black bar area.

In August there was a change to allow all of the pixels to be used when ‘fixed window’ was selected. This means that if you have a notch, the client will render around it giving you the most screen estate possible.
The downside of this is that the client still considers this a ‘real’ area, meaning you can move things into the area where the notch exists and you won’t be able to see it. We believe the impact of this is low though, as there are almost no such windows in EVE that could be accidentally placed here and not be seen sticking out. The one noticeable window that has a button covered by default is the F10 map window. However, as soon as this is moved or reduced in size, it becomes visible.

Hopefully the two options above are flexible enough for everyone :slight_smile:


The update for the notch display breaks my eve settings. I run at fullscreen 1440p on the iMac (so I can use the same settings on my Windows 1440p machine). After the update it will always start at fullscreen 4.5k native. Changing the resolution back to 1440p on the ESC works but every restart (or launching another client) the client goes back to 4480x2520.

Thanks. We’ve just got a repo on this and are working on a fix.

1 Like

The fix is taking a bit longer than we would like. We’re aiming for a deployment early next week to resolve this.

1 Like

Issue is fixed on my client thanks to today’s update. Very much appreciated!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.