Mail ESI Question


(Fecal Matters) #1

Quick question!

Trying to use the /v1/characters/{character_id}/mail/ endpoint to send my Alliance a mail. I am a member of a Corporation of the Alliance and have permissions in game to send Alliance wide eve mails.

I am setting recipient_id to the Alliance ID, and the recipient_type to “alliance”. Upon submitting to the endpoint I get a response of 500 Internal Server Error. I can send to characters just fine so I know the endpoint and code is functional.

Has anyone had any luck with this?


(Blacksmoke16) #2

I just tried it out, and it worked fine.

POST Body:

{
  "approved_cost": 0,
  "body": "testing ESI endpoint, disregard",
  "recipients": [
    {
      "recipient_id": 99002208,
      "recipient_type": "alliance"
    }
  ],
  "subject": "Test mail please ignore"
}

URL: https://esi.tech.ccp.is/v1/characters/96377439/mail/

If you can continue to reproduce this issue create an issue here:

EDIT: I see you already did, nice :slight_smile:


(Fecal Matters) #3

Interesting, are you a normal corp member with privileges to send mail tot he alliance, or a director of corp/alliance?


(Blacksmoke16) #4

The character I tried it with only has Rent Office station service role and view/take access to one hanger.


(Fecal Matters) #5

Thanks so much for the help Blacksmoke! I’ll see if I can figure out what I either am doing wrong or have set improperly!

And just to prove I’m not bonkers :wink: Here is the JSON I’m sending

{ "approved_cost": 0, "body": "test body", "recipients": [ { "recipient_id": 99005688, "recipient_type": "alliance" } ], "subject": "test subject" }


(Blacksmoke16) #6

Yea good luck mate, that JSON looks ok so not quite sure.

Might be due to something with the roles of the character or something? Have to see what CCP says on your bug report.