New launcher and Vanguard?

Hi folks,

Has anyone tried the new launcher manual update for Vanguard?: (the executable) ?

Looks to be an exe run to update the launcher which you need to do in the same lutris/prefix.

The executable will complain that it needs to run as a standard user, not Administrator, so I believe the runas.exe command is needed…

(Im running wine / lutris-ge-lol-7.0-5)

To install use proton 7.2-2, this will not complain about the “run as user”.
Then you can switch to whichever version you want.

May you link the version you are using?
I can’t find Proton 7.2-2 on Steam. Version 7.0 is available but does not work.

I also tried 7.2-GE-2 and this one actually starts, I can see the big EVE logo, but it crashed immediately after.

If anyone has a solution please post it, I am still unable to launch the new installer, no idea what to do anymore.

Edit: I found out 7.2-GE-2 is able to unpack the launcher binaries before crashing it seems. If you started it from Steam you should find a new numeric directory in ~/.steam/steam/steamapps/compatdata/

Inside the new folder you should see pfx/drive_c/users/steamuser/AppData/Local/eve-online/eve-online.exe
You can now start this eve-online.exe file with Proton Experimental.

Still not sure everything is working, but this is as far I can get

Edit: It does seem to work. Client was downloaded and runs normally.

Edit: Even more easy. If you use Steam just install Eve from the Steam store. You can use “TheInvitation” as code to unlock the beta launcher. The Steam version of the launcher works out of the box with Proton Experimental. It will create a new steam-bound account, but you can add your other accounts without issues.


Don’t know about steam, I’m using Lutris. I have used 7.2-GE-2 to install the launcher then switched to GE-Proton8-21.

Yeah, once you get to the EVE logo the launcher should be installed. Set the target to the eve-online.exe and you’re good.
Also monitor the SquirrelTemp folder in Appdata/Local and set it to read-only if it’s getting bigger every time you start the launcher.

1 Like

Thats great news Sir Constantin!

Im also using Lutris 0.5.11, installed the launcher with a lower version.
[Edit wine-ge-8-22]

After installing the launcher [1.0.2], I get an EVE logo which stays at that; no change after some hours, with GE-Proton8-21.

[Edit] When switching to eve-online.exe I get the same eve logo and logs monitor for a new launcher update.

Is there anything needed for working directory?

For interest, anyone needing proton options

I have used Wine-7.2-GE-2 to install the launcher(to get to the EVE Logo)
Then switched to GE-Proton8-21

After getting the Eve logo check if the launcher is installed, in AppData/Local/eve-online/ should be stuff like app-1.0.1 or app-1.0.2, packages, eve-online.exe, Update.exe, etc.
In Lutris rigth click on the game, configure, game options, executable, target the executable in AppData/Local/eve-online/eve-online.exe

This worked with the older launcher versions, i didn’t test with 1.01 or 1.02

1 Like

Installing with Wine-7.2-GE-2 worked for me.
Then set the game’s executable manually, and switch to wine-ge-8-25.

Vanguard starts, I can group up with friends, but I can’t join a game due to missing anti-cheat (EAC).

1 Like

Same thing here

1 Like

Update loops

What video cards and drivers work for people?
(RTX 2080 and driver 525.147.05 no joy yet, I think due to not supporting (or a config is incorrect) DX12 and SM6

With nvidia and Mesa (radeon) configured
Dx12 will work if you install vkd3d and dxvk
This is easier to process using Lutris.

To enable the Dx12 option, install the following two text files:
d3d11.maxFeatureLevel = 12_1

d3d11.maxFeatureLevel = 12_1

However, there seems to be no reports of Vanguard running on Linux yet.


Well we do have the first report of it working

launch options

VKD3D_SHADER_MODEL=6_6 %command%

helps on 10x0 cards that do not correctly report the Shader Model with Linux drivers.

Current showstopper is EAC, but that needs to be fixed by CCP.

1 Like

Launching to menu works fine for me, but attempting to get into a game results in an EAC error kicking me before I load in.

Hopefully in further releases we can play.

I can get in for about a minute. EAC kicks me right away the first time, but if I try again it loads in. After a minute or two it gives me an auth timeout and boots me.

Please enable EAC CCP pls pls

1 Like

Hey Lucy, Aradina

Full graphics now working on ubuntu with the same kick out as you describe, when Easy Anti Cheat cant function and boots. Its been about 8 hours of configuration so far, and that many years since Ive played DUST !

lutris GE Proton8-24 and DXVK 2.3 VKD3d v2.9
D3D extras V2 DXVK NVAPI v0.6.4

Lets get behind the Anti Cheat client shipping with Vanguard thread

Game works well enough, solid FPS on high settings 3440x1440 on a Radeon 5700 on the latest Fedora

You get about a minute of game play before EAC kicks you out

1 Like

Which is so silly when Proton supports Easy Anti Cheat. CCP PLEASE, GET IT FIXED!


Yeah. And make the launcher work on Linux (FC38, Wine 8.21)! I got the following when trying to run it:

System: i9-11900K - ARC A770 LE - 32GB DDR4 RAM

Can you please report this to WineHQ?

I will try to find time to make AppDB entry for WineHQ :slight_smile:

1 Like