New launcher... new Linux error?

But, dont I need to install first winetricks? I heard about that but unsure.

Also, I guess that code line would be added to the linux launcher?

I imagine that if its applied to the launcher, all clients I launch would benefit no matter the profile Im using (I run a high details profile for my main, and a more standard medium looking for the other 4 clients).

Nope, you don’t need winetricks if using setup_dxvk.

I do it the other way myself, using winetricks.

Choice is up to you.

Once it’s done it’s done, unless you run each client in a separate prefix? Then you do it for each prefix. Either command modifies the files under the prefix, not the launcher. The launcher runs using the files under the prefix (the files kinda resemble a windows installation).

But then, where does that code go… or I just need to put that on a terminal?

Is this a terminal command or where does it go?

Yes this is a Terminal Command. It will add DXVK to a wine prefix.
A wine prefix is where wine sores all the resources it needs to run a program, in this case that program is eve.
To use this command you need to replace /path/to/eve/prefix to the location of the eve prefix, I think there was a way to open the prefix from lutris.

Thanks for the clarification. I’m a tad confused on the path to eve prefix… is it the path directly into the folder that has the eve.exe? (inside wineenv) or is the simper /home/user/.eve ? (linux launcher).

I just reinstalled lutris (to work on fixing my issues) and there there is an arrow pointing up next to the play button, click on it and go to configure. in the game options tab it lists the wine prefix location. but if you are using lutris you sould have installed the version that uses Valkan and E-sync, which you can check by going to the runner options tab and checking if DXVK and E-sync are enabled.
But if I’m being honest I think you need to poke at things and don’t be afraid to brake stuff in the learning process, rather then posting something that others might think of as to simple to explain on the forums, your running linux poke at it a little.

I’ve already done that in Lutris. Currently my install works using wine 6.14 staging (last time I looked, but wine got updated so probably is a newer version). I tried both lutris versions and none worked, but wine staging works and I can notice the dxvk/vulkan working.

What Im interested in doing is to enable dxvk in my linux launcher, to see if I can get the same performance that I get with Lutris. My Linux launcher installer is not running with dxvk currently, and thus it uses a lot more cpu than the Lutris install (5 clients under linux launcher… I get over 70% cpu usage, and it gets noticeable slower when doing mundane things, whereas with the Lutris one I get 55% cpu usage tops, and its superbly playable. The problem with the linux launcher is that the ALT key gets stuck a lot, when alt tabbing between clients, and this is another advantage that the Lutris option has, I alt tab without worries.

I also have a eve running thru steam (3 separate game folders if you are keeping tabs), and it worked for 2 or 3 days, then something happened before the launcher update and stopped working. I havent tried the custom proton, but so far I find the instructions sort of obscure :wink:

So, its not a matter of trying :wink: or being afraid to break things. I just wanted to get better performance on the linux launcher which clearly doesnt have dxvk enabled. The only other install I’m yet to try is the windows installer but thru wine. I’m only running this one thru Lutris, but with their dxvk/esync old launcher and on Steam with proton.

So, would… /home/user/.eve be the folder or do I have to put the path to the eve.exe (inside wineenv)?

Thanks for your patience :slight_smile: and help.

I created an empty Wine Prefix. Ran the command above.
Installed Eve Installer without winetricks and it installs and runs perfect.
Not sure how I can tell if it is using Vulkan through.

Im confused with the eve prefix… what is it… what defines it… :slight_smile: I suppose I could make another folder and try it…

@Jayren_Folcrom : if you did it with the above command… I would think its enabled. In my case i can compare with another installation that does not have it enabled, and I can see the CPU usage difference between them when running 5 clients, and the way it plays.

Everything worked for me 3 days ago but now the launcher will run but trying to start any account fails.

I’m running Wine 6.16-1 on Manjaro, I’ve tried via lutris, via steam, none of them work. I’ve tried downgrading wine to 6.16, 6.15… nothing. What’s changed?

EDIT: I tell a lie, tried going into Lutris, changing the wine version to 6.16 staging and now it’s working but running a much older version of the launcher. Guess progress isn’t always a good thing…

And be on alert when it tries to update the launcher on Lutris… when it does it stops working ;(

Just checked my setting on Lutris, and its running the 6.16 staging. And its working fine :wink:

Yes it looks like this breaking change is still affecting us. I am very disappointed and haven’t played in a while now. The only workaround is to override cryptopp.dll as described in this thread