New launcher... new Linux error?

What shipped wine client are you referring to? By local wine, do you mean one you built from source separately from the one installed by your distro?

By “shipped” I mean that I set the launcher not to use a custom wine, so it uses the one that resides in ~/.eve/wineenv. By “local” I mean that I have wine-staging-6.18 installed on the system. I suppose that would count as “system” wine.

So you’re talking about the “native” launcher then? If so I’m afraid I can’t really offer any support for that one as I don’t use it. If you go into the launcher settings and toggle on “Launch EVE with LogLite” and see the python stack trace mentioning launchdarkly then it means the library isn’t in the right directory. If not then it could be a separate issue, but the clients are still running fine for me with wine-staging

If I use a custom wine, I see this error:

EXCEPTION #1 logged at 10/14/2021 13:32:17 : Unhandled exception in <TaskletExt object at 0x3b01808, abps=1001, ctxt=None> 

Formatted exception info: ImportError: DLL load failed: Success.

Common path prefix = c:/buildagent/work/d2d8a22a74178531/eve/release/release

Caught at:
<pre>/packages/bluepy/ CallWrapper

Thrown at:
<pre>/packages/bluepy/ CallWrapper
<pre>/carbon/common/lib/ Startup
<pre>/carbon/common/script/sys/ Run
<pre>/carbon/common/script/sys/ _BuildClassMap
<pre>/eve/common/modules/nice/client/_nastyspace/ <module>
<pre>/eve/client/script/parklife/ <module>
<pre>/eve/client/script/ui/shared/fleet/ <module>
<pre>/eve/client/script/ui/shared/fleet/ <module>
<pre>/eve/common/modules/nice/client/_nastyspace/ <module>
<pre>/eve/client/script/ui/shared/ <module>
<pre>/eve/client/script/ui/shared/mapView/ <module>
<pre>/eve/client/script/ui/shared/systemMenu/ <module>
<pre>/packages/launchdarkly/ <module>
__builtins__ = {'AUR': 30,
'ArithmeticError': <type 'exceptions.ArithmeticError'>,
'AssertionError': <type 'exceptions.AssertionError'>,
'AttributeError': <type 'exceptions.AttributeError'>,
__doc__ = None
__file__ = None
__loader__ = None
__name__ = None
__package__ = None
__path__ = None
_make_user_object = None
client = None
client_instance = None
ext = None
get_client = None
imp = None
json = None
logger = None
logging = None
monolithconfig = None
on_client = None
os = None
platform = None
sdk = None
set_user = None

Thread Locals: session was <Session: (sid:1704643283277176450, mutating:0, contextOnly:False, corprole:0x0, languageID:EN, role:0x4000000000000000L, sessionType:5, rolesAtAll:0x0, rolesAtHQ:0x0, rolesAtBase:0x0, rolesAtOther:0x0)>
Stackhash: 1824858896
Reported from: logmodule

That looks to me like the launchdarkly error, but moving launchdarkly_client.pyd one folder higher in the hierarchy didn’t help it.

Any advice?

I think the native launcher might install EVE into different directories than the regular Windows installer does. Do you have a SharedCache\tq\bin64 folder somewhere in the EVE install directory? Also note that the launcher will remove this file after you move it everytime you start the launcher, so make sure you either chmod 444 it or start the launcher first and then copy it.

I don’t generally recommend changing the permissions because modifying game binaries MAY veer into TOS violation territory, but either way would work

The native launcher and the custom wine use two different WINEPREFIX settings, I think:
my system wine uses export WINEPREFIX=/home/elassus/.wine/; The “shipped” wine client uses export WINEPREFIX=/home/elassus/.eve/wineenv/. But I’m not sure why Vulkan would work in the former but not the latter.

Looking at Client start exception after today update - steam [SOLVED] - #33 by Trii_Seo, it looks like the native launcher does some funky stuff and moving only the launchdarkly library may not be enough. You’re probably going to need to move all of the dlls it searched for and failed to find, not just launchdarkly.

Alternatively, ditch the native launcher and switch to wine-staging with the native windows installer. I’m not sure how much longer the native launcher is going to work with upcoming changes to the oauth API

If you’re talking about my case, it’s linux native actually and not proton. I’ll be switching over likely to wine-staging + windows installer since as you mention the writing is already on the wall.

I’ve just been to lazy busy to do it :stuck_out_tongue:

I just tried installing the windows launcher, and I can’t set the install folder because I get a “the selection contains a non-folder object” in the dialogue.
UPDATE: this bugreport includes a patch that’s supposed to fix the issue. How do I apply it?

Wait for wine release or build wine with the patch on your own.

Confirming on my side - arch, wine-staging (6.16) + windows launcher works well with the workaround.

yes, how do I apply the patch? If I copy the patch file as-is into my patches directory, the first part fails. Looking into the directory …/work/wine-6.19/dlls/kernel32/tests/, the file path.c is there, but the lines in the patch file aren’t anywhere around where the patch file says they are.

Any tips?

and while we’re at it (since that day is coming soon) how did you install the windows launcher? I can’t set the install directory, instead getting an error that “selection is a non-folder object”.

The patch doesn’t cleanly apply to current master wine and needs to be rebased due to other changes they made there since the patch was submitted. It should still work if you go to the wine source directory and do git checkout wine-6.19 before applying the patches.

As for your install directory, I’m not sure…I never change it and it just works

1 Like

the default is “C:\EVE”, which doesn’t work for me. I don’t even know where that folder actually is on my system.

It should be towards the beginning of your eve prefix. In vanilla wine it’s $PREFIX/drive_c/EVE

Afraid I can’t be of much help here - installed out of the box without much fanfare.

At this point, all I really did was cut out the old linux native launcher and replace it with windows, since I use the same wine executable (though with a different wineprefix).

What’s funny is that this appears to have fixed crashing issues with the character editor. Seeing what was happening with paths with the old launcher, I kinda wonder what went on there :slight_smile:

CHMOD 444 doenst work anymore hehe, something deleted the launchdarkthing :smiley:

No big deal, I’ll just copy it manually. But I thought it would be good to say…

Update: Mmmmm no, the file is still there, the clients wont load though ;(
Update#2: It’s working and no idea why. The pyd is still there, shows read only, and now the client loaded fine.

im winning

So who do we aim our pitchforks at? I didn’t skill to 5 on pitchforks for nothing… it’s one of the few “trust the rust” skills I’m proud of!

On a side note: I tried installing with Lutris. That failed. But I somehow managed to trick Lutris into making Steam download and install. Which also failed. But bare with… Using Steam revealed some new launcher errors which Wine on its own previously didn’t throw:

  • Execution of DirectXRedist.exe failed (exit code 9009)
  • Failed to load python extension ‘_trinity_stub’ with flavor ‘’
  • bluepy.Terminate - Reason: Failed to import _trinity_stub (“ImportError(‘No module named _trinity_stub’,)”)

IF you do Lutris… with vulkan and esync… dont update the launcher :slight_smile: I hope some day we can, but Im still avoiding the update and its working, just make sure its using the wine staging and not the lutris as those dont work.

Theres also the launchdarkly thingie that has been explained in the Beta launcher thread, which also is working :wink: