Personal Skill Plans - Failed to Connect to Server. Try Again Later

Unable to access personal skill plans. This message has been up for > 2 weeks.

I don’t think they ever solved the issue… When the NMC came online, the personal skill plan was nixxed for a time being… looks like it never got fixed yet.

Just chiming in… have the same problem since I started (have only used the Native Mac client - so can’t say if it worked before or not).

Same here, Steam, Linux, Proton Experimental.

its never worked on the native mac client, when it was brought online, it was mentioned that it was not available right away…

I am on Linux using Proton/Wine, and I started having this issue a couple of days ago. It was working before that. Also, if you are tracking a personal skill plan, and this issue is occurring, the skill window will take about 15 seconds to appear. So I had to untrack my skill plan.

And today it is working again.

It’s been like this since day 1 for me.

On M1 Mac. Personal plans worked for me, but broke 3 days ago (when new patch came out) and now I’m getting failure to connect error. Interesting that it’s different timing for different people.